LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Nvidia driver not recompiling after Suse update (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/nvidia-driver-not-recompiling-after-suse-update-127071/)

wgm 12-18-2003 07:20 PM

Nvidia driver not recompiling after Suse update
 
Here is where it is. I have Suse pro 9.0, I have downgraded the kernel and source code to 2.4.20-62 to allow the use of audio and ACPI on my toshiba 5205-S703. I then compiled the Nvidia driver, and that all went well.

Everything was working good (except the wireless and eth0 battling for DHCP control).
I recently did a patch upgrade to the KDE, a wireless update and some X11 items. Not the kernel updates.

After that KDE would start with a standard driver, "nv" even though XF86config listed "nvidia" as the driver. This gave me no 3d and I could not log back into an x environment more than once per system boot, the screen would get tweaked and I would have to ctrl-alt-backspace to get out.

I have tried to recompile the Nvidia driver but I get the error "Nvidia.0" module cannot load becuase it was compiled with a different kernel.

I used the IGNORE_CC_MISMATCH=yes to get it to work the first time, but it doesn't work this time.

I have tried reloading the kernel source and it tells me that it is already installed.

Help on this please, I feel like every time I try an update I screw myself.

jcookeman 12-20-2003 09:27 PM

How many kernel sources do you have installed right now?

ls -l /usr/src


All times are GMT -5. The time now is 05:20 AM.