-   Linux - Laptop and Netbook (
-   -   notebook screen flicker (

akshunj 08-16-2003 09:33 AM

notebook screen flicker
I just bought an Averatec 3150 subnotebook, and I installed Libranet 2.8. Everything went smooth except until it came time to configure video. It autodetected the video card (S3 ProSavage), loaded the appropriate X driver, and then configured my screen. First off, let me say that I have several linux boxes going and I don't really consider myself a newbie anymore. However, I know squat about laptops. I set the resolution, refresh rates, and all that business, but when X loaded, I was FLOORED by the horrible flicker. This is at a resolution of 1024x768 and refresh rate of 75hz! I know the screen is not defective since Win XP displays well enough. I played around with ALL of the xfree86config file settings, but nothing changed. Then I loaded Knoppix, and I got the SAME thing! Anyone out there experiencing similar issues? I think it probably has to do with the video driver that X loads; perhaps it's buggy? Any suggestions?

--Akshun J

akshunj 08-16-2003 12:22 PM

solution - sort of...
Well, after doing some additional research, it appears as if the S3 Prosavage DDR video card is certainly the issue (as evidenced by anyone who has that card and has posted here!). The Xfree driver "savage" gives buggy support for this built-in card. VIA's site has some advice for several distributions (Debian and Slackware are notably absent) on how to get the drivers running properly, but it didn't look like much when I read it. S3's site only has windows drivers for the ProsavageDDR chipset. So, I took some advice from someone else who posted here with this card. I am now using the generic VESA driver, and now X seems to be running fine. I hope this helps someone else out there. ;)

--Akshun J

jarek 10-22-2003 01:00 PM

re:notebook screen flicker
This might be a bit late, but I found that you can still use the savage X driver, you just need to set option "UseBios" to "off", e.g.

Section "Device"
Identifier "S3"
Driver "savage"
Option "UseBios" "Off"

This seems to fix the flicker problem. This site has some more info on linux-on-averatec.

All times are GMT -5. The time now is 06:56 AM.