-   Linux - Laptop and Netbook (
-   -   NorhTec's new Gecko edubook (sub $200) performance of Xcore86 compares to what? (

SCerovec 11-06-2009 07:12 AM

NorhTec's new Gecko edubook (sub $200) performance of Xcore86 compares to what?
here has a really interesting options:
1. 8x AA bateries 2000mAh rated inclusive (4hr runtime?)
2. fan-less (=sealed to dust)
3. 4x USB (3 out/1 inside)
4. internal 2.5" PATA hdd bay
6. internal+external SDcard slot
7. 1024x600 resolution LED backlit 9" display
8. Internal PSU/charger
9. 512MB DDR2 ram/8GB solid state storage/1GHz CPU/accelereated VGA for $200

unknown is however to what it's actual performance compares?

A. Just how good is the $65 Xcore86 running @1GHz?
B. Can it be overclocked/modded and to what extent?
C. Can it be idled down and how does it interact with Linux's ACPI?
D. Just how usable the LCD on daylight is?

Anyone has such a device?

I took first steps to acquiring some, but like to have some "hands on" of a fellow LG-er.

SCerovec 01-29-2010 03:54 PM

Been there, done that
Hi, I got one Gecko :)

It is at times like a 950 AMD Duron (CPU has MMX) and at times like a P4 on 500Hz (downclocled).

It "depends".

The CPU is Xcore "Vortex86" and the cat /proc/cpuinfo shows:
2000 Bogomips and:fpu tsc cx8 mmc (only)

It is incapable to boot a Slackware smp kernel:
This CPU has no cmov support...

But the non smp (huge.s) works from install on.

After an easy USB booted install (just dump the *.img to a spare USB flash drive) it installed in a pinch (off a FTP as a source)

Of course it would do so if booted off a USB optical device, but i could get one at the moment :)

Besides it took more than 4 hr to unpack a 13.0 (without KDE4) it all went easy and 1st time okay.

a. no APM at the moment (issue to be resolved)
b. no Vanilla kernel support for HDI sound

Battery lasts incredibly long (Yes it's REALLY AA powered - 8cells)
No AC/DC adapter, just the power cord (it's integrated)
It has full QUERY and "Fn" sequence for num-lock - the keys are ~85% of desktop sized.
The touchpad has good sensitivity
The screen has exceptional brightness and reads out good on broad daylight.
The screen pivot is sturdy and holds really stiff, the unit leaves impression of decent sturdiness, the bottom of the case is ~1mm thick Al sheet.
No noise while operation.
Runs Vanilla Slackware (who could ask for more?) and fits a A5 briefcase

here is OEM supported site and forum (just formed)

At Your disposal.
Stevan C.

giraffedata 10-31-2010 11:29 PM

More about Vortex86
Here's some more information about the primitiveness of the CPU. I just got an Ebox 2300 (= Norhtec MicroClient Jr), which has the same CPU model.

I ran into trouble because the CPU does not have the CMOV instruction. CMOV is an instruction that was new with Pentium Pro. All it is is an instruction that does a test and a register move all at once, letting you do in one instruction what would otherwise take a conditional branch followed by a move instruction. It is optional in i686 architecture. When Gcc generates code for i686, it really generates it for Pentium Pro, and, at least with modern Gcc versions, will generate CMOV instructions. Furthermore, Glibc contains assembly language files that use it.

In Glibc 2.2.2, assembly language routines strcmp() and strtok() use CMOV. strcmp() is used by the dynamic loader (, so when I tried to run a system that was compiled for more advanced CPUs (and was running on Pentium II systems), I couldn't run anything at all. The kernel was OK, but Init (the program running in the very first process), which was dynamically linked, wouldn't. What you get is a trap, which the kernel renders as a SIGILL (Illegal instruction) signal.

So basically, you need to make sure anything you run on Vortex86 is compiled for 586 or less.

SCerovec 11-03-2010 10:55 AM

I'm sorry for Your trouble buddy :(

I know from before it lacks the cmov (line #6)...

But I really had done *heaps* of tasks on it and it still serves me well and is my most reliable companion i ever had...

Not that i would hate it had 3D acceleration or twice the MIPS at twice the wattage cost...

But it surely has a delicate balance of power vs performance that makes it quiite usable most of time, never mind the cmov...

Best regards

giraffedata 11-04-2010 01:24 PM

I actually read that line ("this CPU has no cmov support") before I bought the computer. But it didn't tell me what "cmov support" is or whether that was likely to stop me from using it the way I hoped to. I couldn't find any details anywhere else either. So I bought it, did the experiments, and added that information to the thread.

Now I'll either look for a replacement that has CMOV or find a way to run non-CMOV software on it.

The specs I find for Xcore86 don't mention what instructions it has or lacks, but I get the impression that the follow-ons (SX, DX, MX) also lack CMOV. I wonder why this was omitted. It seems like something that could be added without increasing cost or power usage or anything.

I find conflicting information on what other features the CPU might have. The manufacturer says it is 486, possibly just because of the missing FPU. Linux calls it 586, possibly just because of the missing CMOV. Some say it's technically 686 (because CMOV is optional in 686).

It's worth repeating: my Linux kernel, built for "i686", comes up fine on this CPU. Kernels typically exercise lots of a CPU's arcane features. But it's also 10 year old kernel code compiled by a 10 year old compiler.

SCerovec 11-15-2010 11:29 AM

Put that way, You have a point there, I guess?

On the other hand it runs XP (now obsolete software) without a hickup for what its worth...

I guess You should be the right guy to ask following:

Can You say anything regarding the mttr implementation in the Vortex?
And is there anything to be said about it?

giraffedata 11-16-2010 10:36 PM

I need to correct what I said above about an i686 Linux kernel running on this CPU. The kernel I ran successfully was built for 486, not 686. (I remember now building it that way back then, even though I was using Pentium II, because I thought some day I'd want to run it on something like the Vortex86).

And I'd like to add that I found a great way to deal with the lack of CMOV: make the kernel emulate it. The kernel gets the illegal instruction trap when the user space program tries to execute CMOV, then emulates the instruction, then returns control to the next instruction. After I had this idea, I searched the web and found out that Willy Tarreau wrote that code for Linux in 2002. I got it, patched it into my kernel, and it works! The built-for-686 libc runs.

As for MTRR, your /proc/cpuinfo contents posted above indicates the CPU does not have memory type region registers. On a CPU that has them, the "flags" line includes "mtrr".

But that is just Linux's opinion of whether it has MTRRs, which I believe is based on an examination of its overall model identity. So it's conceivable that the CPU has them and Linux just doesn't know it. Either way, you can't use them through Linux.

All times are GMT -5. The time now is 11:55 AM.