LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 12-01-2005, 04:42 PM   #1
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Rep: Reputation: 0
no sound on thinkpad a31


I just upgraded from Suse ver 9.1 to ver 10.0 on my IBM Thinkpad A31 series model 2652-p3u computer and I still do not have any sound. I was hoping the upgrade would fix it, but it does not recognize the sound card.

Sound configuration comes in as Number 0, Card Model ThinkPad T30.

Any ideas anyone have that I can try or what I need to do to get sound?

Thanks
 
Old 12-01-2005, 05:07 PM   #2
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Make sure you have alsa installed. I think you need alsa-base and alsa-utils. Then try alsaconf.
 
Old 12-01-2005, 05:17 PM   #3
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
sorry, but I am not so experienced with this part.

How do I look for alsa to see if installed?

thanks
 
Old 12-02-2005, 07:59 AM   #4
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
You could try just running alsaconf at the command line. Alsaconf is part of alsa-utils, so if you have that then you should have alsa.

If it doesn't work, you need to use your package manager to find out if it is installed. I'm not sure how to do that in Suse.
 
Old 12-06-2005, 11:54 AM   #5
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Did you get it working?
 
Old 12-06-2005, 02:04 PM   #6
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
I did a search for Alsaconf and it did not find it. Not sure if I need to be logged in as root to do it?

RJ
 
Old 12-06-2005, 04:57 PM   #7
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Yes, you need to be root or use sudo.
 
Old 12-06-2005, 05:24 PM   #8
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
well I guess one step closer. I logged in as root, opened up a terminal window, switched to the /usr directory and type alsaconf and a little program popped up that found a sound card. At the end it asked if I wanted to modify some other conf file but I chose "no" because was not sure. Now I have a new entry to the Sound Configuration page in YAST. For model it says Sound Card, but under Number is blank. It also still shows the Thinkpad T30 but under the Number column it shows Not configured. When I try to delete the entry it just pops be back to the base YAST screen. Still no sound either. You got me closer! Anything else I can try?

Thanks,
RJ
 
Old 12-07-2005, 07:52 AM   #9
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Try running alsaconf again and this time say yes. If that doesn't do it, type "lsmod" at the command line and post the output here. We need to see if the module for your sound card is loaded.
 
Old 12-07-2005, 04:26 PM   #10
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
I love you, man! I have sound finally on my A31!

I did what you said and ran the alsaconf one more time and said yes to "Configure snd-Intel8x0" and it went off into it little world for a minute and came back indicating the sound card was now configured. It ran a test sound and all was good. I added a music CD and it played! Tweaked some volume settings and all it good!

I really appreciate your help and always checking back.

Thanks a million!

RJ
 
Old 12-07-2005, 04:51 PM   #11
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Oops, spoke too soon. When I rebooted the sound stopped again. I also noticed I have a little red X over the Kmix speaker icon in the KDE panel and when I move the cursor over it it indicates "mixer cannot be found".

Is there any way to make the alsaconf settings stick?

RJ
 
Old 12-07-2005, 06:52 PM   #12
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Hmm, maybe something with KDE.

This command will look for sound modules that are loaded
Code:
lsmod|grep snd
Here is what mine looks like
Code:
snd_intel8x0           34752  0
snd_intel8x0m          20100  0
snd_ac97_codec         84728  2 snd_intel8x0,snd_intel8x0m
snd_pcm_oss            55712  0
snd_mixer_oss          20480  1 snd_pcm_oss
snd_pcm                98184  4 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pcm_oss
snd_timer              26628  1 snd_pcm
snd                    59396  7 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
snd_page_alloc         10052  3 snd_intel8x0,snd_intel8x0m,snd_pcm
We need to see if you have the snd modules like mine listed above. My thinkpad has the same sound card yours has. If you don't see the intel8x0 module then try
Code:
modprobe snd-intel8x0
Then see if you have sound again

Check if you have a file called /etc/modprobe.d/sound. Make sure it has this in it:
Code:
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
 
Old 12-08-2005, 05:11 PM   #13
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
I ran the command lsmod|grep snd and got back nothing. Then I ran the second command modprobe snd-intel8x0 and the sound started working. I had to use the volume control in the Alsa mixer to turn the sound up on the Master bars.

The I ran lsmod|grep snd again and got this below.

snd_intel8x0 33408 1
snd_ac97_codec 90876 1 snd_intel8x0
snd_ac97_bus 2432 1 snd_ac97_codec
snd_pcm 93064 2 snd_intel8x0,snd_ac97_codec
snd_timer 24452 1 snd_pcm
snd 60420 6 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore 9184 1 snd
snd_page_alloc 10632 2 snd_intel8x0,snd_pcm

If I go and look at the /etc/modprobe.d/sound file it now reads

alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0

But, once I reboot, the sound stops again. I have to go through these steps to get sound again. Is there a "startup" file where I can add the line "modprobe snd-intel8x0" so each time Linux starts it runs this line or is there a better way?

Thanks again!
RJ
 
Old 12-08-2005, 07:52 PM   #14
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
You can add snd-intel8x0 to the /etc/modules file. That should make it load on boot. Also after you set the mixer settings, run
Code:
alsactl store
That will save the settings so you don't have to keep adjusting the volume.
 
Old 12-09-2005, 11:06 AM   #15
txrj
LQ Newbie
 
Registered: Dec 2005
Posts: 13

Original Poster
Rep: Reputation: 0
I added snd-intel8x0 to a /etc/modules.conf file. I did not find just a /etc/modules file, but it still does not auto load unless I type modprobe snd-intel8x0 at the command line. Am I suppose to type the whole command modprobe snd-intel8x0 in the modules.conf file?

I also tried typing alsactl store at the command prompt after I adjusted the volume but it indicated command not found.

Sorry to keep bugging you, but I can feel we are getting close! What can I try next?

Thanks,
RJ
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
frame buffer/bootsplash/ibm thinkpad a31 ic3 Slackware 3 11-01-2005 10:49 AM
Fedora3 on Thinkpad A31 2652Q5U - Wireless Trouble linus24 Linux - Wireless Networking 2 12-22-2004 10:21 AM
IBM A31 Thinkpad and RedHat 9 Video rnutter Linux - Hardware 1 11-13-2004 02:12 PM
Modem trouble in ThinkPad A31 cyberfree Linux - Laptop and Netbook 1 04-18-2004 02:11 PM
Best distro for Thinkpad A31??? Rivitir Linux - Laptop and Netbook 1 10-09-2003 03:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 11:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration