-   Linux - Laptop and Netbook (
-   -   No power management/ACPI on Toshiba Satellite L500D (

Vlinux6 11-30-2010 05:35 PM

No power management/ACPI on Toshiba Satellite L500D
When I try to boot pretty much any Linux on my Toshiba Satellite laptop, I see a whole bunch of ACPI errors and then a kernel panic. Boot fails. When I boot with the option acpi=off, it boots just fine except that cpu throttling, fan speed control, and multi-core support (It's a dual-core AMD Turion Mobile M520)are unavailable. I have tried VectorLinux (slackware based), Ubuntu, Fedora, and BlueWhite64 Linux. None of them were able to make any of the above things work. There is almost nothing about power management or ACPI in the BIOS. Can anybody help with this? I can provide more information if needed. Thanks.

stress_junkie 11-30-2010 06:23 PM

Post #10 at the following address seems to have some advice.

Among other things it says that you need to use a 32 bit kernel. Bunches of other things in that post for this model of Toshiba computer.

jefro 11-30-2010 06:44 PM

Any choices in bios for power management? Might even fall under pnp OS.

Vlinux6 12-01-2010 01:37 PM

I didn't see anything in the BIOS for power management except for CPU frequency scaling which was enabled. I didn't see anything about pnp os either. I have tried both 32 and 64 bit kernels. I even compiled my own kernel and tried adding acpi support modules and stuff but it didn't really help. I would like to get acpi working, but if I can't, I would like a way to idle the cpu and fan so that I could close the laptop up, put it in my backpack, and take it somewhere else without it roasting inside the bag on the way.

jefro 12-01-2010 04:22 PM

Might be an apm laptop and no amount of acpi would help.

Vlinux6 12-01-2010 08:09 PM

If it is apm (which seems a plausible reason), where should I go from there?

jefro 12-01-2010 09:53 PM

Disable acpi in boot.

Vlinux6 12-01-2010 11:25 PM


Originally Posted by jefro (Post 4177704)
Disable acpi in boot.

I've done that already with acpi=off as a boot parameter. How would I get apm working? When I try to run apmd as root, it says "no apm support in kernel". Would I need to recompile the kernel again with apm stuff?

jefro 12-02-2010 04:43 PM

I guess we need to find out more about the laptop before we go farther.

Might try an old knoppix 3.x live cd just to try.

Vlinux6 12-02-2010 08:33 PM

Why the older version?

catkin 12-02-2010 11:36 PM


Originally Posted by Vlinux6 (Post 4177638)
If it is apm (which seems a plausible reason), where should I go from there?

Try building a kernel with Toshiba Laptop Extras. This is under "X86 Platform Specific Drivers"; it is only listed when some other options have been set. Clues in /usr/src/linux/drivers/platform/x86/Kconfig or here.

jefro 12-03-2010 04:25 PM

catkins suggestion is a choice.

I suggested the old knoppix since it was built about that time and may have offered clues to apm or acpi. I still can't tell if either are well supported but the old knoppix ought to boot. Matter of fact the system would seem to me to be new enough to boot anyway on a newer distro.

Vlinux6 12-03-2010 08:31 PM

jefro: I bought the laptop back in June of this year. I will look at Knoppix.

catkin: Thanks, I'll check it out.

sntnlz 12-05-2010 06:57 PM

Faced the same problem when trying to install SuSE or Ubuntu on my wife's then new Toshiba laptop. Amongst the many things I tries was recompiling the kernel which (under Ubuntu) this fixed the ACPI errors and restored functionality to the function keys, the downside was that the NIC started behaving erratically, an endless loop of unpredictable connect/disconnect cycle.

One of the possible explanations I found for not having a permanent fix (this was several months ago and things might have changed) was that in that series Toshiba used H2O bios which according to what I read passes erroneous address information for certain devices/buses which results in a conflict of address assignments which caused s the kernel to 'panic'. Recompiling the kernel with what ever modules that were involved only allowed the kernel to force the correct address assignment (i.e. ignore what the bios was saying) but at the expense of the NIC. Unfortunately after a few days my wife was running out of patience and needed her a functional laptop so I stopped trying and reinstalled the annoying Win 7 which came with the laptop for her.

If your laptop has the H2o bios, you may want to explore this rout further and try to find exactly how it's doing what it's doing wrong and go from there by either looking for a fix (if there is one) or coming up with one yourself.

Vlinux6 12-05-2010 10:07 PM

Thanks. I do have an H2O bios. Do you know which extra modules needed to be included?

All times are GMT -5. The time now is 10:01 PM.