LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 07-19-2003, 10:00 PM   #1
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Rep: Reputation: 15
Netgear MA401RA setup for SuSE 8.2


I have tried everything I can think of, and I still cannot get this to work. I have scoured this and other newsgroups looking for help and insight. I have followed the troubleshooting section of the SuSE support database article about PCMCIA wireless cards. Nothing gets this working.
Can someone who does have it working post step-by-step instructions for this?
Just for the record the output of iwconfig is:
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

eth1 IEEE 802.11-DS ESSID:"" Nickname:"Prism I"
Mode:Managed Access Point: 00:00:00:00:00:00 Bit Rate:11Mb/s
Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0/92 Signal level:-68 dBm Noise level:-122 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I have tried setting the ESSID in YAST, but it doesn't seen to stick.
Any help would be greatly appreciated.

Zane
--
The box said "Install Windows98 or better", so I installed SuSE Linux.
 
Old 07-19-2003, 10:17 PM   #2
mnain
LQ Newbie
 
Registered: Feb 2002
Location: Maryland, USA
Distribution: Mandrake 8.1
Posts: 8

Rep: Reputation: 0
I use a Dell Inspiron 1100 with a Netgear ma401 pcmcia wireless card, all I had to do was

ifup wlan0

This gets me an ip address. I had to set the route manually. The netgear ma401 works very well for me and I like its range.

If you still face problems I could email you my config files.

My reply email : mnain@yahoo.com
 
Old 07-19-2003, 10:30 PM   #3
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Original Poster
Rep: Reputation: 15
mnain,
I tried your suggestion and here is the output:
ERROR: command 'iwconfig eth1 mode Automatic' returned
Error for wireless request "Set Mode" (8B06) :
SET failed on device eth1 ; No such device.
ERROR: command 'iwconfig eth1 nick Prism I' returned
Error for wireless request "Set Nickname" (8B1C) :
SET failed on device eth1 ; No such device.
ERROR: command 'iwconfig eth1 essid ZAVNET' returned
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device eth1 ; No such device.
Could you email your config files?
zvan@sbcglobal.net

Zane
 
Old 07-19-2003, 11:28 PM   #4
mnain
LQ Newbie
 
Registered: Feb 2002
Location: Maryland, USA
Distribution: Mandrake 8.1
Posts: 8

Rep: Reputation: 0
zvandiver

Can you send me the output of /sbin/lsmod, this will dump the currently loaded modules. The output of /sbin/lsmod should have lines such as :

prism2_cs 63324 1
p80211 15860 1 [prism2_cs]
ds 6604 1 [prism2_cs]
yenta_socket 9760 1
pcmcia_core 41824 0 [prism2_cs ds yenta_socket]

Do you have a line in the /etc/modules.conf like :

alias eth1 prism2_cs

I had to add this to the /etc/modules.conf file. Once this is done, restart networking by '/etc/rc.d/network restart'

Hope this helps.

Madan
 
Old 07-20-2003, 12:24 PM   #5
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Original Poster
Rep: Reputation: 15
Madan,
Here is the lsmod dump (I deleted irrelevant parts).

orinoco_cs 4436 0 (unused)
orinoco 31188 0 [orinoco_cs]
hermes 5924 0 [orinoco_cs orinoco]
...
ds 6604 1 [orinoco_cs]
yenta_socket 9760 1
pcmcia_core 41824 0 [orinoco_cs ds yenta_socket]
...

I added the alias line to the /etc/modules.conf file. When I restart the network I get a set mode error as follows:
eth1 ERROR: command 'iwconfig eth1 mode Automatic' returned
Error for wireless request "Set Mode" (8B06) :
SET failed on device eth1 ; Invalid argument.
(DHCP) . . . . IP/Netmask: 192.168.0.4 / 255.255.255.0 ('dhcppc3')
The card appears active-the green light is steady and KWiFiManager shows it up and running. I am getting a "Unreachable Host" message when I ping the router. I did set the router's IP as the default gateway.
This is the dump from iwconfig:
eth1 IEEE 802.11-DS ESSID:"ZAVNET" Nickname:"Prism I"
Mode:Managed Frequency:2.412GHz Access Point: 00:30:AB:15:56:1D
Bit Rate:11Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:92/92 Signal level:5/153 Noise level:107/153
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Thanks for the help so far. You have gotten me farther than anyone.
Zane
 
Old 07-20-2003, 05:39 PM   #6
mnain
LQ Newbie
 
Registered: Feb 2002
Location: Maryland, USA
Distribution: Mandrake 8.1
Posts: 8

Rep: Reputation: 0
Zane,

From the above I gather that the router is assigning you an ip address, it also shows me that your current ip address is 192.168.0.4 which would mean that your router net is 192.168.0.x, please try to ping the router i.e. ping 192.168.0.x where x is your router ip addess.

You can also try /sbin/route which will dump your current routing table, it should have a default gateway.

can you ping the currently assigned ip address i.e. ping 192.168.0.4.

Hope this helps.
Madan
 
Old 07-20-2003, 06:45 PM   #7
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Original Poster
Rep: Reputation: 15
Madan,
The router does assign the address 192.168.0.4. However, I cannot ping the router. The router address is set as the default gateway. Which mode should I try to set for the card? I have tried Ad-Hoc(seems to be the default), managed, and automatic. Automatic often gives error messages-Cannot be SET.
If I try ifdown eth0 and do not disconnect the cable, it seems that eth0 is still active. If I disconnect the cable and ifup eth1, I cannot ping the router at all.
If I ping the card from another computer, it shows it active. If I ping the card with the eth0 cable disconnected, it is unreachable. Is there some kind of conflict with the eth0 interface? The internal ethernet card is a National Semiconductor card that was configured by the installation routine.
Zane
 
Old 07-20-2003, 09:40 PM   #8
mnain
LQ Newbie
 
Registered: Feb 2002
Location: Maryland, USA
Distribution: Mandrake 8.1
Posts: 8

Rep: Reputation: 0
Zane,

Can you please send me the output of /sbin/route which will list the order of packets send and where they are sent.

Thanks
Madan
 
Old 07-20-2003, 09:45 PM   #9
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Original Poster
Rep: Reputation: 15
Madan,
Here is the output of /sbin/route:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
192.168.0.0 * 255.255.255.0 U 0 0 0 eth1
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth1
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

Zane
 
Old 07-21-2003, 12:42 PM   #10
mnain
LQ Newbie
 
Registered: Feb 2002
Location: Maryland, USA
Distribution: Mandrake 8.1
Posts: 8

Rep: Reputation: 0
Zane,

Can you please try the following command which disable eth0, assuming you do not have a ethernet cable connected to the built in ethernet interface. The command must be executed as root

ifdown eth0

Next dump the /sbin/route, you should not have eth0 listed in that output. Now try to ping your router i.e. ping 192.168.0.1

Hope this helps.
Madan
 
Old 07-21-2003, 03:04 PM   #11
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Original Poster
Rep: Reputation: 15
Madan,
I disconnected the cable from the built in ethernet and issued the ifdown eth0 command. The /sbin/route output was exactly the same, except it took several seconds longer to run. I am thinking that there is a problem changing the ethernet connection from eth0 to eth1, although each is assigned its own IP address by the router. For some reason the eth0 connection cannot be turned off. During boot up, I get a message that initialization of eth0 failed, but I can directly connect without doing anything more.
I am using a Compaq Presario 2170. Of course WinXP handles the wireless issue without any problem.

Zane
 
Old 07-21-2003, 05:03 PM   #12
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Original Poster
Rep: Reputation: 15
Madan,
A follow-up idea.
Could there be a problem with the Mode setting? If I set it to anything except ad-hoc, I get an error message saying there is an invalid argument.
ERROR: command 'iwconfig eth1 mode automatic' returned
Error for wireless request "Set Mode" (8B06) :
SET failed on device eth1 ; Invalid argument.
I have turned off access filtering on my router, but I did list the Netgear MAC as an allowed card. In ad-hoc mode the wireless and the builtin cards seem to be only talking to each other. The wireless cannot connect to the router.
Could this be a SuSE problem in some of the network packages? I will post to the suse-linux-e list and see if I get any responses.

Zane
 
Old 07-22-2003, 09:30 AM   #13
mnain
LQ Newbie
 
Registered: Feb 2002
Location: Maryland, USA
Distribution: Mandrake 8.1
Posts: 8

Rep: Reputation: 0
I get the same errors you mention, I leave everthing as default, I can ping the router. I can also surf the web from anywhere in the house. Suse seems to have problems with wireless. I've used Mandrake 9.1 and Redhat 9.0 these work very well. I used Knoppix on my notebook and it detected the wireless card and got an ip address from the router.

Do you have Knoppix ?
Madan
 
Old 07-23-2003, 05:00 AM   #14
ajs
LQ Newbie
 
Registered: Jul 2003
Distribution: Redhat / Suse / Debian
Posts: 4

Rep: Reputation: 0
Suse 8.2

I have got exactly the same problem with Suse 8.2 - I have changed all sorts of things and I still can't get it going - it is very dissapointing. It really winds me up that Suse doesn't adhere to some of the other distributions standards (I mean 'eth-pcmcia' when you configure your wireless pcmcia card - no wonder ifconfig eth-pcmcia etc. doesn't work ...) Well I give it another week or so and then switch back to Redhat 9, which meant editing three files and it worked flawlessly !!!
 
Old 07-23-2003, 10:46 AM   #15
zvandiver
Member
 
Registered: Jul 2003
Distribution: Kubuntu
Posts: 83

Original Poster
Rep: Reputation: 15
I finally got my wireless card to work. I followed the instructions in the SuSE support database article, and made the recommended changes to get the orinoco module to load instead of the prism2 module. I also got help from Ralph Sanford through the suse-linux-e mailing list.
I did not set up the card as pcmcia, but just as wireless. YAST named the card eth1. I modified the /etc/sysconfig/network/ifcfg-eth1 file as follows:
BOOTPROTO='dhcp'
DHCLIENT_SET_DOWN_LINK='yes'
MTU=''
REMOTE_IPADDR=''
STARTMODE='hotplug'
UNIQUE=''
WIRELESS='yes'
WIRELESS_ESSID='mynet'
WIRELESS_KEY=''
WIRELESS_MODE='managed'
WIRELESS_NICK='Prism I'
WIRELESS_NWID=''
CHANNEL='1'

The hotplug option prevents the system trying to initialize the eth1 connections before the pcmcia service is started.
After the system is up, I issuse the following commands as root:
ifconfig eth1 up
dhcpcd eth1
Everything is then up and running.
Thanks to everyone who helped me through this.

Zane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
netgear ma401RA and knoppix or phlack harddriveless Linux - Distributions 0 05-25-2004 02:18 PM
Netgear MA401RA WLAN problems samhogue Linux - Wireless Networking 0 04-07-2004 10:53 PM
Configuring Netgear MA401RA with RH 9 lil_zaphod Linux - Networking 2 11-19-2003 10:28 AM
Netgear MA401RA in Mandrake jamminjj Linux - Networking 0 02-15-2003 03:45 PM
yet another netgear MA401RA thread ufd163 Linux - Networking 0 02-11-2003 09:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration