LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 09-13-2010, 12:43 PM   #1
CapnStank
Member
 
Registered: Oct 2009
Distribution: Fedora, HPUX
Posts: 31

Rep: Reputation: 2
Need help extending battery life


I've started running Fedora 13 as a dual boot option on my custom built laptop and notice that my battery life runs out in less than an hour... EDIT: After a bit of research from the OEM I found that it is a Compal laptop.

The computer is dual booted with Windows which gets well over three hours so I know its a configuration issue with the laptop.

The only real information I can provide is from PowerTOP
Code:
Cn                Avg residency       P-states (frequencies)
C0 (cpu running)        ( 7.2%)         2.67 Ghz     3.6%
polling           1.0ms ( 0.0%)         2.67 Ghz     0.0%
C1 mwait          0.0ms ( 0.0%)         2.14 Ghz     0.0%
C2 mwait          0.6ms (11.5%)         1.60 Ghz     0.3%
C6 mwait          2.2ms (81.2%)          800 Mhz    96.2%

Wakeups-from-idle per second : 574.7    interval: 10.0s
Power usage (5 minute ACPI estimate) :  62.4 W (0.6 hours left)

Top causes for wakeups:
  37.9% (264.0)     <kernel core> : hrtimer_start_range_ns (tick_sched_timer) 
  21.4% (149.1)       <interrupt> : iwlagn 
  15.4% (106.9)   plugin-containe : hrtimer_start_range_ns (hrtimer_wakeup) 
  11.5% ( 80.0)       <interrupt> : extra timer interrupt 
   7.3% ( 50.6)       <interrupt> : PS/2 keyboard/mouse/touchpad 
   1.1% (  8.0)     <kernel core> : hrtimer_start (tick_sched_timer)
As you can see the hrtimer_start_range_ns is doing far too many wakeups. My google researching shows that it is part of Hyperthreading and is a known issue with the kernal but is there anything I can do for a workaround to make it run longer?

I can provide any further information if required.

Last edited by CapnStank; 09-14-2010 at 01:25 PM.
 
Old 09-14-2010, 11:54 PM   #2
Bryanlee
Member
 
Registered: May 2005
Location: Honolulu, HI
Distribution: Ubuntu 10.04
Posts: 56

Rep: Reputation: 15
I believe you can turn off hyper threading in your bios. That's not an ideal solution but it should help with battery life. There are quite a few other reports of this same problem.
 
Old 09-15-2010, 12:40 PM   #3
CapnStank
Member
 
Registered: Oct 2009
Distribution: Fedora, HPUX
Posts: 31

Original Poster
Rep: Reputation: 2
Yeah, my research has shown that its a bug in the Kernal but I was unable to find if there were any feasible workarounds. If I disable hyperthreading then my Windows boot will suffer so I'd like to avoid that.

Thanks though!
 
Old 09-15-2010, 01:36 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,489

Rep: Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614
? have you turned off unused services ???
http://www.mjmwired.net/resources/mjm-services-f13.html

are you using compiz-fusion ?
if so uninstall it from a laptop

have you used the "power management" tool

is this a Gnome or KDE fedora 13 ?

have you scaled back on the cpu frequency ?
 
Old 09-17-2010, 06:24 PM   #5
CapnStank
Member
 
Registered: Oct 2009
Distribution: Fedora, HPUX
Posts: 31

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by John VV View Post
? have you turned off unused services ???
http://www.mjmwired.net/resources/mjm-services-f13.html

are you using compiz-fusion ?
if so uninstall it from a laptop

have you used the "power management" tool

is this a Gnome or KDE fedora 13 ?

have you scaled back on the cpu frequency ?
1) I set my services as that page recommends, there were quite a few changes I needed to make, thanks.

2) I've removed compiz-fusion

3) By "power management tool" I assume you mean the tools for setting screen dimming, when to shut off hard disks/screen etc.? If so yes.

4) I'm using a Gnome fedora 13.

5) The CPU is set to On Demand at all times. It sits at 800MHz >90% of the time.

I'll report back with the power usage after I get a bit of sample data. Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Extending Ubuntu's Battery Life LXer Syndicated Linux News 0 02-29-2008 05:30 PM
battery life fought Linux - Hardware 5 09-11-2005 01:50 AM
Windows: 4-5 hour battery life, Gentoo : ~2:30 battery life numerous Linux - Laptop and Netbook 3 01-17-2005 08:39 PM
windows, good battery life -> fedora, bad battery life daedalusq1115 Linux - Laptop and Netbook 1 01-17-2005 06:40 AM
Battery life DAChristen29 Linux - Software 2 02-03-2003 12:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 04:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration