-   Linux - Laptop and Netbook (
-   -   My "Intel Pro/Wireless 3945ABG " doesn't work on OpenSuse 10.2 (

aswinkillua_z 07-09-2007 09:43 PM

My "Intel Pro/Wireless 3945ABG " doesn't work on OpenSuse 10.2
Dear pro .....

My Laptop Mobile " Toshiba Tecra Intel Centrino Duo " which Intel Pro/Wireless 3945ABG built in. Yesterday i have installed OpenSuse 10.2. i thought my wireless wouldn't appear any mistake ... as i can use as usually work. before...i have used my wifi in winXP pro SP2 and there are no mistake or undetected but till i try to up the wireless on OpenSuse 10.2... it wouldn't up ... i tried to look up network manager like this :

kwifi indicator is death and always not shown the signal Access POint (Linksys)
i try to use YAST :

here's the detail of the address :
my lspci :
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Expr
ess Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML Exp
ress Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express In
tegrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Aud
io Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (r
ev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (r
ev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Control ler (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (re v 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA S torage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controlle r
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Conne ction (rev 02)
05:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
05:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
05:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
05:06.3 Generic system peripheral [Class 0805]: Texas Instruments PCIxx12 SDA St andard Compliant SD Host Controller

MY iwconfig :

lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.


please anyone can help me to solve this out ..........

seelenbild28 09-02-2007 04:42 PM

try the latest iwlwifi driver package from intel... google...

seelenbild28 09-02-2007 04:44 PM

or include the opensuse 10.3 factory repository and addon-repository in yast, yum or smart, whatever you use and install the ipw3945 firmware, iwlwifi-kmp-default and the new kernel or something else which is available there...

petespin27 09-02-2007 09:21 PM

Have you tried installing the firmware and regulatory daemon from the non-oss repository? Have a look at these instructions here for details on how to install:

N_A_J_M 09-03-2007 12:03 AM

are you sure the kernel module is loaded?
type: lsmod |grep ipw3945
if its not loaded load it with
modprobe ipw3945

if it loads successfully type iwconfig and have a look to see if you can see anything that resembles a wireless adapter. on my system its eth1 yours may be wlan0

if there is nothing, go to yast > network devices > click network cards and select configure with ifup (traditional)

run through the config, select managed and select the encryption, and passphrase etc.
finish and now check iwconfig, you should see a connection

ifconfig should also show the device. you can also try bringing up and down the adapter with ifup eth1 (or wlan0) and ifdown eth1

hope this helps :)

briareus 09-03-2007 05:55 AM

I've had no problems getting the driver, firmware, and daemon from the address above and installing them. You can find the INSTALL file at

after following the directions, making the driver, copying the ucode to /lib/firmware (in my system, yours may differ), and copying the daemon to /sbin, modprobing the driver ipw3945, running /sbin/ipw3945d, I see the LED flickering as the radio scans. I then use iwlist eth2 scan to find the ap, and then use iwconfig to associate with it. Finally I use dhcpcd to get an ip.

All the above will have to be adapted to your opensuse, as I don't run that distro, but you get the idea. If you need more specific help on doing it manually we can help there too.

You may or may not need the ieee80211 packages at that link I posted. It is quite likely they are already enabled in that bloated suse default kernel config.

seelenbild28 09-04-2007 03:47 AM

mac80211 is included in kernel 2.6.22.x from opensuse factory...

odcheck 09-04-2007 04:09 AM

SuSE 10.1/2 - use the Extras non-oss CD disk 6 or install the packages ipw-firmware and ipw3945d from a non-oss repository. You may still have problems on some systems if the "kill switch" is turned on. (On my IBM T60, this is a little switch near the IR port, on other systems it may be an ACPI keyboard switch like Fn+F5 or something you can enable or disable in the BIOS.)
SuSE 10.1 - Use the wlan kernel & install the firmware upgrade. Install ipw3945d. Use traditional ifup instead of Network Manager.


Packages ipw-firmware and ipw3945d reinstall.

seelenbild28 09-04-2007 06:52 PM

hmm... sometimes it would be nice to have a feedback*g

rcastro1414 09-05-2007 05:11 PM

I also had problems with my wireless card I found a nice solution on ndiswrapper this software let you use windows drivers in Linux. It use the .inf file in your Linux. But remember include the actual driver into the blacklist in order to avoid confusions.

All times are GMT -5. The time now is 06:31 PM.