-   Linux - Laptop and Netbook (
-   -   master boot record help (

sfr7 04-04-2004 06:55 PM

master boot record help
I have a computer that will boot from the cd rom drive and have tried to install Mandrake 8.1, Red Hat 7.2 and Corel Linux.
So far the only on that works is the Red Hat.
The problem; in both Mandrake and Corel I never get the option to create a boot disk but did get the chance to do so in Red Hat.
So, when I reboot Mandrake or Corel I get a 'insert system disk' error.
In Red Hat, I have to use the boot disk to boot into Linux. It runs fine from there.
I believe that my problem is that Lilo is not writing to the Mbr either properly or at all.
I did choose 'remove all' as my partition option.
Thanks in advance,

aikempshall 04-07-2004 03:39 PM

How do you reboot Mandrake?

I found grub to be more versatile as all it's config is done in the /boot/grub directory. So I have the grub menu.list in my slackware partition which I can amend from my Redhat/Fedora and Mandrake partitions.


sfr7 04-07-2004 09:08 PM

Tks for your reply.
To answer your question, that's exactly what I'm having trouble with .... I can't reboot. As soon as I restart when install is done I get the message to insert a system disk - which I never get the chance to do during the install.
It skips right over it.
As I mentioned, the only distro that I have been able to get to work so far is Red Hat 7.2 and even that one forces me to have to boot from a 3.5 in.floppy, not from the hard drive.

Just as an aside, I am presently running Mandrakemove and it picks up my 3.5 just fine.
As it is not an installable cd, I don't know if it would recognize my hard disk.

My bottom line is that I think Linux (all 3 versions I have tried) id not installing Lilo to the master boot record so when I reboot, I get the error message mentioned above.

Thanks again for your help.


aikempshall 04-08-2004 02:36 AM

I've only ever managed to boot from floppy on the redhat distro. I would suggest that you go into redhat with your boot disk and then re action the lilo config. I'm a grub person, I found lilo too fiddly. Can't remember whether fedora is a grub or lilo distro. If you do the grub-install it "should" overwrite the current loader in your mbr also the same will happen if you do lilo equivalent.

Did you make a note of the partitions that mandrake and corel were installed in?

Maybe you should wait a bit to see if anyone else has a suggestion in the grub/lilo debate!


upchucky 04-10-2004 04:10 PM

find knoppix, it will boot from cdrom, and can repair unbootable operating systems inculding windows.
knoppix will boot and will not change any settings, unless you tell it to.
it is a complete linux operating system, that does not even need a hard drive to work.
it will automatically mount all existing file systems, partitions and devices.

I got knoppix from Linuxformat Magazine LXF51 for march 2004, it comes in two editions, one has dvd, that has tons of useful apps.

the other issue has three cdroms but does not have knoppix, but it does have other bootable distros that can help, but they are not as simple as knoppix.

tekhead2 04-11-2004 06:41 PM

I was too lazy to redo lilo, and didnt want to burn knoppix. I just went to and downloaded Ranish Partition manager. Its a small bootable floppy , written by some dude, But it fixed my mbr and it even comes with a small bootloader that will load Windows, Linux, and freeBSD. That would be the easiest way to get it too boot. But It wouldnt be the "Linux" way. Just ask yourself what would Linus do?

upchucky 04-11-2004 07:58 PM

Linus would redo Lilo, create bootable floppy, or cdrom.
Just a note, knoppix is also a rescue disk, you can fix anything with it, and not lose files.

sfr7 04-20-2004 06:31 PM

Thanks everyone for your help.
I actually downloaded a copy of Mandrakemove and am using it to learn a bit more ... then I'll tackle a full install and my mbr problem.

Fyi for anyone who wants to give it a try, Mandrakemove is working great on my Compaq Evo N800v laptop with Cdrw/dvd and internal nic card.

The only slightly frustruating thing is that as I am using the downloaded version, I canot save my settings on a usb key like you get in the boxed version.

Trying to see the glass as half full though, it is a good way to learn when I have to remember how to do things when I re-boot.


rootboy 04-21-2004 04:08 AM

1) First off, pick a distro and at least stick with it long enough to get it installed (and then add the others).

2) I hate Compaq's, just exactly for the reasons why you are having trouble. Getting Compaq's to do something as simple as booting into linux is like pulling teeth. Even when you sucessfully install lilo or grub, it still doesn't seem to want to work.

3) Since you don't seem to be too picky, :rolleyes: Do a google and see what distro seems to be the most sucessful/easiest to install on your computer.

I'll save you the trouble, this guy seems to have it working:

4) Once you get the first distro working, then install the rest. Come back here for hints on how to edit your lilo.conf to support the various distros.

5) Did I mention that I hate Compaqs?


simsjr 04-24-2004 06:59 AM


I don't have Knoppix, but I do have Knoppix-STD!

For those not in the know, Knoppix-STD is based on Knoppix but is LOADED with security and forensic tools (STD = Security Tools Distribution). STD is particularly well suited to tasks like wardriving and recovering data from a corrupted hard disk. I hear the feds are big on it too. It's really scary what can be done with Knoppix-STD.

Anyways, what are the steps to fix your MBR from Knoppix? I wonder if the procedure will be the same on Knoppix STD, as I have the same MBR problem.

upchucky 04-25-2004 08:52 AM

once knoppix boots from cdrom, usb, lan, or your particular bootable device which is usually governed by the bios, you can "su" to the hda of your linux install, then use vi to edit the init files, x files, or config files that are not set up right, or have gotten wrong boot/config info that is passed to the kernel at boot time. you can also edit either lilo or grub to make sure the boot info there is ok depending on your particular flavor of linux.

the above files are in different locations on the hda, depending on your distro, and install options.
most important is to set the inittab file to default to init 2, 3, or 4 until you have the x86config file set up properly, anytime you are fine tuning your system, it is best to set the default to init 3, (my personal choice). never set inittab to level 6, it will endless loop your boot.
level 5 starts the x file for your gui.
make a boot disk, and verify that it will boot the hda, many do not, by default, get all the config files needed to start at boot time, and need further files dependent on your distro, kernel, and config settings.

good luck.

All times are GMT -5. The time now is 01:39 PM.