Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 03-30-2006, 06:54 PM   #1
LQ Guru
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,163

Rep: Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522
Mandriva 2006 won't boot on Compaq 1245

I have installed Mandriva ( free ) 2006 on my old laptop, a Compaq 1245. I had Mdk 9.2 on it for about two years, it worked well.

I'm using Mandriva 2006 on my main box and I like it.

I tried Ubuntu on the laptop, but I could not get sound working. I had it working on Mdk 9.2. After a 3 CD install of 2006, on the re-boot, I get 'kernel panic - not syncing' I can, and have booted Knoppix 3.9 on the system, so I'm as sure as I can be, the hardware is not broken.

I thought by some of the other messages before the kernel panic line, for some reason 2006 can not mount the / drive. There is only one drive. I booted Knoppix, I can mount hda1, hda6 and hda7. Hda5 is the swap, and since this machine has only 64M of ram, I'm sure Knoppix is using the swap.

My guess is something is wrong with lilo. I can browse the lilo.conf file on hda1, but I have not been able to figure out how to write it. With Knoppix I edited the /etc/fstab file and made sure hda1 is set to read write (rw) in fstab. I then mounted the disk. I want to change the acpi=ht parameter, and re-install lilo, but I can not get it to write back to hda1. I want to change it to acpi=noacpi How is this done with Knoppix, or any other live CD? I must be missing something.

This is an older 300Mhz machine. Here is a link to a model 1244, just about the same machine, CPU is a little faster.
Old 03-31-2006, 02:33 PM   #2
Senior Member
Registered: Oct 2003
Posts: 2,559

Rep: Reputation: 213Reputation: 213Reputation: 213
First off, you can test to see if those boot options will work by hitting the Esc key as soon as you see the lilo boot selection screen. That will take you to a boot prompt at which you should type:

linux noapic nolapic acpi=off

"linux" is the name of the boot selection in lilo you are going to boot and the remainder are the most common options to try if you are having trouble booting. Post back your results. If it doesn't work, I'll go into more detail about how to run mandriva's lilo from knoppix using chroot.
Old 04-01-2006, 08:48 AM   #3
LQ Guru
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,163

Original Poster
Rep: Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522
Thank-you for your thoughtful response.

I tried your suggestion, and the system still won't boot. My assumption at this point is, the problem is not just these parameters. I have done a little more digging, but without success.

Here is the text of the first error when booting.
'mount: error 6 mounting reiserfs flags noatime' The system retries two more times without the parameters, and fails to mount '/' The last line says ' Kernel panic - not syncing No init found try passing init= option to kernel'

This was a clean install, I partitioned and formatted the drive. Here is the output from fdisk -l.

Disk /dev/hda: 40.0 GB, 40007761920 bytes
240 heads, 63 sectors/track, 5168 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        1350    10205968+  83  Linux
/dev/hda2            1351        5168    28864080    5  Extended
/dev/hda5            1351        1419      521608+  82  Linux swap / Solaris
/dev/hda6            1420        2779    10281568+  83  Linux
/dev/hda7            2780        5168    18060808+  83  Linux
Here is my lilo.conf file.

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

	append=" acpi=ht resume=/dev/hda5 splash=silent"
	append=" acpi=ht resume=/dev/hda5"
	append=" failsafe acpi=ht resume=/dev/hda5"
Here is the current /etc/fstab file.

/dev/hda1 / reiserfs notail,noatime 1 1
/dev/hda7 /data reiserfs notail,noatime 1 2
/dev/hda6 /home reiserfs notail,noatime 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0
I believe the acpi=ht parameter is wrong, this machine is too old to have the programable interrupt controller. If I boot Knoppix, it gives me problems if I don't set acpi=off.

I checked the path to initrd.img and vmlinuz and they are correct.

Any thoughts on what to do next?
Old 04-01-2006, 08:36 PM   #4
Senior Member
Registered: Oct 2003
Posts: 2,559

Rep: Reputation: 213Reputation: 213Reputation: 213
The boot parameters I gave you have the same effect as setting acpi=off in lilo.conf's append line. They overide what's in lilo.conf now; that was the whole point. If what I gave you didn't work, changing lilo.conf won't work.

If you want to know how to do that anyway, boot into knoppix, mount hda1 read/write. Open lilo.conf in a text editor and make the changes you want and save the changes. Then open a console and run:

$ su
# umount /mnt/hda1
# mount -t reiserfs /dev/hda1 /mnt/hda1
# chroot /mnt/hda1
# /sbin/lilo.conf -v
# exit
# exit
$ exit

That will rewrite your changes to lilo.conf to the mbr by utilizing the chroot command.

In knoppix are you booting with a 2.4 kernel or a 2.6 kernel? That could be a difference since mandriva uses a 2.6 kernel and the example in your link also references distros using the 2.4 kernel, namely slackware.

You can try checking your bios setup and make sure plug & play is disbaled if you are able to do that in your compaq. Another thing you can try is adding "nodma" without quotes to your list of boot parameters.

Last edited by kilgoretrout; 04-01-2006 at 08:47 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless button on Compaq M2000 not working in Mandriva 2006; but did once before briareos Linux - Laptop and Netbook 1 01-13-2007 08:57 AM
Mandriva 2006 boot issue Juterassee Mandriva 5 03-02-2006 09:34 PM
Cant boot Mandriva 2006 dvd iso Astral_Nomad Mandriva 3 12-06-2005 04:19 AM
How to make a boot DVD for Mandriva 2006 Beta 2 ? lukiki Mandriva 1 08-23-2005 02:43 AM
Fedora Core 2 in my legendary Compaq Presario 1245 laptop tantotea Fedora - Installation 1 11-10-2004 10:27 AM > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 03:08 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration