LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Mandriva 2006, Averatec notebook, ACPI causes IRQ 11 disabled, network hangs (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/mandriva-2006-averatec-notebook-acpi-causes-irq-11-disabled-network-hangs-392993/)

a2brute 12-15-2005 12:12 AM

Mandriva 2006, Averatec notebook, ACPI causes IRQ 11 disabled, network hangs
 
I'm desparately seekeing a wizard that may be able to help me solve this problem. I fear nothing short of a wizard is what it will take. :scratch:

I have an Averatec 3250 running Mandriva 2006 with ACPI enabled. I must have ACPI enabled to use the USB ports on this laptop, and besides, without it, the battery life is crap. When I try to connect the network (using "ifup eth0") I receive a message from the kernel that IRQ 11 is being disabled and (if the system does not hang right there) the network will not come up at all. If I use the kernel parameter "pci=noacpi" then the network works fine, but the USB ports are not functional. :cry:

I have tried the following kernel parameters with no success:

nolapic
noapic
pci=pirqmask
pci=biosirq
irqpoll
acpi=bios
acpi=noirq

The dmesg output after attempting to bring up the network with the ACPI enabled is as follows:

via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:12.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
eth0: VIA Rhine II at 0x1d800, 00:40:45:25:84:a8, IRQ 11.
eth0: MII PHY found at address 1, status 0x7849 advertising 05e1 Link 0000.
irq 11: nobody cared!
[<c0103efe>] dump_stack+0x1e/0x20
[<c01951eb>] __report_bad_irq+0x2b/0xa0
[<c0195308>] note_interrupt+0x78/0xa0
[<c0194d60>] __do_IRQ+0xe0/0xf0
[<c01055ec>] do_IRQ+0x1c/0x30
[<c01039c6>] common_interrupt+0x1a/0x20
[<c01768aa>] do_softirq+0x2a/0x30
[<c01055f1>] do_IRQ+0x21/0x30
[<c01039c6>] common_interrupt+0x1a/0x20
[<c01951aa>] request_irq+0x9a/0xb0
[<df22042f>] rhine_open+0x4f/0x140 [via_rhine]
[<c02e7bb6>] dev_open+0x46/0x90
[<c02e93f7>] dev_change_flags+0x57/0x140
[<c032e5e7>] devinet_ioctl+0x787/0x7f0
[<c01cac40>] do_ioctl+0x30/0x90
[<c01cae0f>] vfs_ioctl+0x5f/0x1e0
[<c01cafd1>] sys_ioctl+0x41/0x70
[<c0102faf>] sysenter_past_esp+0x54/0x75
handlers:
[<df220860>] (rhine_interrupt+0x0/0x270 [via_rhine])
Disabling IRQ #11


If anyone can help me interpret what this means and figure out how to fix it so I can use both my network AND my USB, I would be forever greatful. :D

Thanks in advance.

Blue_Dwarf 12-28-2005 12:58 AM

averatec acpi problem mandrake 2006
 
I have been having the same problem with my laptop, I load mandriva 2006 on it ok and it all works good, except the usbs won't work. I had mandrake 10.1 on my computer before and all I did to get the usb's working was enable the acpi. I tried enabling the acpi and all of a sudden when I boot up it freezes, I don't know what to do. Is there some way to get the usb's working without enabling the acpi, or is there a way to use an older version of that the acpi with mandriva 2006?

anyways please help!

thanks

bizangous 01-15-2006 03:09 PM

USB Ports not working
 
I am brand new to Linux and I just started with Mandriva 2006. I am also running an Averatec 3250. I cannot get my USB ports to work. I am not having any problems with my networking ethernet and wireless are working but no USB. I don't know what the ACPI is or if mine is enabled. Can anyone help?

vbatts 02-24-2006 08:19 AM

hey all,
i'm not on mandrive, so i can't walk you through the mandriva way, but with suse 9.3 last year when i first got my stable build installed. when installing whatever distro, you have to disable acpi to install the distro. as soon as you have you're distro installed you must find where to go to re-enable your acpi service. yast on suse, and i would suppose the 'Configure my Computer' in mandrake. until you get the acpi re-enabled the powersaved will not throttle the cpu and fan usage, and usb ports will not work. along with a couple other quirky things. i'm certain its not mandriva.
the averatec does not use apm, it uses the acpi

lestoil 02-24-2006 07:19 PM

You may have to try acpi_irq_balance or acpi_irq_nobalance or pnpacpi=off or pci=routeirq. You may have to reserve irq for particular hardware. On one of my setups soundcard,nic and usb hubs used irq11 so had to take out souncard because usb and nic were critical.
Make sure you have latest BIOS for lappy and are using at least ACPI version2.And check BIOS ACPI settings.
Also see if your os has newer kernel that may do ACPI better. If all else fails APM still works well especially if BIOS earlier than 2003.

lestoil 02-24-2006 07:31 PM

Check linux on laptop for successful ubuntu breezy badger and arch installs on that lappy. Wouldn't be suprised if slackware and debian etch or kanotix 2005-04 installed easily too.


All times are GMT -5. The time now is 05:14 PM.