LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 05-08-2004, 10:00 PM   #1
vas_dee
LQ Newbie
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 8

Rep: Reputation: 0
Mandrake 10 doesn't auto power off


Hi,

I recently installed Mandrake 10 community on my dell inspiron 8600 and everything is working fine, except for 1 minor problem. When i shutdown the laptop, either by the gui or shutdown -h or whatever it will run through all the power down sequences however it won't automatically turn it off. Its not really a big problem, but it is annoying that i have to wait for it to power down so i can manually switch it off. I've scoured the web and found a number of people have the same problem both in kernel 2.4 and 2.6 (i'm running 2.4) but i can't seem to find a solution. The really annoying thing is if i use the 2.6 kernel i can power down correctly however i can't get performance profiles/ cpu scaling to work :S
It's really bizarre, i'm sure it's just a configuration problem but my linux knowledge is limited. Can someone give me the definative solution?
Thankyou!

Last edited by vas_dee; 05-08-2004 at 10:07 PM.
 
Old 05-09-2004, 01:39 AM   #2
auditek747
Member
 
Registered: Feb 2004
Location: Ohio, USA
Distribution: Arch Linux
Posts: 464

Rep: Reputation: 30
Are you using APM or ACPI?
Does your battery monitor work?
 
Old 05-09-2004, 02:13 AM   #3
vas_dee
LQ Newbie
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 8

Original Poster
Rep: Reputation: 0
i'm using acpi. Battery monitor works, fans work, cpu scaling works. Hibernate and suspend don't work however, but i'm not really concerned about that.
 
Old 05-09-2004, 03:31 AM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Did you compile your own kernel?
 
Old 05-09-2004, 03:52 AM   #5
vas_dee
LQ Newbie
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 8

Original Poster
Rep: Reputation: 0
no. I don't know enuff about linux to do that sort of thing. A few other posts i read said that i should put a few options within my .config file. Should these options take effect when i reboot or is that to do with recompiling the kernel?
 
Old 05-09-2004, 04:10 AM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Quote:
A few other posts i read said that i should put a few options within my .config file. Should these options take effect when i reboot or is that to do with recompiling the kernel?
No it will not take effect on boot. The .config file is what you use to compile your kernel.
 
Old 05-09-2004, 04:17 AM   #7
vas_dee
LQ Newbie
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 8

Original Poster
Rep: Reputation: 0
ahhh ok. So how do i go about compiling the kernel? Does mandrake make this easier for me?
Cheers for your help by the way. I appreciate your prompt replies.
 
Old 05-09-2004, 04:29 AM   #8
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Ah I don't think you need to. I was just wondering. There are some options you can specify if your power management doesn't work correcty but I just realised that they're all for APM so they don't apply to you.
 
Old 05-09-2004, 11:43 PM   #9
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
I don't currently have Mandrake installed. However I would look at the log files as you press the button.

Probably a file /var/log/acpid, maybe it would be in an acpi folder in /var/log.


Look in /var/log and find the log file for your acpi and tail it while you press the button.

tail -f /var/log/acpid

you should see the event logged. If there is no obvious error then look at the event name.

[Sun May 9 22:25:40 2004] received event "button/power PWRF 00000080 00000006"
[Sun May 9 22:25:40 2004] executing action "/usr/sbin/acpid_proxy button/power PWRF 00000080 00000006"

You need to check the /etc/acpi/events folder and make sure you have a file there that has the command there to execute for the registered event. Some kernel acpi may be different and that would break the function. It may require the event file to be edited or the registered event added to the event file to match the registered event.

If your using acpi_proxy like mine shows above then you would edit that file instead. the default file in /etc/acpid/ should have instructions about the proxy.


If you can check it out post the file contents of the event file in /etc/acpi/events, the proxy config file if you are using that. Probably would be /etc/sysconfig/powermanagement, and the output of the registered event in the acpid logfile.
 
Old 05-11-2004, 03:32 AM   #10
vas_dee
LQ Newbie
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,

Ok i did what u said. No errors were reported when i shutdown using the logout-> turn off computer option. It was a similar call to yours except mine was,

received event "button/power PWRF 00000080 00000001"

the event i have linked to it is /etc/acpi/events/power
and all that is in that file is /sbin/shutdown
 
Old 05-13-2004, 07:07 AM   #11
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Does the logfile show that it registers the event? If not you might need to edit the event file to something like this..

event=button/power *
action=/sbin/shutdown
 
Old 05-27-2004, 08:20 AM   #12
red_over_blue
LQ Newbie
 
Registered: Feb 2003
Location: MB, Canada
Posts: 26

Rep: Reputation: 15
Try passing nolapic in the append options in your /etc/lilo.conf. Don't forget you have to run lilo as root after editing lilo.conf for the changes to be recognized.

Last edited by red_over_blue; 05-27-2004 at 08:21 AM.
 
Old 05-27-2004, 08:39 PM   #13
vas_dee
LQ Newbie
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 8

Original Poster
Rep: Reputation: 0
OMG it worked! Thanks heaps for your post. You don't know how long this problem has been slowly driving me insane! woooooop
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer will not auto power-off. aweir14150 Mandriva 6 02-03-2004 11:19 PM
Power Down...but I want it done auto coopns Linux - Newbie 2 01-31-2004 09:56 PM
auto power on not off slack66 Linux - Software 6 09-12-2003 06:43 PM
Auto Power Off BxBoy Linux - Newbie 1 07-13-2003 07:46 PM
Auto Power Off with Mandrake 9.1 boa Linux - Distributions 0 07-12-2003 04:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 01:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration