-   Linux - Laptop and Netbook (
-   -   Macbook loud fans after installing Slackware (

lensilvan 07-02-2013 02:15 AM

Macbook loud fans after installing Slackware
I finally decided to install Slackware on my Macbook 5.2 ( ), in dual boot with Mac OS X, using rEFIT and LILO.

However, I find out that when I am running Slackware, the macbook's fans are more and more loud, as I run slapt-get for example. Although I switched to the generic kernel and do not use X, this issue persists. It's like if the memory or the CPU is overused, although the system is not particulary slow.
In Mac OS X, I did not have this problem.

What should I do? It should be better that I solve this issue before running X.

ronlau9 07-02-2013 03:05 PM

To my knowledge the fan speed is controlled by OS X depending on the CPU loud .
Can Slackware do the same ?
If not it might be that the fans are running nearly full speed

TobiSGD 07-02-2013 04:43 PM

Check if the power-saving methods for your CPU are working correctly. Please provide the output of


lensilvan 07-03-2013 12:36 AM

Here is the output (half in French, sorry):

cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Veuillez rapportez les erreurs et les bogues à, s'il vous plait.
analyse du CPU 0 :
  driver : acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  limitation matérielle : 1.60 GHz - 2.13 GHz
  plage de fréquence : 2.13 GHz, 1.86 GHz, 1.60 GHz
  régulateurs disponibles : ondemand, userspace
  current policy: frequency should be within 1.60 GHz and 2.13 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency CPU is 1.86 GHz.

Some additional details: I'm using the x86_64 version.
While running Slackware, the macbook heat is increasing and then the fans start running. I never experienced this on my Mac OS X installed in the other partition.

TobiSGD 07-03-2013 11:00 AM

OK, so power-management for the CPU is working correctly, as it seems. Next thing to check would be the video device. The free nouveau driver has issues with setting the correct clockspeed and lacks power management features, so I would recommend to install the latest Nvidia driver next and see if temperatures decrease.

lensilvan 07-03-2013 11:20 PM

I know it's annoying but I can't install xf86-video-nouveau-blacklist, necessary for running the nvidia driver. According to slapt-get, xf86-video-nouveau-blacklist is nowhere to be found. Here are the mirrors I use:

# This can point to any release, ie: 9.0, 10.0, current, etc.

The xf86-video-nouveau-blacklist is required according to:

TobiSGD 07-04-2013 06:18 AM

Just do this

echo "blacklist nouveau" > /etc/modprobe.d/nouveau.blacklist
as root, it has the same effect as installing xf86-video-nouveau-blacklist.

lensilvan 07-04-2013 08:51 AM

I followed the instructions on the wiki, then run as root echo "blacklist nouveau" > /etc/modprobe.d/nouveau.blacklist as indicated.
At rebooting very disappointingly, the error no nvidia graphics adapter probed and coud not insert nvidia: No such device, appeared. I've installed all the drivers and blacklisted the driver nouveau, so where is the logic in this situation???

lensilvan 07-05-2013 12:18 AM

I don't understand at all. I just checked if /etc/modprobe.d/nouveau.blacklist was created and it is the case.


blacklist nouveau
I then deleted it and rebooted but this absurdity still occurs. Then I removed the nvidia drivers and X was loaded as before. After I blacklisted again nouveau, X was loaded correctly but my mouse stopped working and I had to remove again nouveau.blacklist.

Knightron 07-05-2013 10:28 AM

Have you made a xorg.conf/xorg.conf.d file?

lensilvan 07-05-2013 05:12 PM

I tried to generate it once but it failed.
It seems that blacklisting nouveau don't have any effects at all on the nouveau driver which keeps running as if nothing happened. I removed nvidia and blacklisted nouveau and I booted normally.

Knightron 07-05-2013 08:42 PM

You need an xorg.conf file or an xorg.conf.d file if you want to use the nvidia drivers. This is why it's not working. You're attempting to blacklist nouveau with nothing to replace it.
You said you'd installed the nvidia drivers. (assuming you have done it correctly) As root, do the following.

mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

This will create a file called /etc/X11/xorg.conf.d/20-nvidia.conf, containing the following.


Section "Device"
        Identifier "My GPU"
        Driver "nvidia"

The part that says 'Driver "nvidia"', is telling xorg to use the nvidia driver instead of nouveau. Restart your computer to see if you have success.

lensilvan 07-06-2013 09:44 AM

I applied all this.
Issues keep going and going. After reboot, I get the same and the same error "No nvidia graphics adapter probed." "Error: could not insert 'nvidia': No such device'".
Fatal server error: no screen found.

Knightron 07-06-2013 09:38 PM

You sure you've compiled and installed it?

lensilvan 07-06-2013 11:51 PM

Yes, sure!!!
I guess it's an issue caused by xorg.conf (Once, I tried to generate one using X -configure but it failed since it detected 2 screens.). Maybe I should try to 'correct' xorg.conf but I can't find it.

Well, I don't know the origin of that issue and what to do.

All times are GMT -5. The time now is 05:35 AM.