-   Linux - Laptop and Netbook (
-   -   Looking for a Distro to run on some older Toshiba Laptops, need wireless too (

captainjrl 06-15-2006 12:52 PM

Looking for a Distro to run on some older Toshiba Laptops, need wireless too
I work at a K-8 school and we have some older laptops that are no longer in use. I have two varieties of Toshiba Satellite's, 2140XCDS and 2250XCDS. Below are specs for each:

2140s: AMD K6-2 450 MHz, 64 MB RAM, 4.3 GB hard drive
2250s: Mobile Intel Celeron 600MHz, 64 MB RAM, 6 GB hard drive

First I'd like to get linux on them and second have them use some older Linksys 802.11b cards (WPC11).

I've tried to get Ubuntu 6.06 on them but the install always seems to stop part way through.

Looking for help and suggestions.

syg00 06-16-2006 06:56 AM

Mmmmm - don't like your chances with Ubuntu. I lump that in the "mega-distro" basket.
With 64Meg, you need a light distro - 4.3 Gig would be on the lower end of the scale as well. Especially when the next update comes along. Maybe you should look at Xubuntu (Ubuntu with XFCE, a much lighter DE than Gnome).

I run Ubuntu on a Toshi SatPro (PIII, 256 Meg), and it's just passable.

captainjrl 06-16-2006 10:43 AM

Thanks, I'll give Xubuntu a shot and report back with results.

cayzar 06-16-2006 11:22 AM

I have just been over and over this with three laptops of same aprox vintage.
Ubuntu ran fine but a little slow. Suse was nice but too bloated and slow for the smaller processor and ram, forget madriva unless you have a hot system.
Vector ran very nice indeed. Small, light, tight and powerful.
The best results that I had were with debian. Debian seemed to due better on my older hardware. Only had problems with my vid, didn't get to setting up wireless though.
for a 450 with little ram vector and debian are the best choices IMHO.

captainjrl 06-16-2006 01:47 PM

Xubuntu seems to have installed fine. However I don't see anywhere to set wireless settings. I am very new to linux, so it is very possible I missed it. Can anybody point me in the right direction as to where it is or if I need to install additional software?


cayzar 06-16-2006 04:07 PM

There are other threads discussing wireless. All of them start with install a package called ndiswrapper first, then the driver.
Do you know what kind of wireless you have? i.e. broadcom, intel, other?

captainjrl 06-16-2006 04:30 PM

The wireless card is a PCMCIA card. A Linksys WPC11 802.11b card.

Are there distros that already have the ndiswrapper built in?

rickh 06-16-2006 08:01 PM

You don't need ndiswrapper for that card. You don't need it for most cards, actually. If it's just WPC11 with no 'version number' after it, it's one of the easiest cards possible to get working. I should think it would work out of the box on most current distros. Info:

syg00 06-16-2006 10:44 PM

I would also have thought that should be fairly straight-forward; especially if it's a Dapper level (6.06).

Under normal Ubuntu,it's System - > Administration -> Networking. Make sure the interface is active, and set to default (if that's what you want). Be aware that my Cisco 350 (old 11b) card shows up as eth1 - the wifi0 shows as not configured. Makes no difference to me, it "just works" - no ndiswrapper, nothing else to do.

captainjrl 06-19-2006 03:41 PM

rickh: Its a ver 3

rickh 06-19-2006 10:42 PM

Ooh! Ver 3 ... not as easy, orinoco chipset ... supposedly works, though. Do a "Titles Only" search of these forums for orinoco ... Lots of hits ... Driver has been around a long time ... Still may work out of the box. Did you try activating it from your Networking Gui program?

captainjrl 06-20-2006 11:31 AM

I forgot that when I installed Xubuntu I had an extra 128mb of RAM in the machine because Ubuntu wouldn't work with the stock 64mb. After that I tried to pull it and then run the laptop and it wouldn't load up. I tried reinstalling Xubuntu with only the 64mb in to no avail. I got Vector Linux to install but did not see a way to configure the wireless.

So at the moment I am still trying to find a distro to run with the 64mb of RAM only, and then figure out the wireless. Since Vector is the only one to successfully install and work I am sort of leaning that way unless another sugestion works. So far Ubuntu and Xubuntu are a no go.

Thanks for all of you that are helping me. I'd love to expose myself to linux a little more and then my students to it as well to show them an alternative to Windows.

rickh 06-20-2006 12:01 PM


I am still trying to find a distro to run with the 64mb of RAM only
Check out this thread, especially post #32.

captainjrl 06-23-2006 12:01 PM

No offense but, I read through that and it looked a little more complicated than what I'm after. Any other suggestions?

cherriepuppy 06-25-2006 03:56 PM


i've got puppy linux running on a toshiba 7010ct, p2 300mhz
currently got 128MB ram but have had it running on less before i got a upgrade, also using it with a prism54 chipset, wireless pcmcia card with no problems, if you search the various puppy linux sites you will find lots of drivers for different wireless cards.

hope this helps

All times are GMT -5. The time now is 01:52 PM.