LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Live linux distro for Toshiba Satellite? BIOS issues (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/live-linux-distro-for-toshiba-satellite-bios-issues-4175602446/)

Wolfpeach42 03-24-2017 04:19 AM

Live linux distro for Toshiba Satellite? BIOS issues
 
Hi All

I'm trying to get a live linux distro to work on my toshiba satellite laptop, but having issues with booting/BIOS.

I've been using Puppy Linux (lupu-528.005.iso) on an old Acer machine, and this works fine, but I cant get it to work on my newer Toshiba.

Spec:

Toshiba Satellite L50-C-20G
Intel Core i3-5005U CPU 2.00GHz
x64 based
4GB RAM
200GB HDD
Windows 10 Home

I've tried booting it from USB, and from CD, but neither are recognised. I've and reset the boot order in BIOS to USB first, and then CD, then HDD, but it just boots straight to windows.

I disabled the "secure boot" setting. This made no difference.

I modified the boot setting in the BIOS from UFEI (the default) to CMS (legacy setting), but this resulted in nothing booting at all - no OS found.

I'm all out of ideas!

beachboy2 03-24-2017 11:50 AM

Wolfpeach42,

Welcome to LQ.

The following link may give you some assistance with UEFI and Secure Boot.

An earlier Toshiba L50 with similar problems, subsequently solved, here:
https://ubuntuforums.org/showthread.php?t=2195059

Wolfpeach42 03-25-2017 10:45 AM

Thanks for the pointers - that helped! Have been down a few rabbit holes, but finally got it fixed. Posting this now using a Linux Lite live USB :) It's a Toshiba BIOS issue, related to secure boot on UFEI - not really a linux issue. Here's how I got it to work:

There are options on the BIOS that will not appear unless you set a password on the HDD under the security menu on BIOS. These need to be set, otherwise, no matter what boot options you have specified (USB or CD first, etc), the laptop will ignore all other media and boot straight to windows.

So, first set a password on the BIOS.
Two new options will appear:
1) Boot menu "enabled" or "disabled" - set it to "ENABLED".
2) BIOS access rights - set to "FULL"

Then, go to ADVANCED menu > System Configuration
Set BOOT MODE to "CSM"

Hope this is of help to someone else!

beachboy2 03-26-2017 11:50 AM

Wolfpeach42,

Glad you solved the problem.

Acer notebooks have a similar arrangement and require a supervisor password to be set in the BIOS, prior to tweaking.


All times are GMT -5. The time now is 05:50 AM.