-   Linux - Laptop and Netbook (
-   -   line in/out problems with lenovo s10-3t (

zythar 04-25-2010 06:05 PM

line in/out problems with lenovo s10-3t
internal microphone is not working at all.
when i insert mic or headset into jacks that are placed on left side of notebook, mic is not working too and sound is listened only from speakers, not from headset. i'm running custom kernel. maybe i have forgotten to enable some modules? what should be enabled for working jacks and mic?

ps os is ubuntu lucid

Mr-Bisquit 04-25-2010 06:24 PM

You need to check alsa and/or pulse to be sure that the mic is enabled.
Look in the administration/hardware of your desktop menu.

zythar 04-26-2010 12:38 AM

i've checked pulseaudio settings, there, in input tab, mic is unmuted and volume of mic is on 100%.
but when i opened alsamixer i found that i have 4 (or 5) mics and they are muted, when i activated them, i couldn't add their volume.
i thought that problem was in sound card driver. i mean, i have forgotten to enable some modules. but i recompiled kernel again, enabling all that related to sound, but it doesn't worked again.

zythar 04-27-2010 10:30 AM

i've tried to use kernel, that shipped with ubuntu, but there was difference. same situation with internal mic and with jacks.

zythar 04-27-2010 11:28 AM

problems with jacks solved by adding to /etc/modprobe.d/alsa-base.conf followinf line:
options snd-hda-intel model="olpc-xo-1_5".
problem with internal mic is still waiting for solution.

Shadow_7 04-27-2010 09:01 PM

$ amixer

It might hint at what alsa thinks you have hardware wise. Are you using oss emulation? There various ways to configure audio on a given system.

in aumix I generally set mic and input gain to achieve a recordable level.

aumix -m 75 -i 40 -m R

These same settings seem to correspond with Mic and Capture in amixer. It also shows as Mic and Capture in alsamixer. Although Mic seems associated with playback and Capture with capture (toggle with tab between them). Of course I have different hardware so maybe not applicable in your case. ATIIXP in my case.

All times are GMT -5. The time now is 03:44 AM.