-   Linux - Laptop and Netbook (
-   -   LILO BIOS Check (

darkarcon2015 07-29-2005 02:24 PM

I have Slackware 10.1 (kernel running on my IBM Thinkpad T42 and for some reason the LILO BIOS Data Check takes forever to complete. On my desktop computer, it takes about 1 second to complete. My Thinkpad takes at least 15 seconds to complete. Can I disable this check or is there anything that I can do to speed this up a bit? Thanks for any help.

Half_Elf 07-29-2005 03:15 PM

hmmmm what you mean by "LILO BIOS data check" ? As far as I know, LILO doesn't care about the BIOS, unless it does some check that I am not aware of...
Can you give some more details?

darkarcon2015 07-29-2005 07:40 PM

Right when you pick a distribution other than Windows, it says at the bottom of the screen "Bios Data Check." When it;s done it says Complete and then starts to load the kernel.

Half_Elf 07-30-2005 02:04 PM

Oh, sorry for the confusion... Still this check isn't done by Lilo atmo, as the kernel is already loaded in memory at this point (I think?)

Hmmm I never had problem with this. In newer kernel, there is some options that make some "check" to the BIOS, like, in "Processor in feature" the "Firmware drivers/BIOS enhanced drive call..." or in "Plug and Play" the option "Plug and Play BIOS support".
My guess would be to turn off these 2 options, but I don't really know if these have something to do with the "BIOS check".

darkarcon2015 07-31-2005 01:54 PM

Sorry, I got the process wrong, it goes like this:

*LILO Bootloader*
boot: Linux
Loading Linux.....*series of dots until the next line appears*
BIOS data check successful
*Screen clears and the kernel starts to load*

I checked on my desktop and those two lines are diabled as well as on my laptop. Also, my desktop doesn't produce as many dots during the Loading process.

Half_Elf 07-31-2005 11:57 PM

the "dots" are the kernel that is tranfered in high memory (RAM). Sometime it can take more time, as example if you are booting from a floppy, as floppy are REALLY slow...

If you see more dots, this only mean your system transfer rate from harddrive to memory is really slow, maybe a dying hdd or just a very old IDE bus that transfert really slowly... What kind of laptop is this?

darkarcon2015 08-02-2005 07:57 AM


Originally posted by darkarcon2015
I have Slackware 10.1 (kernel running on my IBM Thinkpad T42...
1.7 GHz Pentium M Dothan
512 MB RAM

I am booting from the hard disk which has an RPM of 7200.

octinum 08-26-2005 05:54 PM

I have the same problem here!
I have an HP-Compaq nx9005 notebook, and it is lilo! I always install grub because of this problem.

I think that happens when the kernel is uncompressing to memory. Here are my observations:

1) Lilo passes this step almost instantly on desktop machines. I installed Slackware on 2 notebook machines, both booted so slow. 4 desktops have no problems.
2) Grub handles this. I don't know how, but Grub never waits.

Why do I not switch to Grub this time? Because I want to solve this! :)

michaelk 08-27-2005 09:28 AM

I quick google found this:
Lilo has a option to skip this test.
By entering nobd as a boot-argument, or by setting the global flag 'suppress-boot-time-BIOS-data' in

octinum 08-27-2005 02:50 PM

I'm sorry for posting this too late, but I solved the problem just an hour later than my previous reply.
I read lilo.conf manual more carefully(i.e. using my brain instead of another part of my body :) ) and found the answer there.
Just add the following in /etc/lilo.conf, under Global section:


Like this:

# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
timeout = 1200

The file goes on of course, this is just the portion you need.
Note: Maybe you will need to do

as root. I did it anyway, because I recompiled my kernel at the same time.

shaiss 02-18-2010 12:28 PM

Im on ubuntu 10.04 alpha 2 and adding compact worked for me. Lilo was showing the dots and taking 10 seconds even though I'm running of a 15k rpm drive.

All times are GMT -5. The time now is 05:50 PM.