-   Linux - Laptop and Netbook (
-   -   LFTP - ls can see files but "get: Access failed: 404 filenotfound (.\ReadMe.txt)" occ (

MatthewSmith 08-01-2012 04:36 PM

LFTP - ls can see files but "get: Access failed: 404 filenotfound (.\ReadMe.txt)" occ
I'm trying to develop an automatic downloader to work for auto-retrieving virus definitions.
Using lftp (LFTP | Version 4.0.7) running on Cygwin (1.5.10), (unfortunately on top of Windows XP SPLatest...)
I can login to the web site ok (Symantec, using anonymous account they advertise), and can drill down to eg:
lftp> pwd

and can see files ok: (after a little SNIPing...)
lftp> ls
-rw-r--r-- -- /mwg-internal/de5fs23hu73ds/files/javascript/sw.js
-rw-r--r-- -- /mwg-internal/de5fs23hu73ds/files/default/img/bg_titlebar.gif
drwxr-xr-x -- /public/english_us_canada/liveupdate/mac_liveupdate/updates
-rw-r--r-- -- CurrentVersion.txt
-rw-r--r-- --
drwxr-xr-x -- OldVersions
-rw-r--r-- -- ReadMe.txt
and have a local folder with permissions all set ok. (admin account on my local pc helps)
lftp> lcd LUTest/test
lcd ok, local cwd=/home/masmith2/LUTest/test


when I try to actually download a file - I get 404 file not found.

lftp> get1 -a ReadMe.txt
get1: Access failed: 404 filenotfound (ReadMe.txt)

I am hiding behind a boeing proxy server, but that's set up ok (before that, the lftp ls command didn't work.)
I've tried various flavors of get1 ./ReadMe.txt, verified case, all the simple things...

I've tried already.
I can access the ReadMe.txt and others thru Tnternet Exploder on the same computer at the same time no problem at all.

Any Thoughts????

lithos 08-02-2012 09:32 AM


I don't know of "get1" command in lftp (neither lftp in Cygwin)
but on my CentOS machine this gets me the file complete download

lftp -c "get -c"

or with:


MatthewSmith 08-02-2012 03:32 PM

get1 - get 1 file: settings list.
get1 is documented in the man page, also, as transfer a single file.
"First make it work, then make it work well..."

My suspicion is that there's a setting in the lftp settings that's not working well with my corporate proxy server, which I know will let me get the file with eg. Internet Explorer's ftp access.

lftp settings below. ( passwords obscured, irrelevancies like screen color and torrent removed from list.

hopefully irrelevant prompts and such removed - they trip the images filter on this site.

set bmk:auto-sync yes
set bmk:save-passwords no
set cache:cache-empty-listings no
set cache:enable yes
set cache:expire 60m
set cache:expire-negative 1m
set cache:size 16M
set cmd:at-exit ""
set cmd:cls-completion-default -FB
set cmd:cls-default -F
set cmd:csh-history off
set cmd:default-protocol ftp
set cmd:fail-exit no
set cmd:interactive no
set cmd:long-running 30
set cmd:ls-default ""
set cmd:move-background yes
set cmd:move-background-detach yes
set cmd:parallel 1
set cmd:prompt "lftp removed to prevent images trip
set cmd:queue-parallel 1
set cmd:remote-completion on
set cmd:save-cwd-history yes
set cmd:save-rl-history yes
set cmd:set-term-status no
set cmd:status-interval 0.8s
set cmd:stifle-rl-history 500
set cmd:term-status ""
set cmd:term-status/*rxvt* removed to prevent images trip
set cmd:term-status/*screen* removed to prevent images trip
set cmd:term-status/*xterm* removed to prevent images trip
set cmd:time-style removed to prevent smileys...
set cmd:trace no
set cmd:verbose no
set cmd:verify-host yes
set cmd:verify-path yes
set cmd:verify-path-cached no
set dns:SRV-query no
set dns:cache-enable yes
set dns:cache-expire 1h
set dns:cache-size 256
set dns:fatal-timeout 7d
set dns:max-retries 1000
set dns:order inet
set dns:use-fork yes
set file:charset UTF-8
set ftp:abor-max-wait 15s
set ftp:acct ""
set ftp:anon-pass xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
set ftp:anon-user xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
set ftp:auto-passive-mode yes
set ftp:auto-sync-mode "icrosoft FTP Service|MadGoat|MikroTik"
set ftp:bind-data-socket yes
set ftp:charset ""
set ftp:client lftp/4.0.7
set ftp:device-prefix no
set ftp:fix-pasv-address yes
set ftp:fxp-force no
set ftp:fxp-passive-source no
set ftp:fxp-passive-sscn yes
set ftp:home ""
set ftp:ignore-pasv-address no
set ftp:lang ""
set ftp:list-empty-ok no
set ftp:list-options ""
set ftp:nop-interval 120
set ftp:passive-mode on
set ftp:port-ipv4 ""
set ftp:port-range full
set ftp:prefer-epsv no
set ftp:proxy
set ftp:proxy-auth-type user
set ftp:rest-list no
set ftp:rest-stor yes
set ftp:retry-530 "too many ... removed "
set ftp:retry-530-anonymous "Login incorrect"
set ftp:site-group ""
set ftp:skey-allow yes
set ftp:skey-force no
set ftp:ssl-allow yes
set ftp:ssl-allow-anonymous no
set ftp:ssl-auth TLS
set ftp:ssl-copy-sid yes
set ftp:ssl-data-use-keys yes
set ftp:ssl-force no
set ftp:ssl-protect-data no
set ftp:ssl-protect-fxp no
set ftp:ssl-protect-list yes
set ftp:ssl-shutdown-timeout 5
set ftp:ssl-use-ccc no
set ftp:stat-interval 1
set ftp:sync-mode on
set ftp:timezone GMT
set ftp:trust-feat no
set ftp:use-abor yes
set ftp:use-allo yes
set ftp:use-feat yes
set ftp:use-fxp yes
set ftp:use-hftp yes
set ftp:use-mdtm yes
set ftp:use-mdtm-overloaded no
set ftp:use-mlsd no
set ftp:use-pret yes
set ftp:use-quit yes
set ftp:use-site-chmod yes
set ftp:use-site-idle no
set ftp:use-site-utime yes
set ftp:use-site-utime2 yes
set ftp:use-size yes
set ftp:use-stat yes
set ftp:use-stat-for-list no
set ftp:use-telnet-iac yes
set ftp:verify-address no
set ftp:verify-port no
set ftp:waiting-150-timeout 5
set ftp:web-mode off
set ftps:initial-prot ""
set hftp:cache yes
set hftp:cache-control ""
set hftp:proxy ""
set hftp:use-authorization yes
set hftp:use-head yes
set hftp:use-mkcol no
set hftp:use-propfind no
set hftp:use-type yes
set http:accept */*
set http:accept-charset ""
set http:accept-language ""
set http:authorization ""
set http:cache yes
set http:cache-control ""
set http:cookie ""
set http:post-content-type application/x-www-form-urlencoded
set http:proxy ""
set http:put-content-type ""
set http:put-method PUT
set http:referer ""
set http:set-cookies no
set http:use-mkcol yes
set http:use-propfind no
set http:user-agent lftp/4.0.7
set https:proxy ""
set mirror:dereference no
set mirror:exclude-regex "removed to prevent smileys..."
set mirror:include-regex ""
set mirror:order "*.sfv *.sig *.md5* *.sum * */"
set mirror:parallel-directories yes
set mirror:parallel-transfer-count 1
set mirror:set-permissions yes
set mirror:skip-noaccess no
set mirror:use-pget-n 1
set module:path /usr/lib/lftp/4.0.7:/usr/lib/lftp
set net:connection-limit 0
set net:connection-takeover yes
set net:idle 3m
set net:limit-max 0
set net:limit-rate 0:0
set net:limit-total-max 0
set net:limit-total-rate 0:0
set net:max-retries 1000
set net:no-proxy ""
set net:persist-retries 0
set net:reconnect-interval-base 30
set net:reconnect-interval-max 600
set net:reconnect-interval-multiplier 1.5
set net:socket-bind-ipv4 ""
set net:socket-bind-ipv6 ""
set net:socket-buffer 0
set net:socket-maxseg 0
set net:timeout 5m
set pget:default-n 5
set pget:save-status 10s
set sftp:charset ""
set sftp:connect-program "ssh -a -x"
set sftp:max-packets-in-flight 16
set sftp:protocol-version 4
set sftp:server-program sftp
set sftp:size-read 32k
set sftp:size-write 32k
set sftp:use-full-path yes
set ssl:ca-file ""
set ssl:ca-path ""
set ssl:cert-file ""
set ssl:check-hostname yes
set ssl:crl-file ""
set ssl:crl-path ""
set ssl:key-file ""
set ssl:verify-certificate no
set xfer:auto-rename no
set xfer:buffer-size 0x10000
set xfer:clobber no
set xfer:destination-directory ""
set xfer:disk-full-fatal no
set xfer:eta-period 120
set xfer:eta-terse yes
set xfer:log yes
set xfer:make-backup yes
set xfer:max-redirections 10
set xfer:rate-period 15
set xfer:verify no
set xfer:verify-command /usr/share/lftp/verify-file

All times are GMT -5. The time now is 04:57 AM.