LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Lenovo w520 with ubuntu 12.04 stuck on native resolution (1920 x 1080) (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/lenovo-w520-with-ubuntu-12-04-stuck-on-native-resolution-1920-x-1080-a-4175454214/)

ABitTooSpicy 03-15-2013 11:41 AM

Lenovo w520 with ubuntu 12.04 stuck on native resolution (1920 x 1080)
 
Laptop: Lenovo w520
Nvidia Driver version: 304.64

I just upgraded from Ubuntu 11.10 to 12.04 and I can no longer change my resolution. My laptop is a Lenovo w520, Nvidia X Server Settings reports 1920 x 1080 as the only option. Which is normally fine but doesn't work when I connect to a projector with lower resolution, as cloning only clones part of the screen to the projection and presentations look pretty messed up!

This used to work fine with 11.10 not sure what changed...

Tried a fix I found for a similar issues but it did not work. I used the nvidia X server-settings, saved configuration to X file to create an xorg.conf file. I then added the following line (Option "ModeValidation" "AllowNonEdidModes") to the devices section. This now makes many other resolutions available however none of them work properly. I end up with my desktop duplicated multiple times on the screen anytime I change resolution...

One more thing I tried:

I found a command line option that lets me change the resolution to my laptop:

nvidia-settings --assign CurrentMetaMode="LVDS-0: nvidia-auto-select @1280x1024 +0 +0 {ViewPortIn=1280x1024, ViewPortOut=1440x1080+240+0}, DVI-I-0: nvidia-auto-select @1280x1024 +0 +0"

However if I try to clone or change the resolution on the external monitor VGA-0, then the laptop LVDS-0 goes back to the default 1920x1080. Is there a way for me to do the nvidia-settings --assign command that lets me hit both displays in one shot instead of having to do them one at a time?

I'm so close I can feel it!!!...

ABitTooSpicy 03-15-2013 01:00 PM

FIGURED IT OUT!!


nvidia-settings --assign CurrentMetaMode="LVDS-0: nvidia-auto-select @1280x1024 +0 +0 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+240+0}, VGA-0: nvidia-auto-select @1280x1024 +0 +0"

I realized that xrandr was showing my 2 displays as LVDS-0 and VGA-0 and I was putting in DVI... so obviously it wouldn't work! Hopefully this helps someone else as well! =)


All times are GMT -5. The time now is 05:16 PM.