LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 03-09-2016, 09:46 AM   #1
LeoZhekov
LQ Newbie
 
Registered: Mar 2016
Distribution: Mint 17.3 KDE
Posts: 2

Rep: Reputation: Disabled
Lenovo G50-70 video drivers on Mint 17.3 KDE


I am having difficulties setting up the video drivers on my Lenovo G50-70 running Mint 17.3 KDE. I've tried a lot of stuff. I've set th driver to the closed one, but still shows me only the Intel HD graphics. I am trying to run Minecraft and it says that I don't have OpenGL installed. I believe the AMD card is not detected at all and doesn't move a damn bit to help out the fellow Intel card.. What can I do to get at least OpenGL to work so I can play games (not just Minecraft)?
 
Old 03-09-2016, 11:31 AM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,408
Blog Entries: 10

Rep: Reputation: 866Reputation: 866Reputation: 866Reputation: 866Reputation: 866Reputation: 866Reputation: 866
LeoZhekov,

Welcome to LQ.

Mesa/OpenGL drivers from:
https://launchpad.net/~oibaf/+archiv...aphics-drivers

NB Supported Ubuntu versions:
- 14.04 (trusty) <- only 14.04 and 14.04.1 are supported. 14.04.2 and later are not supported.

I am assuming that Mint 17.3 is based on 14.04 or 14.04.1 but I am not certain.

**Can somebody else confirm this please?

This link has more information:

http://askubuntu.com/questions/50156...untu-14-04-lts
 
Old 03-09-2016, 12:41 PM   #3
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by beachboy2 View Post
I am assuming that Mint 17.3 is based on 14.04 or 14.04.1 but I am not certain.

**Can somebody else confirm this please?
Hi beachboy2...

You are correct. The package base is 14.04 and the kernel version is 3.19.

@LeoZhekov: I understand that you're having difficulties but please watch the language.

Regards...

Last edited by ardvark71; 03-09-2016 at 12:48 PM. Reason: Changed wording/Added request.
 
Old 03-09-2016, 01:25 PM   #4
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,408
Blog Entries: 10

Rep: Reputation: 866Reputation: 866Reputation: 866Reputation: 866Reputation: 866Reputation: 866Reputation: 866
ardvark71,

Thanks.
 
Old 03-09-2016, 02:59 PM   #5
LeoZhekov
LQ Newbie
 
Registered: Mar 2016
Distribution: Mint 17.3 KDE
Posts: 2

Original Poster
Rep: Reputation: Disabled
I installed the mesa things in the first link, but still could not run it. It showed an error:
Quote:
The program 'java' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
(Details: serial 410 error_code 143 request_code 139 minor_code 7)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

@ardvark71
What language????
 
Old 03-09-2016, 05:50 PM   #6
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by LeoZhekov View Post
What language????
The "d" word in your fifth sentence.

Regards...
 
Old 03-09-2016, 05:51 PM   #7
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,279
Blog Entries: 3

Rep: Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838Reputation: 838
Quote:
Originally Posted by beachboy2 View Post
Thanks.
You're welcome.

Regards...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Start problem on lenovo G50-70 LukeBaccio Linux - Laptop and Netbook 3 12-24-2015 08:24 AM
Lenovo G50-70 no auto fan speed Dobigeon Linux - Laptop and Netbook 2 04-02-2015 11:45 AM
[SOLVED] RTL8723BE Lenovo G50-70 jobalcaen Linux - Laptop and Netbook 4 02-17-2015 02:07 PM
[SOLVED] Slackware64 on Lenovo g50-70: no sound TheWormKill Slackware 7 08-09-2014 08:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration