LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 02-14-2014, 05:17 AM   #31
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 176

Rep: Reputation: Disabled

the gnome keyring does not store the passwords as plain text. they are encrypted.

but it does sound similar to your problem.
 
Old 02-14-2014, 06:02 PM   #32
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
Does Xubuntu also use gnome? Yes, it sounds similar to my problem but my concern is this was submitted four years ago. Would the suggested information still apply today?
 
Old 02-14-2014, 06:10 PM   #33
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 176

Rep: Reputation: Disabled
xubuntu uses the gnome keyring yes. a lot of distros do. don't get too hung up on gnome in the name. it refers to the libraries it uses.

I don't know how to check, but if you could get a list of the passwords stored by the keyring, you may find your solution. (or more mystery )

there is an app called "seahorse' that may be beneficial here. it supposedly can manage the keyring in a gui.
 
Old 02-14-2014, 11:47 PM   #34
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
This seemed to be promising but when I typed in the recommended script, nothing happened.

https://bugs.launchpad.net/ubuntu/+s...g/+bug/1022322
 
Old 02-15-2014, 12:58 AM   #35
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
It appears that I am dealing with a bug in the network manager--and by extension the gnome keyring. This is a bug that goes way back and I'm surprised no one has resolved it by now. What to do? The curious thing here is that when I close the laptop lid, while the computer is still on, as soon as I reopen it, the wifi clicks in instantly. My question is how to accomplish that login process without closing the lid! Does someone know what is accomplished by closing the lid? If so, we can maybe figure out how to replicate that procedure at the initial login.
 
Old 02-15-2014, 06:15 AM   #36
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 176

Rep: Reputation: Disabled
my guess is you could do the same by restarting the networking system. Its hard to say.
.
On my system (debian, not ubuntu, you command may be slightly different), I can run.

Code:
/etc/init.d/networking restart
and the network modules will all restart. I expect that would do what you want if that command works in ubuntu.


you could also try taking the interface down and then back up:

Code:
ifconfig wlan0 down
ifconfig wlan0 up
assuming that your interface is named wlan0.

One other thing you could try is disabling networking in the network-manager right click menu, and then re-enabling. Or restarting the network-manager service.

Code:
service network-manager restart
If that work you may find this linked article helpful. You could set up a script that does this automatically on boot maybe just a menu entry that makes it handy.

http://askubuntu.com/questions/14210...m-the-terminal
 
Old 02-15-2014, 05:02 PM   #37
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
Aha!...Okay. What I found is that by right clicking on the network manager and then disabling and then re-enabling the network, my computer went directly online! Great! Bravo! Incidentally, there was no response from "service network-manager restart" or the other scripts mentioned. So we are getting warmer here. Thanks so much for your patience and persistence. So how can I now accomplish this disable-re-enable function so that it happens automatically? Notice that both in closing and opening the lid and also with "disable/re-enable" function, doing anything about the bum password was never necessary. So what does it mean that my system always defaults to the wrong password, but at some level must know the "correct" one?
Thank you again!
 
Old 02-15-2014, 09:35 PM   #38
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 176

Rep: Reputation: Disabled
I still think the problem is in the keyring. The old password is probably in there somewhere.

I didn't mention it, but the service restart command should be done with sudo

Code:
sudo service network-manager restart
or if that command doesn't work try:

Code:
sudo /etc/init.d/network-manager restart
both actually work on my system, but again I'm debian not ubuntu.

The site you linked to is interesting. It mentions modifying a .desktop file. Did you try that? They are just text files and easy to edit.
 
Old 02-16-2014, 04:34 AM   #39
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
network-manager is just a front end, you don't have to use it. It gets a bit ugly and CLI based without it, but you don't have to use it.

I've got older hardware so I basically can't use it as the drivers are quirky (for wireless). Like the key to the wireless doesn't always get set at the first attempt. So try and try again is status quo. And better left to scripts.
 
Old 02-16-2014, 09:11 PM   #40
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
Well, yes, I have older hardware too. A Lenovo Thinkpad T400. So what is the script you recommend using? The thing is, I'm able to get online simply by disabling and then re-enabling the wireless connection. I'm not using the front end network manager, just right clicking the wifi symbol in the top right corner. That does the trick. If there were a way to get into the keyring as dolphin_oracle suggests, and delete that false password, it would seem the problem could be solved. If other people have this problem why hasn't
it been resolved by previous system updates?
 
Old 02-16-2014, 09:16 PM   #41
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
What about this as an option? Does it make sense?

http://binaryimpulse.com/2013/06/saf...xubuntu-12-04/
 
Old 02-16-2014, 10:06 PM   #42
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 176

Rep: Reputation: Disabled
I don't think removing the keyring is a good option. Removing network-manager might be. You could check out wicd. To give you an idea of it, I've got a video on it (installed on antix by default) here: https://www.youtube.com/watch?v=i8WO8NaM2tM
 
Old 02-17-2014, 12:32 PM   #43
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
I write my own short bash script to set my wifi parms. It comes in handy for traveling as I can pass one parameter and it does the parms for whatever location I setup in the script. Pros and cons. Simple and works, but network authentication information is in plain text in a single file for multiple locations.

In debian, if you define the interface in /etc/network/interfaces, network-manager ignores the device. You can setup pre and post up parts there to run scripts, or put them in /etc/rc.local or /etc/sysctl.conf or whatever works. That's just how I do it.

In a perfect world it would just work, focus on other things. But these old broadcom chipsets. And the firmware that is pulled in from other sources. In my case the firmware debian grabs by default isn't the firmware that works best for my wifi.

To be honest these days I just ethernet into a standalone router in repeater mode and use it as the wifi card. Much simpler and works out of the box. Plus I can relocate it for optimal signal strength. But when I travel the router doesn't fit well in the same case as the laptop. Pros and cons.
 
Old 02-17-2014, 01:57 PM   #44
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
Interesting comments, all. I appreciate the sustained feedback on this topic. Just to clarify to Shadow_7, this problem of getting on wireless occurs only on my home router. Once I'm out at a public wifi hotspot or in a private residence where I need to use their password, there is no problem. The problem is solely with my laptop and my router. It's like they "don't like each other"! It may be the easiest thing for now is just to click on the wifi symbol and do the "disable"/"re-enable" routine. That works and it's simple. I don't know why it works or what the system "learns" by going through "disable"/"re-enable," sequence but it gets things up and running. If I were to opt for the script routine, what is the sequence I would put into the terminal? It would seem that with all the trouble this causes people, someone would find an upgrade that would eliminate all this nonsense so that wifi would "just work"!
 
Old 02-17-2014, 03:06 PM   #45
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
Does that router run linux? Or some propriety thing that has to be rebooted once a week or it gets quirky? The places out and about probably power cycle their router once per 24 hour period. I have to power cycle mine on occassion. That simple M$ solution that still seems to fix most ails. Beyond that upgrade the firmware, and disable UPNP and other things with known security issues.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Laptop won't recognize home router with Xubuntu Yuhan Linux - Laptop and Netbook 2 12-17-2013 11:38 PM
New laptop, connects to router, will not connect to internet BobNutfield General 2 01-12-2013 06:44 PM
Toshiba won't connect to Netgear wireless router.. shirky Linux - Networking 4 02-14-2012 08:04 PM
How do I set up a laptop as a router to connect wirelessly to my ADSL router hairysocks Linux - Networking 12 12-20-2009 06:51 AM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration