-   Linux - Laptop and Netbook (
-   -   Laptop with via chrome9 slackware black screen on boot (

splintercdo 02-02-2011 01:58 PM

Laptop with via chrome9 slackware black screen on boot

decided to start to learn linux for real started setting up slackware going through everything carefuly, now slackware 13.1 is installed,

Lilo boots correctly
I start linux
some information is starting to show up in console
then screen turns black and nothing helps

I can't get working even text console :(

I have suspicion, it might be problem of configuration of x windows, because chrome 9 video card isn't too friendly with linux.

It's so annoying :( Please help,
how can I boot at least in text mode


OK progress is hapening, I booted from DVD and as my installation was on /dev/sda2
i mounted in in /root/la
so now I have access to file system will continue to search

tsg 02-02-2011 02:42 PM

If you can get to your /etc/inittab, change the following line:


# Default runlevel. (Do not set to 0 or 6)



# Default runlevel. (Do not set to 0 or 6)

splintercdo 02-02-2011 03:10 PM

Thanks, for the answer
had to learn a bit to work with vi :)

but interesting fact is that runlevel was already 3, even thou I tried to change it to 4, no result

I guess the problem might not be the video card hmm...

I would appreciate a lot some other suggestions

tsg 02-02-2011 03:14 PM

It could be the video settings in LILO. Try setting vga=normal in your /etc/lilo.conf and run lilo.

splintercdo 02-02-2011 04:16 PM

OK it was hard task to run lilo :)

I changed lilo.conf, but it was impossible to run lilo itself because my sda2 was under /root/la
but lilo even thou ran it from under mounted sda2 tried to use absolute directories for files that it uses for it's job
I changed lilo.conf directory with -C and map file with -m. Than LILO had problems with lilo.bmp :)

I mounted also sda2 under / , slackware showed that mount is successful but with "ls" I could see that it wasn't, SO

I ran again setup, and reinstalled lilo, now slackware is loading without framebuffer, BUT again till the point where it seems to try to switch to x window, and again we have black screen and no signs of life :(

So I guess I have 2 ways
1. Try to look at x configuration, have to find where it is on slack :)
2. Or try to reinstall all system and install just basic packages not full and then move forward from console interface which will show up I hope so in this case.

But now most important thing is to go sleep :)

So, if there are some crazy smart persons, please help ;)

tsg 02-03-2011 08:13 AM

You can tell the boot loader on the install disk (assuming that's how you're booting to get into lilo.conf) to mount the root directory with root=/dev/sda1 (or whatever it happens to be) and you won't have to worry about the mount paths.

If your inittab has level 3 as the initdefault, then I doubt X is the problem, but just in case, the configuration file is /etc/X11/xorg.conf. I would try booting as above and running lilo again just to be sure.

Is there anything in the log files that might give a clue?

splintercdo 02-03-2011 11:28 AM

First thing I'm sorry I am hurrying today very much so didn't had a time to look at laptop more, so now I am running away again, BUT

1. I loaded as you told from install disk (DVD slackware 13.1) (I can't load from my scsi HD) but I already explained situation earlier and how I solved it (AND YES now I have lilo.conf with vga=normal).

2. I looked briefly through xorg.conf (have no time today :( ) and with my little understanding think that there everything is OK nowhere is mentioned anything about VIA just VESA, I guess with vesa I should not have any problems.

3. Thanks for giving me clue to look at log files, so the things are going as follows
(below are endings of log files)

imps2:Auto-detected intellimouse PS/2 (hmm.. that's interesting in setup I showed that I have USB mouse, but anyway when system was booting I didn't had mouse connected, just "synaptic pointing device" integrated in my laptop)

HDA Intel 0000:06:01.0: setting latency timer to 64

then came something more suspicious
viafb: probe of 0000:01:00.00 failed with error -12

and dmesg showed even more
v map allocation for size 134221824 failed: use v malloc = <size> to increase size.
ioremap failed
viafb: probe of 0000:01:00.00 failed with error -12
fuse init(API version 7.13)
lp:driver loaded but no devices found
ppdev: user-space parallel port driver
powernow: This module only work with AMD K7 CPUs
cpufreq-nforce2:No nforce2 chipset

That's all for log files, excuse me if I am something missing but, this was really fast insight and I am running away,

today I fear I won't have any more time to look at anything much more.

Tomorrow I will have time to sit down and look more deeply
Will try to look at error messages of log files.

But for now it would be nice surprise if anybody would give some clue, thanks in advance ;)

splintercdo 02-04-2011 11:18 AM

OK, now I am starting to run out of ideas, It's just impossible

1. I reinstalled system with minimum only A packages
2. I set vmalloc=256M
3. Now all of the log files are empty

But it's persistently giving no signs of life after a bit of loading :(

Only way how I can access files of installed system is to boot from DVD and then mount /dev/sda1 to some directory
It is impossible even to boot in text mode, so

I guess this really isn't x window problem.

H_TeXMeX_H 02-04-2011 11:58 AM

Chrome9 seems to be made by Via. It may work with the vesa drivers.

Please do a full slackware install, I don't see any reason to install just the a packages, unless you want to make things really hard on yourself.

I would get it to boot to the CLI, where you can login, then I would try to deal with the xorg.conf.

splintercdo 02-04-2011 12:39 PM

Man I have no doubt that you are experienced slackware user, but you didn't read this topic,

1. I installed Full package
2. I checked xorg.conf
3. I checked log files
4. I changed malloc
5. I changed lilo configuration to absolute minimum
6. I installed lilo in mbr and first partition
7. I had some problem when created partitions with fdisk and also that is solved now
8. I booted system from DVD and mounted my installed partition to directory to change configuration files and check log files
9. I reinstalled slackware with different package sets and configurations
10. I probably forgot to mention something in this replay that I did


H_TeXMeX_H 02-04-2011 01:13 PM

I did read the entire thread, I really did, now whether I understood it ... that's different.


Originally Posted by splintercdo (Post 4246352)
I ran again setup, and reinstalled lilo, now slackware is loading without framebuffer, BUT again till the point where it seems to try to switch to x window, and again we have black screen and no signs of life :(

To me this suggests that you were able to boot to a login console, you logged in, and then ran "startx" and then everything went black, right ? If not, please correct me.

splintercdo 02-04-2011 01:29 PM

No, no, these were old suspicions about the problem, they are incorrect

here I repost answer from other post to another person:


thank you for an answer,

no my friend I never was able to boot in text mode from hard disk

only way how I can access files of my installed system is if I boot from my installation DVD and then mount my installed system tree under some directory

this way I can to change configuration and look into log files, but that is all, because only apps I can run are from installation DVD

And it seems like dead end at this time

Even thou may be some experienced users might figure out something from the log file text I posted in my previous thread(but the funny[bad way ] thing is that when I installed only A packages - log files were empty)

And now I seriously doubt that this is problem with x windows,

also I have runlevel 3 all the time I even tried to change it to 4


H_TeXMeX_H 02-04-2011 02:04 PM

I see, well see:

I would try blacklisting viafb.

splintercdo 02-04-2011 03:21 PM


THANK YOU SO MUCH! You see I didn't had doubts that you are experienced user.

Now I have fully functioning KDE desktop.

Actually it's funny that solution was so simple, but I paste so much effort, but I don't feel bitter not a bit, I said I want to learn linux for real and it's great that there are people willing to help, it was good experience.

Will get a bit better and will start to help others

P.S. Oh yeah - what I did is:

I edited file: /etc/modeprobe.d/blacklist.conf I added viafb to the list of blacklisted framebuffers

H_TeXMeX_H I shake your hand! :)

H_TeXMeX_H 02-05-2011 08:07 AM

Cool, so it worked, glad to hear it :)

All times are GMT -5. The time now is 12:58 AM.