LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 08-04-2008, 09:54 PM   #1
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Rep: Reputation: 30
Laptop typing problem


My Compaq Presario 2100 -5+ years old- is having typing problems.
The cursor jumps around while typing.
I'll be typing then suddenly the cursor moves to a different line and begins inserting text there. It's doing it now as I type this. Does it also in Open Office, Thunderbird and kwrite.

Is it the keyboard?
The graphics card?
The screen
Or ????


I'm using Mandriva 2008.
Did a --auto-update last night... didn't help.

Where do I start looking?
Any help appreciated.
 
Old 08-05-2008, 01:37 AM   #2
everest40
Member
 
Registered: Jul 2008
Distribution: Ubuntu $LATESTVERSION
Posts: 168

Rep: Reputation: 67
I'd guess that you're accidentally touching your laptop's touch pad as you type, which the computer then interprets as a tap or click. You might try touchfreeze as a solution.
 
Old 08-05-2008, 01:55 AM   #3
BugZRevengE
Member
 
Registered: Oct 2005
Location: Australia
Distribution: Slackware & Kubuntu & CentOS
Posts: 106

Rep: Reputation: 17
I have had this problem under both linux and windows on several laptops... it tends to be the built in mouse device (touchpad, or whatever). As they get older, they often become more sensitive, and if you put any pressure on the palm-rest around the touchpad, it makes the mouse move and/or click.
Very frustating (Dell had an issue with a particular model, that was fixed by a bios update - so check to see if updating bios helps), otherwise I disabled the touchpad in bios, and used an external mouse (which I prefer for anything more then 5 minutes)

everest40 - nice find! It could be very useful!

Last edited by BugZRevengE; 08-05-2008 at 01:58 AM. Reason: everest40 beat me to the post - and the tool linked is nice!
 
Old 08-05-2008, 05:00 AM   #4
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 73
Syndaemon also temporarily turns off the touch pad when typing, it is included with the synaptics drivers, so no extra installation is needed.

I added this to my .xinitrc so it is loaded when X loads.
Code:
syndaemon -i 1.5 -d -t -K
Here are all of the options.
Code:
Usage: syndaemon [-i idle-time] [-d] [-t] [-k]
  -i How many seconds to wait after the last key press before
     enabling the touchpad. (default is 2.0s)
  -d Start as a daemon, ie in the background.
  -p Create a pid file with the specified name.
  -t Only disable tapping and scrolling, not mouse movements.
  -k Ignore modifier keys when monitoring keyboard activity.
  -K Like -k but also ignore Modifier+Key combos.
 
Old 08-06-2008, 09:33 PM   #5
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Where is the .xinitrc file located?
I looked several places but did not find it.
I've never used the mousepad.
 
Old 08-06-2008, 10:05 PM   #6
BugZRevengE
Member
 
Registered: Oct 2005
Location: Australia
Distribution: Slackware & Kubuntu & CentOS
Posts: 106

Rep: Reputation: 17
.xinitrc file is created in your home directory: /home/USERNAME/.xinitrc
if it does not exist, you can create it yourself...
However your .xinitrc is only read if you are logging in from the command line and running startx
If you log in from a gui X based login screen, then you will need to use the file .xsession again, created in your home directory

If you are not using the trackpad/mouse thing, then you would be best of to disable it completely... either in a BIOS option, or in your xorg.conf file looking at the synaptics pointer device.
 
Old 08-10-2008, 07:35 PM   #7
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
The most likely cause of the problem is ghosts are messing with your touchpad. Touchfreeze will keep them from doing that.
 
Old 08-13-2008, 10:24 AM   #8
dennisk
Member
 
Registered: May 2004
Location: Southwestern USA
Distribution: CentOS
Posts: 279

Rep: Reputation: 30
If your touchpad is a synaptics see the synaptics man page for the to turn off tapping and scrolling. This will prevent any stray taps from disrupting your typing.

dennisk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem typing in applications emer_son Linux - Newbie 1 07-03-2008 02:33 PM
Laptop typing spontaneously turns Caps on ksmuller Linux - Laptop and Netbook 1 11-16-2007 06:03 PM
Keyboard typing problem dc11 Linux - Software 2 01-28-2006 12:20 AM
problem after typing startx kool_kid Slackware 2 02-05-2005 07:22 PM
having typing problem onlyhuman9 Linux - Laptop and Netbook 1 08-03-2003 08:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 09:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration