-   Linux - Laptop and Netbook (
-   -   Laptop restarts instead of shutting down -- running Fedora 9 (

CFDingman 03-03-2009 11:45 PM

Laptop restarts instead of shutting down -- running Fedora 9
I am gradually learning to run Fedora 9 on my Toshiba Satellite M305D-S4830. Recent kernel upgrades have ended problems with wi-fi, etc., but at some point in recent weeks the machine stopped shutting down, no matter what I ask. If I click system-shutdown-shut down in Gnome menus, the computer restarts instead. Choosing restart produces the same behaviour. Likewise sudo shutdown now -P. Likewise halt. I stop it by entering and of these commands, then waiting for the shut-down to complete and the restarting to begin, then entering the grub menu and forcing it off with the power button.

Likewise, if I try to hibernate, it goes through the sleep sequence up to a point but then tries to restart right away - with mixed results, but never a power off condition.

Only slightly related thing I might have done to cause this, as far as I can recall, would be fooling with the quirks database to try (unsuccessfully) to get hibernate or standby to work right. However, when I run the quirk-checking script, it tells me I have no quirks, so I don't think I've done anything to alter the normal state of this installation.

Any hints on how to troubleshoot this?



j-ray 03-04-2009 03:35 AM

I would take a look at the BIOS because I don't have a better idea...
Someone who knows better told me that you have to exchange the bios firmware chip.
Good luck,

JacekZ 03-14-2009 05:13 PM

I doubt it is your BIOS. I had a F9 machine that shut down or hibernated fine. Installed F10 and shut down works OK but hibernate results in an instant reboot at the end of the going to bed process. I have to use the power button to make it switch off. The computer is a Dell Inspiron 530 which has hardware tailored for linux. So I tried ubuntu intrepid ibex and guess what - same problem trying to hibernate! So I'm back with F10, tried installing by both pre-upgrade and by full distro disk. Same result each time. But I did notice that hibernation did work on the clean reinstall, until I did the full yum update. After that the problem resurfaces. I note that on an old laptop with non-linux friendly hardware, hibernation works fine! My best guess is the kernel is to blame, but I'm no expert. In case it helps anyone advise, I have noted that when the machine makes the unwelcome auto-restart, there is a screen message: booting from CD. There is of course no CD in the drive. During the installation process on both Fedora and Ubutu, it was not possible to take the disk out of the drive prior to the reboot phase at the end of the installation. It is as though something thinks the installation CD is still in the drive!


All times are GMT -5. The time now is 09:30 AM.