-   Linux - Laptop and Netbook (
-   -   Laptop battery dead? Worked for months but sudden apparent failure! (

the_variant 06-02-2005 04:00 PM

Laptop battery dead? Worked for months but sudden apparent failure!
A quick introduction before I ask my question, Im Alan from Shetland (currently living in Sundsvall, Sweden though) and I have used GNU Gentoo for about four years now I think. Anyway, here is my question:

I think my laptop battery might be dead, the charge has dissapeared while switched off two nights in a row and now the battery no longer shows up in the system monitors! The battery module is loaded correctly and syslog-ng registers the pluging in/out of the ac adaptor. ls /proc/acpi/battery/ is empty. the battery works anyway for a few minnits if i unplug ac adaptor...

I can't see anything really obvious in the logs but there is this cryptic message a lot:

May 29 11:20:44 a4lv ACPI-0272: *** Error: Thread 2D9D cannot release Mutex [MUT1] acquired by thread 2D9E
May 29 11:20:44 a4lv ACPI-1138: *** Error: Method execution failed [\_SB_.RDEC] (Node cbfc3680), AE_AML_NOT_O

as you can see, that was a while ago, here is annother more recent log entry:

Jun 2 18:17:18 a4lv ACPI: AC Adapter [AC] (on-line)
Jun 2 18:17:18 a4lv ACPI: Battery Slot [BAT1] (battery present)

but /proc/acpi/battery/ is still empty and the sys monitors still register nothing :(

This is pretty crap seeing as its a new laptop!

Toshiba satellite pro A60 celeron 2.8G/hz kernel = 2.6.11-gentoo-r4

Please help!

I have had the lappy plugged into AC for two weeks now but the problem surfaced the past two days only.

mikejac69 06-02-2005 05:07 PM

Had a similar prob with an old lappie under Windows, turned out that the battery was incorrectly showing as discharged! All I needed to do was to reboot the comp each time it turned itself off (it was alos doing this every 5 mins) up until the point when the comp would not boot at all (battery totally flat) hope that this is the only problem with your almost brand new Lappie, if not, sounds like it needs to go back to whence it came!

All times are GMT -5. The time now is 01:56 AM.