-   Linux - Laptop and Netbook (
-   -   KUbuntu 7.05 with 2.6.20-17-generic kernel on Thinkpad 600E running 4x faster (

AndrzejL 09-27-2008 06:51 PM

KUbuntu 7.05 with 2.6.20-17-generic kernel on Thinkpad 600E running 4x faster
Hello Everyone!

I own IBM ThinkPad 600E that I have purchased recently. Its an old and slow machine so I was not sure will it run unix-like OS. It does. I have tried all of mine linux install and I have found out that sound and graphic are known and common problem on this machine. PCLOS 2008 MiniMe, Backtrack II and III beta, etc. etc. all of them were very ¨quiet¨ distros. I read many threads on many forums and I have found out that the biggest percentage of solved cases on this machine is with Ubuntu Kubuntu and Xubuntu. I have decided to use Ubuntu in 7.04 or 7.10 that I have in my stack of cds. No way. Boots up with errors and I have read plenty of ¨how tos¨ but still no go. I cant download the text mode installer as I am using very weird internet connection which is preety expensive while downloading a lot of data. I have tried my KUbuntu 7.05 and BINGO. It works. No sound and sluggish graphics were not a problem since I have found this thread But then I have rebooted the system and was testing my sound and it seems not only that my 330 MHz 128 MB ram machine can play a sound but it plays it very fast :). Maybe even too fast for me. The effect is similiar to an old tape players that someone switched to double speed playback. 2 minutes of a song played in 30 seconds :). New world record :P? And then I have realised that this is not only case with sound. When I am typing a command sudo it can look like sssssuuudddddddooooo as my keyboard is trying to beat the world speed record as well. My clock is doing the same thing. 1 normal minute in this world lasts for 60 seconds. Clock on my TP is gone mad as 1 minute = 15 seconds there. I have been testing it with stopwatch.

I am using KUbuntu 7.05 with 2.6.20-17-generic kernel. Tested with uname -r command

The machine is IBM ThinkPad 600E 330 MHz 128 MB Neomagic graphics and problematic sound card

Internet connection? Prepaid Nokia N73 in Irish network connected via USB and dialed by kppp with 1GB for 10euro addons.

Steps to recreate problem?

2) Downloading full upgrade (173 updates) via Adept Manager

Does anybody knows how to fix this problem?

Please do not hasitate to ask any additional questions.

Thank you in advance


Btw this doesnt work for me.

Btw 2: Now after each reboot kDessktop keeps crashing with 2 nasty popup windows

Eric Elliott 09-28-2008 05:43 PM

No brain possible cure, is update to latest kernel using adept_manager. Kernels are not large files to download.
Your system seems to run at 2X or 4X speed but still does correct timings to connect thru Internet. Interesting. Why are what parts of your computer not seeming to use correct speeds?
Problem could be hardware. Have you checked what speeds the BIOS lists as in use before Linux loads? Memtest86 is in standard Kubuntu installation. It loads after BIOS, before Linux & does list hardwares and speeds
I have 1 MOBO that does not use same speeds & timing at each boot, Memtest86 caught that problem.
Your System menu has utilities that show hardware found by kernel. Command lspci does same in Konsole.
When you get this far you should know if hardware or BIOS is not starting correctly, if Linux is finding correct hardware and have some idea if correct drivers are being used.
Loading other distro that worked quietly, then checking speeds, hardware found and drivers in use may yield some clues.
It seems you would want to have Kubuntu 8+ & Debian 4 DVDs shipped to you. Kubuntu as familiar and capable of installing your sound hardware. Debian as being more stable, less likely to have problems due to hardware not detected or driven correctly.
I have had problems come with updates of Kubuntu, found no cure for problems included with updates, then problems leave with later update. Mostly those were sound & video problems in Thinkpad. A little later kernel may not have same problem.

AndrzejL 10-12-2008 12:32 PM

Hi Lads.

Eric Elliott thank You for Your fast reply. I really appreciate Your help and please forgive me for taking my time here but I had a serious project to do and I had to install Windows XP Professional on the thinkpad as it was a necessity to acomplish it so I couldnt test my Kubuntu. I was very surprised. Genuine Windows Installation was working very stable on this old machine. I had sound and all that. But I have promised myself that I will get independant from Gates software and I am going to keep this promise... As soon as the project was finised I have decided to redo the system. I do enjoyed the Kubuntu so I am back to it and I have followed the instruction above again.
I am sure that the BIOS is setup to do the non fast boot and all the kernel options were added before booting up from the install CD.

I have been using my Dell Latitude D600 (PCLOS 2008 MiniMe) to post my first message. That is why the timings were correct. What I have noticed during installation of Kubuntu on the IBM machine is that the clock is going with normal speed while running from the install CD. Right after the installation the clock was ok as well. So I started thinking and trying different options and figured that I was the one that have messed up the previous installation. This time I have skipped 2 things from the instructions as I suspected that they might cause trouble.

First one was this as my sound is automatically activated.

¨ Note: On some laptops (at least on mine), the sound devices are not automatically activated, even with BIOS quick boot disabled. This may be a result of using APM instead of ACPI. See the Problem with broken sound on some ThinkPads for more info. Adding the following script (not thoroughly tested!) to /etc/rc.local should enable them:

# activate devices (Thinkpad boots with devices disabled unless "fast boot" is turned off)
# Try the ACPI method first, then if it fails, use APM method.

{echo 'activate' > /sys/devices/pnp0/00:05/resources} || setpnp 0x0e on
{echo 'activate' > /sys/devices/pnp0/00:06/resources} || setpnp 0x0f on

# Now that devices are active, use modprobe to load the drivers.
modprobe snd-cs4236

# You may need to load these modules here instead of in /etc/modules.
# modprobe snd-pcm-oss
# modprobe vvsnd-mixer-oss
# modprobe snd-seq-oss

exit 0¨

and this part as my battery is lasting for 3 mins and I am using laptop on the ACDC adapter all the time.

¨ Power Settings

acpi needed to be disabled, need to use apm.

nano -w /etc/modprobe.d/power

add the following bit of code to the new file:

options apm power_off=1 realmode_power_off=1¨

And my machine flies it!!! DVD, avi, mp4 mp3 k3b cia fbi kgb You name it its running it :D

Thank You again for all Your help and God bless thinkwiki www.

Good Luck


I will check the system after the full upgrade finishes as I dont know will some of the updates not make a mess of my OS :).

The system is up and running after updates :)

Eric Elliott 10-12-2008 06:07 PM

In my old memory is this; last time I loaded Kubuntu 7.1, sound (& some other thing) did not work but after updates all worked properly. Send me an address, I will send the O. S. you want. Or will send at least 2 distributions of your choice. Eric |AT| eric-elliott dot com. Let me know what you need.

Quick boot does not change how OS loads. Quick boot just minimizes hardware checks done by BIOS before boot starts. At least that is what quick boot used to be.

AndrzejL 10-14-2008 06:18 PM

Hi Eric Elliott!

You are the men but I dont want to be a hassle and I dont want to give You any unnecessery expenses like media + cost of sending them. I should be ok with what I have at home specialy that the IBM is only my second laptop that I am using as a spare machine. Its mostly been used with my pcmcia atheros card to check up my wireless network security level :) and to create a backups of my movies/music and other multimedia as I do not like to use the original disks as they might get damaged and even if it happens rare I dont want to use my DELL laptop to do this as I am using it most of the time and do not want to make it sluggish.

2 questions.

1) Cant get skype and dvdshrink in repos. Where could I get them?

2) I am used to use PCLOS 2008 MiniMe which has this cool PCC which stands for PCLOS Config Center which allows me to config all the hardware + my network connection + my internet connection sharing. I would love to use the IBM as a ad-hoc wireless network server but somehow I cant make it to work the way I want to. In PCLOS that was a matter of 3 clicks and downloading 3 tiny programs. Is there a software that will do it for me in Kubuntu? I am annoyed as wireless assistant would not detect my ad-hoc connection and wireless manager does but will not connect to it. Connect button is inactive. This PCC stuff is basicly a drak***** software that is used in mandriva:

drak3d drakedm draklog draksplash
drakauth drakfirewall drakmouse drakTermServ
drakautoinst drakfont draknet_monitor drakupdate_fstab
drakbackup drakgw draknetprofile drakups
drakboot drakhardware draknfs drakuser
drakbug drakhelp drakperm drakvpn
drakbug_report drakhelp_inst drakprinter drakwizard
drakclock drakhosts drakproxy drakx11
drakconf drakids drakroam drakxconf
drakconf.real drakinvictus draksambashare drakxservices
drakconnect drakkeyboard drakscanner drakxtv
drakconsole draklive-install draksec drawpix
drakdisk draklocale draksound

Is there a chance of installing it on Kubuntu?

By the way. Kubuntu aircraick suit works great with my freshly installed madwifi 094 drivers but its bit outdated dont you think? 063 version where the newest one is 093 I guess as my provider blocks aircrack www and not even a proxy will help here.

One more time thanks a lot Eric Elliott.


All times are GMT -5. The time now is 11:05 PM.