LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 07-16-2010, 04:06 AM   #1
Otto Silver
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Rep: Reputation: 0
Korean Keyboard on Kubuntu


I have been trying for almost a week now to get my keyboard to type Hangeul. I tried searching for answers and applying the ideas, but nothing works. I am quite new to Linux, so there are many things that I don't see as obvious.

I managed to get it done in Ubuntu 10.0.4 under Gnome, but K(DE)ubuntu is not playing along. I tried IBus, like in the GDE, but that doesn't do anything. I can't even find IBus to do anything. I tried playing with SCIM, but I don't see any options that lets me chose the keyboard settings I need. Today I tried SKIM, but still not working.

I tried installing extra languages on the system, but as soon as I install Korean, all my menu items in the language preferences turn to Korean, even if I installed another language before Korean. When I try to set English as the default language an update dialogue appears and it keeps on updating seemingly in an endless loop.

I am not Korean and can't use a Korean system, so this is not going to work. Needless to say, with everything being in Korean I can now not make heads or tails of IBus or SCIM or SKIM or even my browser.

Has anyone managed to install a Korean layout on English Kubuntu system?
 
Old 07-16-2010, 11:03 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,846

Rep: Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008Reputation: 2008
I sympathize. Multi-language support can be a pain to set up.

I've found this page to be helpful for general language support information.

http://www.jw-stumpel.nl/stestu.html

Unfortunately, while it's a good overview, it doesn't cover everything.

For CJK, the general steps are to:

1. Ensure that your locale is UTF-8. Most systems use it by default these days. The "locale" command should tell you what you have, with the entries probably looking something like "LANG=en_US.UTF-8" You'll want to keep your locale setting in English.

2. Install an IM framework and an appropriate backend; scim, uim, or the new ibus (not yet mentioned in the above page), and, for you, probably the *-hangul module.

3. Make sure you also have the appropriate gtk and qt immodules for you chosen IM installed. The debian modules for them are as follows. *buntu should be the same or similar.

scim-gtk2-immodule, scim-qtimm,
uim-gtk2.0, uim-qt
ibus-gtk, ibus-qt4

4. Run im-switch to set the framework you want your system to use.

5. Check to be sure your environmental variables are set to use that framework. It's these variables that tell the individual programs which framework to use, so they need to be set correctly. In theory im-switch should do it all for you, but I've personally had a bit of trouble with this. So you may have to manually set them up in your shell's configuration files. The command "env |grep MOD" will tell you what your current settings are. For example, I have this:

GTK_IM_MODULE=uim
QT_IM_MODULE=uim
XMODIFIERS=@im=uim

Generally the IM's are enabled with either shift+space or ctrl+space, but this can be configured in the settings. I can't help you with the details for how they handle hangul though.

Note that the localization (l10n) packages and the corresponding settings in your desktop are a separate thing from the input system. As you discovered, they are for determining which languages the menus and dialogs are displayed in. Your locale setting also affects which localization is used.

The desktop keyboard settings are likewise only marginally important; as they are there mostly for determining the physical layout of the keyboard, and switching between alphabetical layouts. So you'll need to make sure they're set appropriately for English input, but since CJK are handled by the IM, these settings don't apply to them. IOW, if your English input is ok, leave them alone.

Last edited by David the H.; 07-16-2010 at 11:05 AM.
 
Old 07-17-2010, 04:04 AM   #3
Otto Silver
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you. I will use this post as a guide and see if anything new turns up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KUbuntu keyboard and mouse strucks on first log on pradeep2002gs Linux - Newbie 2 11-19-2008 07:23 AM
kubuntu and labtec wireless keyboard/mouse kjf Linux - Hardware 0 11-14-2007 01:08 PM
grub Kubuntu and Ubuntu no keyboard SVwander Linux - Newbie 1 01-31-2007 01:55 PM
korean keyboard layout help ! LinuxNewbie999 Linux - Newbie 2 10-16-2006 03:50 AM
Keyboard locked for main user in Kubuntu Mohtek Linux - Newbie 0 07-28-2006 05:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration