LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 01-20-2010, 07:33 PM   #1
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Rep: Reputation: 0
Keyboard inactive when log in GUI, but active on Console, any command line ??


Hi there !
First, thanks to all who share their solutions. As a newbie, I will share first this problem (!)
After trying to change the keyboard language (Msi Wind 100+, SUSE 10.0) with Yast, reboot and now, the keyboard is inactive when log in GUI (so I cannot log in), but with CTRL + ALT + F2, the keyboard is active on Console. Do you know a command line to "wake up" the keyboard for log in into GUI ??
Please be very explicit, because I am not familiar at all with command line.
 
Old 01-22-2010, 05:55 AM   #2
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Quote:
Originally Posted by Msi100SuSe10 View Post
After trying to change the keyboard language (Msi Wind 100+, SUSE 10.0) with Yast....................
So you need to change the keyboard layout back again , is n't it ?


if you are in Shell i.e. ( when you press ALT + CTRL + F2 )

after logging in, type starx to start GUI.

you have to open this file /etc/X11/xorg.conf

you will find the section
Quote:
Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "latitude"
Option "XkbRules" "xfree86"
EndSection
Since my laptop was DELL latitude model is "latitude".
Keyboard type is "us".

Now change that text with your own laptop information. or else post your laptop company, type , model.

Last edited by raju.mopidevi; 01-22-2010 at 05:57 AM.
 
Old 01-22-2010, 06:07 AM   #3
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
You can edit that file "/etc/X11/xorg.conf" with super user mode.
 
Old 01-22-2010, 09:04 PM   #4
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Hi Raju ,
In Shell, I log in as root user, type startx. Then this lines appear :

xauth : creating new authority file/root/.serverauth.3229

Fatal server error :
Server is already active for display 0
Il this server is no longer running, remove /tmp/.X0-lock
and start again.

Please consult the X.Org Foundation support at http://wiki.X.Org for help.

Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up
/usr/X11R6/bin/xinit : unable to connect to X server
/usr/X11R6/bin/xinit : No such process (errno 3) : Server error.


then it keeps writing theses successive lines every minute.....

rt_ioctl_giwscan.16(16)BSS returned, data length = 1528

rt_ioctl_giwscan.11(11)BSS returned, data length = 1065

rt_ioctl_giwscan.7(7)BSS returned, data length = 732

rt_ioctl_giwscan.15(15)BSS returned, data length = 1530



more ideas ?
 
Old 01-22-2010, 11:19 PM   #5
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
If you are unable to get GUI for superuser, leave it. We don't need GUI. We can make it using command mode itself.

login as SuperUser in command mode.

Code:
$su
password:
#cd /etc/X11
#vi xorg.conf
then find this section
Quote:
Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "latitude"
Option "XkbRules" "xfree86"
EndSection
change keyboard xkbmodel to microsoft natural.
or else
if your system directly connected to internet, follow this step
Code:
sudo yast2 --install x11-input-synaptics
 
Old 01-23-2010, 03:59 AM   #6
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Original Poster
Rep: Reputation: 0
ok.
I follow the steps and
sudo yast2 --install x11-input-synaptics
download ok.
but, Yast is looking to access installation media (CD), but cannot because I do not have cd reader.

Any other step to bypass this one .. ?
 
Old 01-23-2010, 10:10 AM   #7
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
I mentioned two types of solutions,
have you followed first steps ?
Code:
$login:<name>
password:
$su
password:
#vi /etc/X11/xorg.conf
find this section ---
Quote:
Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection
xkbmodel as "104"keys pc. try to change xkbmodel .
 
Old 01-23-2010, 07:19 PM   #8
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Original Poster
Rep: Reputation: 0
yeah, CTRL+Alt+F2 Console, after login in su, I edit the line :
Option "XkbModel" "pc104"
to (as you suggest)
Option "XkbModel" "microsoft natural"


the problem is tha I dont know how to save and quit (in CLI)...

I reboot in CTRL+Alt+F7, by clicking "reboot" in the GUI log in menu.
When I check again the

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection


My editing "microsoft natural" has not saved. The line is still unchanged.
 
Old 01-23-2010, 07:41 PM   #9
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
after going into Vi editor
- press "i" to insert .
- press "esc" after modifying the data , then your cursor goes to end of the page
- type ":wq" to save.
 
Old 01-23-2010, 08:10 PM   #10
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Original Poster
Rep: Reputation: 0
ok.
I did exactly
- press "i" to insert .
edit the line
Option "XkbModel" "microsoft natural"

at the end of the page
- type ":wq" to save. recording (flashy) appear.

then after ..?
 
Old 01-24-2010, 06:02 AM   #11
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Is your screen refreshed after change of keyboard type ?

if yes, then your keyboard model is changed.
 
Old 01-24-2010, 08:05 PM   #12
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Original Poster
Rep: Reputation: 0
after recording,
in CTRL + ALT F1 Console , I write ;

# rug refresh

then a red bar apprear ... Refreshing services .. 100% Succesfully refreshed.


#reboot

when i repeat the steps :

$login:<name>
password:
$su
password:
#vi /etc/X11/xorg.conf


Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us, ca, fr"
Option "XkbModel" "pc104"



... editing was not saved ??
 
Old 01-25-2010, 10:10 AM   #13
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Original Poster
Rep: Reputation: 0
sorry, it seems that each step has a "stone" for me ... thanks for your patience.
Is there any other CLI, more "deadly", that could still save me from a "Restore factory Settings" that erase all data ...?
 
Old 01-25-2010, 10:16 AM   #14
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Quote:
Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "microsoftpro"

Option "XkbRules" "xfree86"
EndSection
My xorg.conf includes these. I don't know , why your data was not saved.
after editing in vi editor, it is better to check there it self.
Code:
$grep XkbLayout /etc/X11/xorg.conf
you must get this
Quote:
Option "XkbLayout" "us"
similarly
Code:
$grep XkbModel /etc/X11/xorg.conf
you must get this
Quote:
Option "XkbModel" "microsoftpro""
If you are able to get like that, then you modified correctly. otherwise not saved.
 
Old 01-25-2010, 09:53 PM   #15
Msi100SuSe10
LQ Newbie
 
Registered: Jan 2010
Posts: 17

Original Poster
Rep: Reputation: 0
I cannot get it saved ...

On another forum, a user suggests to look at logs for Xorg :
less /var/log/Xorg.0.log

Then I get many worrying messages:
about 20 lines mention :

(WW) The directory "/usr//X11R6/lib/X11/fonts ... does not exists. Entry deleted from the path.

Further in the list;
(WW) Warning, couldn't open module rfbkeyb
(II) UnloadModule : "rfbkeyb"
(EE) Failed to load module : "rfbkeyb" (module does not exist, 0)


Should I reinstalled directories for Xorg ??
I only have factory version of openSuSe 10.0, no cd reader, but I can connect to Internet.
 
  


Reply

Tags
command, line, log, msi, suse10


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost console login prompt--neither GUI or command line prompts display JMCraig Red Hat 7 11-14-2008 12:15 PM
can log in from command line but not from GUI logon screen bezdomny Linux - Desktop 1 07-19-2008 08:11 PM
network gui app "active" vs. "inactive" ? Hewson Linux - Newbie 1 12-01-2007 05:01 AM
Neat : After wireless Active, it become Inactive Again yteckong Linux - Wireless Networking 4 05-09-2007 07:00 AM
Can I change the console command line? coopns Linux - Newbie 3 06-16-2004 07:20 PM


All times are GMT -5. The time now is 08:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration