-   Linux - Laptop and Netbook (
-   -   kernel panic after building custom kernel for macbook (

sparrott 06-29-2007 09:41 AM

kernel panic after building custom kernel for macbook

I bought a new macbook and I want to dual boot it with SuSE. I've installed openSuSE 10.2, using the how-to here:

I've compiled a custom kernel but now when I try and boot into linux I get the following:

i8042.c: No controller found.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)

Kernel alive
kernel direct mapping tables up to 10000000 @ 800)-d000

I went into the rescue system using the install cd and there was no lilo.conf in /etc, even tho I put one there after compilation, before I tried to reboot. So I created a new lilo.conf with the following:


append="root=/dev/sda4 quiet sysrq=1"

I also tried with sda3, just incase. And also without the append, so just 'root=/dev/sda4'

and then tried to run lilo but it said something about a read only file system and didn't do anything. When I go back into the rescue console again the lilo.conf file is gone again.

Any ideas on how I can get it to work?


kaz2100 06-29-2007 06:06 PM


I only can guess, however
1. I think your problem is that / cannot be mounted, reason can be either controller, file system or whatever is not supported by kernel, (if supported by module, you need initrd)
2. With rescue disk, I think / is on CD, which is read only. So, wherever you think /etc is not wherever you want.
3. You need to know where your penguin lives. /dev/sda /dev/sdb.... This is where you picked through fdisk. This is not "try and error"

post here
a. what file system and controller you have. and related kernel options
b. cfdisk output

Happy Penguins!

All times are GMT -5. The time now is 01:24 PM.