LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Issues with grub installing on multiple distros (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/issues-with-grub-installing-on-multiple-distros-4175646680/)

TheEzekielProject 01-21-2019 09:54 PM

Issues with grub installing on multiple distros
 
Hello all,

I will just start at the beginning, I have an Asus G751JM that I have been using a few years now without any issues. Suddenly it quit booting. (installed on a 240GB Corsair Neutron GTX ssd) I tried a reinstall and it went through to the installation of grub at which point it failed, and failed to boot. I ran a SMART test and it passed. So I tried some other distros. Same issue. Fails at grub install.

At this point I figured my ssd may just be dying (yes despite smart) as it's maybe 5 years old, so I bought a new one. I am having the same issues with it failing with the installation of grub.

I have tried installing devuan and ubuntu studio on the new drive both failing at grub. Both through the guided installations and manually formatting.

I can chroot into these installations no issues or boot it using SuperGrubDisk2, but I cannot get grub working properly.

Anyone have any ideas what's going on here?

syg00 01-21-2019 10:18 PM

Maybe it's not the SSD at fault - the lapop is at least as old. We have an old HP that occasionally resets itself and defaults back to booting Windows (that never gets used) - I have to go in and change the default back with efibootmgr.
Check your firmware to ensure it hasn't gone and reset options like safeboot back to defaults. Just a stab in the dark ...

TheEzekielProject 01-21-2019 10:45 PM

I checked the firmware settings and nothing has changed. Tried installing in the second hdd bay and same results. It's strange to me that it only has issues with installing grub. Windows boots fine on the machine.

yancek 01-22-2019 06:09 AM

It would be useful if you explained what "failing at grub" means. If you get a message it would be best if you posted it, the entire message as there are numerous reasons a bootloader will fail to install. You indicate windows is working but neglect to indicate which version of windows you are using. That also would be useful information. Are you using and were you using UEFI on the machine, with both windows and whichever Linux you used and now try to use?

colorpurple21859 01-22-2019 06:18 AM

list of items to do:
fast boot disabled in windows 10
secure boot disabled in bios
for uefi system create fat32 partition flagged esp(if it doesn't already exist) mounted at /boot/efi
for gpt drive booting in legacy mode create a 1mb partition flagged grub-bios/boot-bios partition, unformatted/cleared

TheEzekielProject 01-22-2019 01:12 PM

Hello all,

So it looks like I got it working. Here are the steps I took:

• Boot into UbuntuStudio 18.10 Live > Try Ubuntu without installing.
• Open gparted and create the partitions to be installed to(no lvm or encrpytion). I created a 512MB EFI, 512MB boot, 50GB root, 880GB home, and 8GB swap partition. Close gparted
• Run the installer, unselect “Download updates while installing” and unselect the third party software option. Install.
• It once again failed at the installation of grub.
• Quit installation, reboot to the live install usb again
• Mount root and boot to /mnt and /mnt/boot
• Mount virtual filesystems
Code:

for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i mnt$i; done
• Chroot to the system
• Update repos [apt-get update]
• purge grub
Code:

apt-get purge grub-common
• Format the EFI partition from terminal
Code:

mkfs.vfat /dev/sda1
(Not sure this part was necessary, but I read in some other forum and post of someone with a similar issue stating that grub failed to install because it wasn’t formatting the efi partition properly for whatever reason)
• Reinstall grub
Code:

apt-get install grub-pc
This time there were no errors/warnings and it appeared to complete as normal, so I rebooted and It booted Ubuntu Studio as expected.


All times are GMT -5. The time now is 03:35 PM.