LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   iPAQ Synchronizing mayhem (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/ipaq-synchronizing-mayhem-309679/)

Vorik 04-04-2005 02:38 PM

iPAQ Synchronizing mayhem
 
Hi all!

I've got some trouble getting synchronization to work between my iPAQ H2200 and my Kubuntu Linux system with KDE 3.4 (latest versions of all software)

The ultimate goal is to get synchronization of Calendar, tasks and contacts working between Kontact and the iPAQ.

The communication works okay, but I havent got a clue where to go from here.
I'm using RAKI and when I type synce-serial-start it works like a charm.

Okay, so i'm told on the Synce site that I need to install 'pocketpccommunication'.
- Tried to get it through apt-get/synaptic. Isn't there
- Tried to compile it. I cant even get ./configure to finish properly. (Error about cpp)
- Tried kitchensync, but there is no plugin for pocketpc
- Tried configuring it in raki, but get the error : "No synchronizer found for Appointment"
- Tried to configure it in Kontact, but also no connector available that makes sense..

Please help!

Vorik
Netherlands

Vorik 04-12-2005 02:57 PM

Well.. It still doesnt work, but i've got some extra information.

Pocketpccommunication is depreciated, one should use syncekonnector these days.

It doesnt compile because i'm missing some files because i've got kdepim 3.4 installed instead of 3.3...

Now i'm stuck with libkcal.la missing :*(

Greetz,
Vorik

DigitMole 04-27-2005 04:25 PM

How did you get yours to communicate?

My iPaq 2215 just sits there telling me unable to connect.

synce-serial-config (ok reconized usb)
started dccm (via RAKI)
synce-serial-start (wiating for device)

What am I missing ??

DigitMole

Vorik 04-28-2005 09:27 AM

Well, as my ipaq has a startup and sync password started dccm from the commandline...

Then i start synce-serial-start.

Then i start the Activesync app on the ipaq and tap connect.

Thats it if I remember it correctly. Currently, I've given up.

DigitMole 04-29-2005 09:59 AM

Thanks for the reply......

Thats pretty much how I tried it.
still could not get it to communicate.

Think I will wait until better reliability between PocketPC and Linux

Thanks Again

DigitMole

mikolo 05-02-2005 04:58 AM

You need to build module for ipaq , yours kernel doesn't see ipaq.
Better instructions are in HERE

DigitMole 05-04-2005 09:16 PM

Followed Those instructions to the tee.

My Kernel is 2.6.10
It sees my iPaq as a USB jornada 548
/proc/bus/usb/devices sees my iPAQ as vendor 03f0 ProdID=1016
and onlt two E: end points
set-serial-config seees my iPAQ as ttsyUBS0

But It Still just sits there
iPAQ says unable to communicate


DigitMole

Vorik 05-12-2005 07:31 AM

Hi, its me again! ;)

I've tried to make it work on another computer, (Kubuntu 5.04 also).

Still, I'm at the same point, namely Raki stating that "there is no synchronizer for Appointment" in the Configure iPAQ screen.

The same goes for "tasks", "contacts" and the others. (only AvantGo seems to be selectable)

I've tried the howto mikolo suggested, but to no avail.

Any help VERY MUCH appreciated!

Thanks,
Ger.

Edit: By the way, with Multisync and Evolution, synchronization works perfectly. However, i'd like to use the KDE PIM suite fro all my PIM stuff... But the connection seems to be working fine.

forrestcupp 05-15-2005 06:43 PM

Here's how I finally got my ipaq to connect.

I finally found out that your pocketpc has to be disconnected when you start dccm or vdccm. If it is already connected it won't be recognized. After you start dccm, then you connect your ipaq. After it is connected then you run synce-serial-start.

I had so many headaches getting this to connect before I found out that it can't be plugged in when dccm starts. After I found that out, it works like a charm every time.

I still don't know how to get raki to sync anything, though. There is no syncronizer found for anything. I can get multisync to work, though.


I just found out that the new version of raki doesn't support syncing yet except for Avantgo. They are working on integrating Kitchensync with it. Until then we are out of luck.

mabreaux 09-17-2006 04:55 PM

usb conifg of synce
 
How do you determine which usb port the PDA is not and what are they called in Linux? what is that command to use to config synce?

Quote:


breaux-hp-linux-zzvu:/home/mabreaux # synce-serial-start
Connect script failed

synce-serial-start was unable to start the PPP daemon!

Michael



Quote:

Originally Posted by DigitMole
How did you get yours to communicate?

My iPaq 2215 just sits there telling me unable to connect.

synce-serial-config (ok reconized usb)
started dccm (via RAKI)
synce-serial-start (wiating for device)

What am I missing ??

DigitMole



All times are GMT -5. The time now is 10:31 PM.