-   Linux - Laptop and Netbook (
-   -   Internet on HP Mini 2133 running Linux - URGENT! (

givelivelove10 11-25-2012 07:32 PM

Internet on HP Mini 2133 running Linux - URGENT!
I got an HP Mini 2133 for christmas a few years ago and it was running Linux. It works fine, but I did something to it to make it so that when I log in, I have to type "start x" to get it out of a code interface. When it logs in, it shows the normal desktop screen and works fine, the only problem is, there is no internet. I used to have it, but somehow along the lines, it got deleted and I don't anymore. I can't find it anywhere on my computer. How do I re-install the internet, or am I asking the wrong question.


pixellany 11-25-2012 08:06 PM

First, this is NOT urgent---people here work on issues when they feel like it. You'll actually get better response with words like "please".

We'll need to know what version of Linux and what Desktop Environment you are using. Also, how do you connect to the internet---eg cable, DSL, FIOS, etc.

Since you are tuned in to using the terminal, open one up and enter "ifconfig -a"----post the results here.

yancek 11-25-2012 10:39 PM

Your computer came with Suse Linux Enterprise Desktop and if you go to the /etc/inittab file, you should see a line like this near the top:


If the number above is not 5, you should change it to 5 logged in as root.

Post the output of the command suggested above to get help with your internet connection.

givelivelove10 03-06-2014 08:00 PM

Hi- sorry for using Urgent- it was my finals week and I didn't have a computer, but you're right, a little kindness goes a long way :) Thanks for replying.
I usually connect to the internet through wireless to Comcast at home, and my schools wireless connection when at school.
I don't know how to search for the "ifconfig-a" and when I tried nothing comes up. I tried typing this both before typing "startx" and searching but nothings coming up. again, I'm not sure what im doing wrong, though I know im definitely typing something in wrong. I tried opening the Gnometerminal and typed <ifconfig-a> but it says bash:syntax error near unexpected token 'newline'. How should this be typed?

I also tried searching for the /etc/inittab file but also nothing showed up. I don't know if this is because it was deleted or I'm just not searching properly.

Please let me know if you need anymore information. I really do appreciate your help :)

Emerson 03-06-2014 09:33 PM

It is

ifconfig -a
note the space.

givelivelove10 03-09-2014 01:35 PM

Thanks for being so patient and helpful with me. I found the /etc/inittab file and it says id:3:initdefault. It wouldn't let me change it though, I'm assuming that has to be done somewhere else?
Also, when I tried opening the terminal and typing ifconfig -a it says command not recognized. I'm sorry, but im probably going to need a step by step.

timl 03-09-2014 05:24 PM

Hi, did you use the root user to access the /etc/inittab file as yancek suggested? A normal user is not able to modify this file. What error message did you get?

Regarding ifconfig you didn't inadvertently type "ipconfig"? Can you pls copy and paste the actual error message. This is what I get:


[tim@beiderbeck ~]$ ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 98 bytes 13057 (12.7 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 98 bytes 13057 (12.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

p4p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet XX.XX.XX.XX netmask broadcast XX.XX.XX.XX
inet6 fe80::52e5:49ff:fe19:7d55 prefixlen 64 scopeid 0x20<link>
ether 50:e5:49:19:7d:55 txqueuelen 1000 (Ethernet)
RX packets 13599143 bytes 6657394802 (6.2 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 15448867 bytes 9450351961 (8.8 GiB)
TX errors 0 dropped 0 overruns 0 carrier 1 collisions 0
Where I have shown XX.XX.XX.XX you should see your IP address.

When posting, remember to go to "advanced" and use the quote icon to format your output.


All times are GMT -5. The time now is 12:35 AM.