LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Insert Boot-Disk and press any key (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/insert-boot-disk-and-press-any-key-154235/)

computerlady911 03-06-2004 01:21 PM

Insert Boot-Disk and press any key
 
I installed Lindows on my laptop and after rebooting I get: "Insert Boot-Disk and press any key" message. I completly cleaned the disk before starting. Even cleaned the mbr with fdisk /mbr. I searched the forum and could not find anyone getting the same error. Can anyone help?

ProStar Laptop is PIII 933 with 256 ram. Single 10GB Toshiba MK1017gap HD. Sis 630/540 Mobo. Have successfully used SuSE and Mandrake 9.2 on it.

Qzukk 03-06-2004 02:21 PM

Sounds like lindows didn't install a new mbr for some reason. Or, lindows didn't set its partition as bootable and your system is one of those with a bios that demands that you have one bootable partition.

computerlady911 03-06-2004 02:45 PM

I think you are right
 
I had chosen the option of taking over the entire hard drive. I will now try to dual boot with a small Win98/dos partition. See if that works.

Why would Lindows not load lilo in mbr?

I did use cfdisk to see if there was a bootable partition and there was.

computerlady911 03-06-2004 10:11 PM

Fixed!!!
 
Fixed!!! This is what I did. I used cfdisk from my Lindows disk to delete all the partitions. Then, I dug up a win98 boot disk and used fdisk /mbr just in case. Then I used fdisk and created a 50mb partition and used the rest of the hard drive for the other partition. I formatted them and then booted with the install disk. Install went smoothly and it booted fine. I am using it right now.

bLiNdRaGe 10-02-2004 03:29 PM

Help
 
I have that exact same problem, but i haven't yet figured out how to fix it... i have a 333mhz p2 laptop, and i've tried installing Slackware, SuSe, and even ::gulp:: lindows....if you can help me out by giving me in detail how to fix this prob, it would be extremely appreciated...i'm on AIM at Hockeystop01 or e-mail at bLiNdRaGe@3vilPenguin.tk as i don't get to check back at this site regularly...tks

computerlady911 10-02-2004 03:52 PM

Here is a more detailed description of what I did
 
Boy that was a while ago. The best I could figure was that all the different flavors of Linux that I had been messing around with had put conflicting info in my Master Boot Record and they were also using different boot loaders. This is how I fixed it.

Okay, this is what you do: (everything on the machine will be erased.)

Find a win98 boot disk and boot your machine.

At the a:\ type fdisk /mbr (you probably will not get any response from that.)

Then reboot with the same disk and at the a:\ type fdisk (without the /mbr) and remove all partitions you have and reboot.

Run Fdisk again. Create a partition and reboot.

At the a:\ type format c: /s (This will format the C: and make it bootable. This may not be intirely necessary, but it will verify that the disk is in good shape and is bootable.)

After the format is complete, remove the boot disk and see if it boots to a c:\.

Now you can put your Linux Installation disk in and reboot to install.

After tying several different flavors, I am now settled on Mandrake 10.1 community for my laptop. It works far better than any other I have tried. But your system may not be powerful enough. I think they recommend at least an 800mhz machine. My laptop is a ProStar brand, PIII 966, with 256mb of ram and 10GB hard drive. It runs beautifully.

Good luck!

db391 10-04-2004 08:20 AM

nah to fix the problam open fdisk and set the boot partition to be active and then update your lilo

you shouldnt need a dos/win9x boot disk to get yoru linux to work.

computerlady911 10-04-2004 01:56 PM

Tried that
 
I tried that. The partition was already set as bootable. It still didn't boot.

As they say, there is more than one way to skin a cat. There may be a way to clear the mbr using Linux fdisk. But I didn't know how. I knew how with Windows boot disk. So I used the tool I knew. And it did work.


All times are GMT -5. The time now is 12:25 AM.