LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 07-13-2005, 04:12 PM   #1
tall_thor
LQ Newbie
 
Registered: Jul 2005
Location: Denmark
Distribution: RedHat 7.3
Posts: 2

Rep: Reputation: 0
IBM t43 sloow disk. URGENT


Hi,

I have just got a new IBM T43 notebook and I need to run RedHat 7.3 on it as I need to deliver an application for RH7.3.

I have installed 7.3 and it works. However the disk speed is SLOW 2.4 MB/s
when timed with hdparam. I have looked at the hd and I can see that the hd is not using dma. I have tried to setup the hd to use dma but I am not allowed to do that even if I am root.

hdparm -d1 /dev/hda
/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)


I have looked at the pci using lspci and there is alow of unknown devices. I have tried to upgrade to 2.4.31 and the problem remains.
lspci gives:
00:00.0 Host bridge: Intel Corp.: Unknown device 2590
(rev 03)
00:01.0 PCI bridge: Intel Corp.: Unknown device 2591
(rev 03)
00:1c.0 PCI bridge: Intel Corp.: Unknown device 2660
(rev 03)
00:1c.2 PCI bridge: Intel Corp.: Unknown device 2664
(rev 03)
00:1d.0 USB Controller: Intel Corp.: Unknown device
2658 (rev 03)
00:1d.1 USB Controller: Intel Corp.: Unknown device
2659 (rev 03)
00:1d.2 USB Controller: Intel Corp.: Unknown device
265a (rev 03)
00:1d.3 USB Controller: Intel Corp.: Unknown device
265b (rev 03)
00:1d.7 USB Controller: Intel Corp.: Unknown device
265c (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI
Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corp.:
Unknown device 266e (rev 03)
00:1e.3 Modem: Intel Corp.: Unknown device 266d (rev
03)
00:1f.0 ISA bridge: Intel Corp.: Unknown device 2641
(rev 03)
00:1f.2 IDE interface: Intel Corp.: Unknown device
2653 (rev 03)
00:1f.3 SMBus: Intel Corp.: Unknown device 266a (rev
03)
01:00.0 VGA compatible controller: ATI Technologies
Inc: Unknown device 5460
02:00.0 Ethernet controller: Broadcom Corporation:
Unknown device 167d (rev 11)
04:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev
8d)
04:02.0 Network controller: Intel Corp.: Unknown
device 4224 (rev 05)



I have tried to boot knopix and in this case lspci gives:
0000:00:00.0 Host bridge: Intel Corp. Mobile Memory
Controller Hub (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. Mobile Memory
Controller Hub PCI Express Port (rev 03)
0000:00:1c.0 PCI bridge: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1
(rev 03)
0000:00:1c.2 PCI bridge: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3
(rev 03)
0000:00:1d.0 USB Controller: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev
03)
0000:00:1d.1 USB Controller: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev
03)
0000:00:1d.2 USB Controller: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev
03)
0000:00:1d.3 USB Controller: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev
03)
0000:00:1d.7 USB Controller: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI
Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge
(rev d3)
0000:00:1e.2 Multimedia audio controller: Intel Corp.
82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio
Controller (rev 03)
0000:00:1e.3 Modem: Intel Corp. 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Modem Controller (rev 03)
0000:00:1f.0 ISA bridge: Intel Corp. 82801FBM (ICH6M)
LPC Interface Bridge (rev 03)
0000:00:1f.2 IDE interface: Intel Corp. 82801FBM
(ICH6M) SATA Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801FB/FBM/FR/FW/FRW
(ICH6 Family) SMBus Controller (rev 03)
0000:01:00.0 VGA compatible controller: ATI
Technologies Inc: Unknown device 5460
0000:02:00.0 Ethernet controller: Broadcom
Corporation: Unknown device 167d (rev 11)
0000:04:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II
(rev 8d)
0000:04:02.0 Network controller: Intel Corp.: Unknown
device 4224 (rev 05)


I have tried the following two grub configurations:
title Red Hat Linux (2.4.31)
root (hd0,2)
kernel /vmlinuz-2.4.31 ro root=/dev/hda6 hdc=ide-scsi
initrd /initrd-2.4.31.img
...
and
title Red Hat Linux (2.4.31)
root (hd0,2)
kernel /vmlinuz-2.4.31 ro root=/dev/hda6
initrd /initrd-2.4.31.img
...

Did I forget to include something when I build the kernel???

Any Information/help would be appriciated as I have a deadline (first linux project in the company) and the management doesn't really approve that I convinced the customer to use linux.
Greatings,
Thor.
 
Old 07-14-2005, 11:37 AM   #2
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
It seems that there are a couple of problems. First of all, the laptop uses PCI-E, which is not supported by 2.4 kernels, as I recall. That's probably why knoppix "lspci" find the devices, and RH7.3 lspci does not.

That is likely the reason for the disabled dma. I doubt you have any means to get 2.4 kernel to enable DMA for this PCI-E laptop.

As RedHat 7.3 is old, I would suggest you to dump it and get a decent (recent) distro. Only if the application you are talking about is 100% required then stick with RedHat. It is quite possible that you can make the application work even in newer enviroment with little work... if you're lucky
 
Old 07-14-2005, 02:15 PM   #3
tall_thor
LQ Newbie
 
Registered: Jul 2005
Location: Denmark
Distribution: RedHat 7.3
Posts: 2

Original Poster
Rep: Reputation: 0
ICH6 seem to be supported from 2.4.26 at least it is an option when I build the 2.4.31 kernel.

any other suggestions??
/Thor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with linux installation on IBM T43 laptop jbkim Linux - Laptop and Netbook 6 11-19-2005 04:35 PM
problem with installing linux on IBM thinkpad T43 xray2004 Linux - Laptop and Netbook 1 11-18-2005 10:56 PM
IBM T43 laptop and Linux RH3 trombi Linux - Laptop and Netbook 1 08-29-2005 06:41 AM
URGENT!!..configuring IBM 2113 monitor to work with RH 9 bmon Linux - Hardware 1 05-05-2004 03:44 AM
Urgent:installing from hard disk pithan Linux - Software 1 09-06-2001 09:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 11:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration