-   Linux - Laptop and Netbook (
-   -   HP Pavilion DV4000 Resolution xorg.conf (

Oxagast 04-26-2006 01:06 PM

HP Pavilion DV4000 Resolution xorg.conf
I finaly got around to trying to put linux on my new laptop. I've had a few issues, but nothing major so far. Just stuff with the internal wireless not working... but I got that fixed with a windows driver and ndiswrapper. I have installed the current (2006.0) Gentoo. The problem I am working on right now has to do with Xorg. My resolution is wrong, I am running in 16bit color (I think) and I have no 3D accelleration. I do not infact even have an xorg.conf right now, it is running on what Xorg guesses at as the default, and it seems to work, although runs with regular old vesa. I believe it is running at 1024x768, although this is a widescreen laptop... so it looks kinda fuzzy on the LCD. I believe the native resolution is 1024x800. My card is a Intel 915GM Express, and I think the same for the LCD as it is all internal. I read that the i810 driver works for this card, however I have not been successful at getting it to work correctly. Also in the kernel there is a module for the i915, and I have that compiled (as a module), although I can't get that to do anything either. Does anybody have any suggestions as to how I could get this driver (either the kernel one, or the one that came with Xorg (i810)) to work with Xorg? I have found various xorg.conf's that use this driver, however, I have not been able to make any of them work. I get some error on trying to start X about no screens found, and no driver found in the configuration for BusID PCI:0:2:1, which is listed as being a graphics device in lspci, however, I did not even mention this in the xorg.conf. Preferably I would also like the external monitor port, and the S-Video port to work as well, but my main goal right now is just to get the right stuff working on the laptop screen.

Here is the output of lspci:

--- Cut ---
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
--- Cut ---

Thanks in advance,

doush 04-26-2006 01:56 PM


vbios isnt reporting correct res to the system...
go for 915 resolution

and do u know whats the real shame ?
this problem is around for a long time and havent fixed by any kernel or xorg yet !!

Oxagast 04-26-2006 03:11 PM

Thank you, I will try that. It can't perminatly screw up my vbios if something goes wrong, right?

Oxagast 04-26-2006 03:39 PM

I still get this message when I try to start X:

--- CUT ---
(II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G
(II) Primary Device is: PCI 00:02:0
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(EE) No devices detected.

Fatal server error:
no screens found
--- CUT ---

I can paste my xorg.conf if you want, but it's the same as this:

Anybody know what that's about?

That one does not have a BusID line in the driver for the i810, so I tried putting one in there, and if I do BusID "PCI:0:2:0" The error will say PCI:0:2:1, but if i do PCI:0:2:1, the error will say it about PCI:0:2:0. Why is this? It's two different things like mentioned in my first post... but I'm confused as to what each of them is, and why they dont work? They work with 1024x768 in vesa... so what gives? I tried configuring and using 915resolution, but it doesn't seem to make a difference. Does it matter which mode I use? I also tried putting two device sections in the xorg.conf, but that doesn't work either.

Oxagast 04-26-2006 04:52 PM

I still have not gotten this to work with the i810 driver, but I did get it to work with the vesa driver and 915resolution (so now I'm atleast running at 1280x800 24bit). If anybody knows whats up with the i810 driver not working, it'd be great if you could point me in the right dirrection.


All times are GMT -5. The time now is 03:14 PM.