-   Linux - Laptop and Netbook (
-   -   HP pavilion 1000 laptop,annoying fan-rotation problem. (

casmac 12-25-2006 06:12 PM

HP pavilion 1000 laptop,annoying fan-rotation problem.
Hi everyone:
I installed SUSE10.1 on my HP pavilion dv1650 laptop. It turns out the fan sometimes starts rotating as soon as I log in my account, eventhough the computer is *cold*, and it fails to turn off after running for awhile. This problem also happend to me when I had FC5 installed a few months ago (so i am not blaming SUSE linux).
I also have windowsxp installed, and I never ran across similar fan problem as i use Windows. Isn't it odd? The fan usually gets out-of-control when i use Linux, but stays rather quiet when running Windows(as a matter of fact, HP notebooks do not make that much noise like the Toshiba ones).
Does similar problem ever bother you on laptop? Any suggestions to solve this problem?
Thanks a lot. enjoy your holidays..


minrich 12-26-2006 08:12 AM

Is your suse 10.1 the old or remastered version?

I had my acer ferrari 3400 running at 2GHz for the first 5-10 minutes until I disabled the Novell-zmd package management system (replaced by smart) and the beagle search functions. It sure did heat up my hdd and cpu (I use gkrellm to monitor the cpu, and S.M.A.R.T. to monitor my hdd temp although it only reports to my /var/log/messages.

How is you cpu_freq setting I use Powernow_k8 on my amd64 mobile athlon and it is set to acoustic - it only jump from 800MHz to 2000MHz when I 'update channels' on smart package manager (about 30 seconds for 7 channels)

Hope this helps

casmac 12-27-2006 07:24 PM

Thanks for the tip. I got my SUSE 10.1 in October, and i am not sure which version it is. The package comes with a mannual and some CDs/dVD(and an activation code). I just installed 'smart' package from the DVD source, is it sufficient or there are more tasks to be done? By running command: cpufreq-info, it shows that(for both CPU)
driver: centrino
current policy: ondemand, may decide which speed to run between 1000MHz and 1.67GHz
current frequency: 1000 Mhz

So, it is already running at lowest speed. Do I need to change the policy to 'powersave'?

minrich 12-27-2006 08:28 PM

ondemand should be fine

the suse guru repository has the gkrellm package and if you install the rpm and configure it you should be able to see if the cpu is running fully loaded on startup, and it also displays the cpu temp so you can see if it is staying excessive - I wouldn't have thought that you have as bad problems as perhaps your original question indicated HP pavilion dv series seems to one of the best attuned to linux.

You can easily experiment with turning off the Novell-zmd package manager and/or the beagle file search engine using Yast (enter root password) > System > System Services (Runlevel)

All times are GMT -5. The time now is 06:31 PM.