-   Linux - Laptop and Netbook (
-   -   How to install Ubuntu on a HP computer with Freedos? (

omar89 03-26-2012 05:10 PM

How to install Ubuntu on a HP computer with Freedos?
Hi everybody!

I've just bought a HP laptop which has Freedos as OS.

I've started the laptop and I've put the Ubuntu 11.04 CD but nothing happen.

I've tried to press on escape and others buttons from the keybord but I couldn't boot on the CD.

I've searched on Google some Freedos commands so that I would find one which would let me boot on the CD, but I found nothing.

How can I do with Freedos as OS to install Ubuntu? Replace Freedos by Ubuntu I mean

Thank you so much for you help!

snowpine 03-26-2012 05:28 PM

Welcome to the forums!

1. Have you tested the Ubuntu Live CD on a different computer to make sure it works? Have you checked the md5sum of the disk for download/burn errors?

2. You need to go into the HP's BIOS settings and make sure that the Boot Order is set so the CD drive is before the Hard Drive. Unfortunately every computer BIOS is a little different what keys to press. Usually it is one of the Fn keys.

3. FreeDos is irrelevant to the equation.

TobiSGD 03-26-2012 05:31 PM

As snowpine already posted, it doesn't matter which OS is on the machine if you want to install a new OS. Just start the machine and press repeatedly the F9-key (that works at my HP Compaq 615, at least) until you get the boot-menu. Now choose to start from the CD.

omar89 03-26-2012 05:56 PM

Thank you snowpine, thank you TobiSGD for your answers.

1. Yes I've tested the CD in several other computer and it works well.
2. Actually, it is what I'm trying to understand, how to "ask" the computer to boot automatically on the CD.

Here is what I get when start my computer without putting the cd:

FreeDOS kernel version 1.1.32a (Build 2032a) [Sep 24 2003 21:58:48]
Kernel compatibility 7.10 - WATCOMC - FAT32 support

(C) Copyright 1995-2003 Pasquale J. Villani and The FreeDOS Project.
All Rights Reserved. This is free software and comes with ABSOLUTELY NO WARRANTY; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation ;
either version 2, or (at your option) nay later version.
C: HD1, Pri [ 1], CHS= 0-32-33, start= 1 MB, size= 900MB
0 - Choose English as the locale and keyboard layout.
1 - Choose French as the locale and keyboard layout.
2 - Choose Italian as the locale and keyboard layout.
3 - Choose German as the locale and keyboard layout.
4 - Choose Spanish as the locale and keyboard layout.
5 - Choose LA Spanish as the locale and keyboard layout.
6 - Choose Brazilian as the locale and keyboard layout.
7 - Choose Portuguese as the locale and keyboard layout.
8 - Choose International English as the locale and keyboard layout.
Select from Menu [012345678], or press [ENTER] - Singlestepping (F8) is: OFF

But when I start my laptop here is what I get when I put the CD:

"Press the ESC Key for Startup Menu"

And when I push on ESC key, I get this message:

Unable to switch off A20 address line.
Size clamped down to 64MB (0xfbc0 Kib to be precise).
0x03EF0000 (65994752 decimal) bytes extended memory detected

Public Domain ATAPI CD-ROM Driver v0.2.10 ALPHA, KJD 2001-2003
Failure! No IDE/ATAPI Dreives found!
Kernel: allocated 40 Diskbuffers = 21280 Bytes in HMA

FreeCom version 0.82 pl 2 [Apr 28 2003 17:50:57]

Error setting soft hotkey mode

CuteMouse v1.9 [FreeDOS]
Installed at PS/2 port

SHSUCDX Version 2.1
(c)John H. McCoy, October 2000, Sam Houston State University
Jason Hood, August 2003.

Can't open CD driver FDCD0001
SHSUCDX can't install.
XKEYB 1.15: keyboard driver for FreeDOS AT machines (more info: XKEYB /?)
Installed c:\fdos\bin\key\us.key

So what should I do?

Thanks again

snowpine 03-26-2012 06:11 PM

I'll repeat: by the time you see anything having to do with FreeDOS, your computer BIOS has already booted from the hard drive, and you've missed the opportunity to boot Ubuntu. You need to set your BIOS options (or choose from the F9 boot order screen like TobiSGD suggests) and boot from the CD, not the hard drive. BIOS options flash by quickly; you will only have a couple of seconds to press the correct key. :)

TobiSGD 03-26-2012 06:12 PM

It seems to me that the press on the Esc key launches the boot menu of FreeDOS, not the one in the hardware.
Try it this way:
1. Put in your Ubuntu CD.
2. Shut down the machine completely.
3. Now start the machine and immediately press repeatedly the F9 or F10 key. F9 should bring you the a boot menu, F10 should get you in the BIOS. May be you should have a look at the manual which key exactly is needed for the boot menu.
4. Either choose in the bootmenu the option to start from CD, or change the boot options in the BIOS so that the CD will be booted before the harddisk.

omar89 03-27-2012 03:30 AM

Thank you guys! As you said, I had just to press F9 key to have the menu and then, to choose to start the CD.

All times are GMT -5. The time now is 03:02 PM.