LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 03-06-2009, 04:28 AM   #1
amit_kalipur
Member
 
Registered: Dec 2008
Location: Delhi 91
Distribution: RHEL 5
Posts: 74
Blog Entries: 2

Rep: Reputation: 15
How to disable getting IP from APIPA.


Dear All,
When I configure static ip address 192.168.0.111 to my laptop,It isautomatically getting IP addredd from APIPA.It makes me unable to connect to proxy to access internet.May u tell me how to disable getting IP from APIPA.

After setting up static ip address,I run service network restart,then a message is displayed "Network connection is disconnected"Meanwhile It automatically search for ip address and then It gets IP from APIPA range and a message is displayed "Network connection is established".What is the cause and How can i sort out it?
Thanks and regards
Amit.
 
Old 03-06-2009, 04:51 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Rep: Reputation: Disabled
APIPA seems to be Microsoft technology and possibly on Windows assigns Ip address via APIPA.
I am not sure how your RHEL5 is taking ip address through it because it should not.
Are you running version of windows?
 
Old 03-06-2009, 11:28 AM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,456

Rep: Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564
If you want to disable APIPA (aka link-local) simply add NOZEROCONF=yes to your /etc/sysconfig/network file and restart network services.

service network restart

How did you configure a static IP address?

BTW APIPA is now a standard (RFC 3927)

Last edited by michaelk; 03-06-2009 at 11:35 AM.
 
Old 03-07-2009, 04:28 AM   #4
amit_kalipur
Member
 
Registered: Dec 2008
Location: Delhi 91
Distribution: RHEL 5
Posts: 74

Original Poster
Blog Entries: 2

Rep: Reputation: 15
Quote:
Originally Posted by michaelk View Post
If you want to disable APIPA (aka link-local) simply add NOZEROCONF=yes to your /etc/sysconfig/network file and restart network services.

service network restart

How did you configure a static IP address?

BTW APIPA is now a standard (RFC 3927)
Thank you very much for help.
Sir,I added the same you mentioned above,but there is effect of this.When i run service network restart,for some time it gets ip that i configured and a message is displayed "The network connection has been disconnected" and after sometime other message is displayed "The network connection has been established" and then It gets ip addredd from APIPA range. I am attaching a screenshot of that.

Last edited by amit_kalipur; 05-04-2009 at 07:29 AM.
 
Old 03-07-2009, 05:37 AM   #5
amit_kalipur
Member
 
Registered: Dec 2008
Location: Delhi 91
Distribution: RHEL 5
Posts: 74

Original Poster
Blog Entries: 2

Rep: Reputation: 15
Quote:
Originally Posted by amit_kalipur View Post
Thank you very much for help.
Sir,I added the same you mentioned above,but there is effect of this.When i run service network restart,for some time it gets ip that i configured and a message is displayed "The network connection has been disconnected" and after sometime other message is displayed "The network connection has been established" and then It gets ip addredd from APIPA range. I am attaching a screenshot of that.An icon will be displayed on message.
How can i get this icon on toolbat?Please help me.
 
Old 03-07-2009, 06:09 AM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,456

Rep: Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564
Post the contents of your /etc/sysconfig/networking/devices/ifcfg-eth0
 
Old 03-10-2009, 04:18 AM   #7
amit_kalipur
Member
 
Registered: Dec 2008
Location: Delhi 91
Distribution: RHEL 5
Posts: 74

Original Poster
Blog Entries: 2

Rep: Reputation: 15
Quote:
Originally Posted by michaelk View Post
Post the contents of your /etc/sysconfig/networking/devices/ifcfg-eth0
Thank u for ur reply.Now that problem is solved.I think it because I configured DHCP SERVER and it is not getting ip from APIPA range but when i
run "ifconfig" it displays ip address other than static ip 192.168.0.125.
I configured static ip but it is getting ip from dhcp.Now it is pinging from both 192.168.0.125 and 192.168.0.245.
What is the reson?


[root@amit ~]# cat /etc/sysconfig/networking/devices/ifcfg-eth0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Ethernet
DEVICE=eth0
HWADDR=00:21:9b:f3:01:36
NETMASK=255.255.255.0
IPADDR=192.168.0.125
ONBOOT=yes
USERCTL=yes
IPV6INIT=no
PEERDNS=yes


[root@amit ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:21:9B:F3:01:36
inet addr:192.168.0.254 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::221:9bff:fef3:136/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1893 (1.8 KiB) TX bytes:15063 (14.7 KiB)
Interrupt:169 Memory:fe8fc000-0
 
Old 03-11-2009, 12:20 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,456

Rep: Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564Reputation: 3564
Try adding this line to the ifcfg-eth0 file.
BOOTPROTO=static
 
Old 03-12-2009, 06:44 AM   #9
amit_kalipur
Member
 
Registered: Dec 2008
Location: Delhi 91
Distribution: RHEL 5
Posts: 74

Original Poster
Blog Entries: 2

Rep: Reputation: 15
Quote:
Originally Posted by michaelk View Post
Try adding this line to the ifcfg-eth0 file.
BOOTPROTO=static
Thank you for ur kind reply
I added that but there is no effect.It takes ip from DHCP when I connect my
system to internet it pings both ip addresses static and DHCP.

[root@amit ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Ethernet
DEVICE=eth0
HWADDR=00:21:9b:f3:01:36
NETMASK=255.255.255.0
IPADDR=192.168.0.125
ONBOOT=yes
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
BOOTPROTO=static
[root@amit ~]#
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable "last login log" & disable "last login message" when start login. hocheetiong Linux - Newbie 4 02-08-2011 05:35 AM
Bydefault APIPA is assigned to LAN Card. amit_kalipur Linux - Laptop and Netbook 0 02-27-2009 05:33 AM
how to disable Text-to-speechmanager on startup, and disable fsck after 20 boots Kristian2 Slackware 2 02-25-2009 10:55 AM
dbx command for corrosponding commands disable or disable on gdb bshankha AIX 0 09-26-2006 09:38 AM
what are the services i can disable, also disable ads, banners in konqueror? greythorne SUSE / openSUSE 3 03-16-2005 08:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration