-   Linux - Laptop and Netbook (
-   -   How to Change modules; on a IBM Thinkpad T30 Network Driver (

wkdude18 06-19-2008 08:01 PM

How to Change modules; on a IBM Thinkpad T30 Network Driver
My internet connection does not work in Slackware 12.1 because I do not have the correct driver installed. However, my IBM Thinkpad T30 dualboots with an Elive (coolest distro ever) installation, and wireless worked perfectly out-of-the-box after I changed my network and encryption settings in the GUI. So, I probed /lib/modules for the network driver and in the /net/wireless directory I found adm8211.ko all by itself, so therefore I assumed it was the active network driver. So I rebooted into S-Ware, and I tried to change the driver to adm8211 by doing rmmod airo (currently active driver) whic was successful, and then modprobe adm8211. No error messages appeared, but iwconfig said there were no wireless extensions for all interfaces, even after using ifconfig [interface] up, so presumably there was no active network driver.

So, two questions: One, how to identify the currently active driver (i.e., the one Elive uses on my laptop); Two, how to change a driver (i.e., the one Slacware uses to the one Elive uses).

Please help, thanks in advance :)

All times are GMT -5. The time now is 12:00 AM.