-   Linux - Laptop and Netbook (
-   -   Hopelessly stuck on making Nvidia Driver work on Debian (

chui1989 09-22-2012 06:29 PM

Hopelessly stuck on making Nvidia Driver work on Debian
Before I posted question here, I'd been hacking around for the solution for my problem, but none of them worked. Here is my situation. I had a Win7 OS before I put a Debian Squeeze on it, now I got a dual-boot. However, I tried both ways to install driver for my Nvidia Quadro 1000M card on this machine, Debian ways,, and the Nvidia driver script from its website, both yielded the same results. "failed to initialize the nvidia graphic device, none of the screen has been configured."(From var/log/Xorg.log), and one thing I realized was that after tweaking the linux version of Nvidia driver from above, my windows Navidia driver broke as well when I logged into windows, and I had to reinstall to get it back working again. Does it mean that I can't get two drivers on the same machine even there are for different OSs and are in different partition? Or those above solution only worked for standalone linux machine? Sorry about my incomplete knowledge for drivers, but please help cuz I am going nuts here. Thank you ini advance.

towheedm 09-22-2012 09:03 PM

It's strange that installing the Linux driver broke the Windows driver. These are totally separate and different drivers.

I've never used the Debian way of installing my nVidia driver. I've always used the version from the nVidia driver site.

Since you did not mention the release of Debian or the driver version, I'll describe what I do to install driver version 173.14.3x on Squeeze using GNOME.

If you automatically boot into X, do the following:
  1. Drop to the command line by pressing Ctrl+Alt+F1
  2. Backup your xorg.conf file (should you want to revert):

    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_orig
  3. Blacklist the Nouveau driver (this can also be done by the nVidia script):

    echo -e "blacklist nouveau\noptions nouveau modeset=0" | sudo tee /etc/modprobe/nouveau-blacklist.conf
  4. Update your initramfs:

    sudo update-update-initramfs -k all    # Use -k $(uname -r) for the currently running kernel only
  5. Install the kernel headers (you can skip this if they are already installed):

    sudo apt-get install linux-headers-$(uname -r)
  6. Reboot.

    sudo reboot
  7. This should automatically reboot to the command line. If you get a flashing cursor, press Ctrl+Alt+F! for the command line and stop gdm:

    sudo service gdm3 stop
  8. Now run the downloaded nVidia installer script:

    sudo sh /path/to/script/ -a -e
    This will build the pre-compiled kernel interface, the kernel module and also install the GLX drivers.
    The options are:
    1. -a - Automatically accept the license agreement
    2. -e - Expert mode. It should be safe to accept the defaults provided.
  9. Once the module is successfully built, insert the module into the currently running kernel:

    sudo modprobe nvidia
  10. Start GNOME:

    sudo service gdm3 start

If all went well, you should now be running the proprietary nVidia driver. You can tweak your xorg.conf file as needed.

Hope it helps.

chui1989 09-23-2012 12:54 AM

I want to thank you for this lengthy reply, but it still hasn't been working for me, I did follow your steps exactly and got the same answer, before I boot into the GUI OS, I got a black screen with a blinking like crazy cursor, the log from Xorg.log says "No devices detected and fatal server error: no screen found", what does it mean? Also, I discovered that if I got rid of xorg.conf in /etc/X11/, at least I could boot into system without stucking at the black screen and cursor, even though I can't use dual-display cuz it says X server is not configured. anyidea? Thank you

It's working after I disabled Nvidia optimus, screw them, Thank you again

cascade9 09-23-2012 04:16 AM


Originally Posted by chui1989 (Post 4786911)
It's working after I disabled Nvidia optimus, screw them, Thank you again

Disabling optimus will probably have some effect on your battery life with windows.

I'd give bumblebee a try, that can let you leave optimus running for windows and you can use the nVidia GPU with linux.

All times are GMT -5. The time now is 06:23 PM.