LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 11-12-2008, 03:59 PM   #1
SleepyWolf
LQ Newbie
 
Registered: Nov 2008
Location: Sofia
Posts: 19

Rep: Reputation: 0
Having some problems with Aspire 5730z and Ubuntu


Hi.
I've sought for the info that can help me, but I haven`t found anything, so I would ask directly.
I have notebook Acer Aspire 5730z with Ubuntu 8.04. I can get on with it, however, this a problem I am not able to cope with.
When I try to turn on some "video and sound effects" the laptop blocks and the only way to control it, is by holding switch off until the notebook is off and restart it. Only the touchpad of the mouse can move on the desktop, nothing more. The blocking effects are the webcam (I've learned there are problems with the compatibility with linux and I am trying to resume them), the visualization of the music-player Rhythmbox, some songs in the internet (this for example : http://hooligans.bg/gallery/displayimage.php?pos=-14528 I have no problems with .mp3s, but in this page when I turn on the song, it begins 4-5 seconds and then the laptop blocks)...
I have had this with VLC media player, so I had been told to change the "video output module" to X11 and now it works properely. And for the webcam - it is working normally within Kopete and Ekiga, but never in skype.
Am I wrong that the problems are connected with the drivers devices and the codec? Оr they are somewhere else?

Sorry for the long description and thanks.
 
Old 11-13-2008, 12:31 PM   #2
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 83
You are probably correct about driver difficulties, can you please post output of

Code:
lspci
here, and we can talk some more.
 
Old 11-13-2008, 02:45 PM   #3
SleepyWolf
LQ Newbie
 
Registered: Nov 2008
Location: Sofia
Posts: 19

Original Poster
Rep: Reputation: 0
Here is what displays this command:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Atheros Communications Inc. Unknown device 002a (rev 01)
 
Old 11-13-2008, 04:13 PM   #4
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 83
Ok, well as far as I know, all your hardware is supported by ubuntu. It may be the case that the integrated graphics card:
Quote:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
is just not powerful enough to handle what you are trying to run. Can you tell me whether you are trying to run compiz on your machine? It may be to your advantage to disable this, the easiest way to do this is

System -> Preferences -> Appearance

click on 'Visual Effects' tab and select 'None', then let us know how you get on.
 
Old 11-17-2008, 12:48 PM   #5
SleepyWolf
LQ Newbie
 
Registered: Nov 2008
Location: Sofia
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
System -> Preferences -> Appearance

click on 'Visual Effects' tab and select 'None', then let us know how you get on
Thanks!
Well, this action helped, the visualization system goes easier now, bet the other problems are still here. Of course, there is difference: when I click on the button for the visualization on "Rhythmbox" (this function, that make some effects when a song is played, for example, lines are moving and changing colours) instead of complete blocking, the screen now goes black and I can restart the notebook with Ctrl+Alt+Del and the system loads after that without the checking of "unpropered shut down".
The web cam is running very well only in the system "Kopete" (which loads icq). Within "Ekiga" (system for telephone call throught internet) in the check menu it is running well, but I have not tried it as a "real" connection...
 
Old 11-17-2008, 03:25 PM   #6
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 83
Sounds to me like a broken install. I would tar up my home directory, then reinstall completely. I'm betting you changed something somewhere or installed something like AWN at some stage. The reason I say this is because my hardware is similar to yours:

lspci:
Code:
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8039 PCI-E Fast Ethernet Controller (rev 14)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
07:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
07:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
07:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
07:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
07:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
and I have full effects, standard ubuntu style compiz, none of the really flashy stuff. I have in the past messed up my system by trying to run 3D cube for example.
 
Old 11-24-2008, 04:34 AM   #7
SleepyWolf
LQ Newbie
 
Registered: Nov 2008
Location: Sofia
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks!
May be, I will reinstall because I haven`t touched anything during installation. :-)
 
Old 11-24-2008, 03:16 PM   #8
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 83
Good stuff, hope that works out for you! If you have anything saved in your /home directory, don't forget to tar it up and back up, or at least copy everything into an external harddrive for safe keeping...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Linux Linpus on Acer Aspire 5730Z Shoebox Linux - Laptop and Netbook 10 12-29-2008 09:37 AM
Problem with Acer Aspire 5730Z - Bios level Ashkandi Linux - Laptop and Netbook 1 10-24-2008 05:41 PM
Running Ubuntu 7.10 on Acer aspire 4520 amitabhishek Linux - Laptop and Netbook 28 02-20-2008 07:19 PM
Three huge problems i really need help with, Ubuntu 6.06, acer aspire 9500 wfc2023 Linux - Software 1 04-22-2007 05:30 AM
Ubuntu trouble on Acer Aspire 5021 djepix Linux - Laptop and Netbook 1 01-26-2007 11:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration