-   Linux - Laptop and Netbook (
-   -   gentoo && amd64 kernel help (

DaFrEQ 04-05-2004 10:11 PM

gentoo && amd64 kernel help
Sorry for a pseudo re-post, but I thot this rather no longer belonged as a SuSE topic.

I'm now at the point of choosing a kernel. First off, is there a specific kernel for the amd64 installs?
I've googled, and found jack crap.

I ran:
emerge gentoo-sources
because I couldn't find anything about the amd64 kernel source (If there is such a thing) and got the following error:

Calculating dependencies
!!! all ebuilds that could satisfy "gentoo-sources" have been masked.
!!! possible candidates are:
- sys-kernel/gentoo-sources-2.4.26_pre (masked by: missing keyword)
- sys-kernel/gentoo-sources-2.4.19-r11 (masked by: -keyword)
- sys-kernel/gentoo-sources-2.4.20-r14 (masked by: missing keyword)
- sys-kernel/gentoo-sources-2.4.20-r7 (masked by: -keyword)
- sys-kernel/gentoo-sources-2.4.22-r3 (masked by: -keyword)
- sys-kernel/gentoo-sources-2.4.22-r4 (masked by: -keyword)
- sys-kernel/gentoo-sources-2.4.22-r5 (masked by: -* keyword)
- sys-kernel/gentoo-sources-2.4.22-r7 (masked by: -* keyword)
- sys-kernel/gentoo-sources-2.4.25 (masked by: missing keyword)
- sys-kernel/gentoo-sources-2.4.26_pre5 (masked by: missing keyword)
- sys-kernel/gentoo-sources-2.4.26_pre6 (masked by: missing keyword)

!!! Error calculating dependencies. Please correct.

And thats it. Correct what? I didn't see anything in the install about any of this. I thot that all of the time spent with downloading sources, portages, emerging, n such would have taken care of these dependencies.

Please advise.


DaFrEQ 04-06-2004 01:51 AM

Ok. So I used the:
emerge gentoo-dev.sources
and it seemed to be ok.
Continued with the installation procedures, and now I'm stuck at the grub install. The documentations says that the following command will work:

emerge --usepkg grub

However, once this command is run the following appears:

Calculating dependencies
!!! all ebuilds that could satisfy "grub" have been masked.
!!! possible candidates are:
- sys-boot/grub-0.92-r1 (masked by: -keyword)
- sys-boot/grub-0.93.20030118 (masked by: -* keyword)
- sys-boot/grub-0.94-r1 (masked by: -* keyword)

!!! Error calculating dependencies. Please correct.

So again, I'm stuck at a dependency check. However, there isn't any info on how to get around this particular portion. At least, none that I've seen.

Please advise.


DaFrEQ 04-06-2004 04:10 PM


crashmeister 04-06-2004 04:44 PM

you'll need to install grub-static.Grub doesn't compile with 64 bit.

DaFrEQ 04-06-2004 05:39 PM

You lost me there.
Lilo says the same thing... only i think it has 1 or 2 more broken depends.

Forgive my ignorance today, as I've been awake waay too long and am out of Dew...

Can you point me to a doc that tells me about grub-static and 64-bit info?


crashmeister 04-07-2004 05:44 AM

All you need to do is 'emerge grub-static'.There's some more info here:

DaFrEQ 04-07-2004 12:52 PM

Tnx. I got that under control last nite. I was going to post, but now I came across something else (plz dont hate me :) )

grub-install --root-directory=/boot /dev/hda


Probing devices to guess BIOS drives. This may take a long time.
df: Warning: cannot read table of mounted filesystems: No such file or directory
df: Warning: cannot read table of mounted filesystems: No such file or directory
Could not find device for /boot/boot: Not found or not a block device.

Not sure, but the documentation says I have to do this unless the /boot par isn't a seperate par. Mine is. It's on /dev/hda2.
I also tried that in the command and it said the same thing. (just a shot in the dark)

Also, the docs say if you have no flopp to add the following:

Tried that and it returned:
Unrecognized option '--no-floppy'
Usage: grub-install [OPTION]...blah blah blah

Standard help as far as I can tell which means the --no-floppy options is... extinct?

Please advise.


DaFrEQ 04-07-2004 05:32 PM

Right, so I found out that the --no-floppy option is a boot option only???
(plz correct if I'm incorrect...)
Just wondering why they put that part in the install... maybe I read it wrong.

Anyhow, still having problems getting grub-install to work from the above post. Any ideas?
I googled all day, and even posted on the gentoo forums, but no one seems to know... or reply.


crashmeister 04-07-2004 06:20 PM

I am not a grub expert (only used it once) but it looks like you'd need to specify --root-directory=/dev/hda without the /boot.
The --no-floppy thing is just to tell grub not to probe for a flopp buty drive since the emachines doesn't have one but it works fine either way.Just don't forget to add the bootoptions or pretty much nothing will work.
Hope that helps.

DaFrEQ 04-08-2004 06:32 PM

Ok so that didnt work either.
I tried:
# grub-install --root-directory=/boot /dev/hda
also tried:
# grub-install --root-directory=/dev/hda
also tried:
# grub-install --root-directory=/dev/hda /boot
also tried:
# grub-install --root-directory=/boot /dev/hda2

None seem to work. As a matter of fact, the only one that didnt simply print the grub help menu was the initial grub-install --root-directory=/boot /dev/hda

So, I'm unclear. On the gentoo forum, someone said something about doing "grub manually" but didnt' leave much of an explanation.
Would it simply be easier to re-start the install and only have the 1 partition? (other than swap that is)
The only reason to use the --root-directory= option is if your /boot is a serperate partition. At least that's how I read the install docs.

Plz let me know if I'm wrong, or just simply overlooking something.


crashmeister 04-08-2004 07:07 PM

Nah - without the /boot partition you'll get into other problems.Don't remember which ones but there was something.Make sure your fstab is ok and all the partitions are mounted when you configure grub.Didn't have any trouble there at all besides typos with the bootoptions.

DaFrEQ 04-10-2004 04:18 AM

Ok. So I finished with the second attempt of stage2 and now the machine freezes during boot.
The following is whats left on the screen after whatever scrolls on by:
ACPI: Processor [CPU0] (supports C1 C2)
mice: PS/2 mouse device common for all mice
input: PC Speaker
serio: i8042 KBD port at 0x60,0x64 irq1
atkbd.c: Unknown key released...
blah blah blah

I've searched the gentoo forums, but those posts over there seem to be less relevant to the topic than anything I've ever seen.
SO, does anyone know how or maybe a way or a place that can inform me of how to get this damn gentoo distro installed, and actually Working on this laptop?

I've been screwing with it for 2 weeks now, and between the gentoo site glitching and not letting ppl be able to read the damn install docs, or even dl them for that matter (gee, what a Eureka! idea eh?), crappy stages that seem to work when they want, and a bunch of miss-match info on what does and doesnt work with this distro on this laptop... I'm really confused and totally frustrated.

Plz show me the light.
P.S. see, this is the damn problem with ONE (1) OS trying to dominate the market and getting away with it for stupid governmental and SHEEP reasons.
"Gee, lets build a new system that will only work with winbloz"
"But we've already done that"
"Ya I know, but lets keep doing it!" so tired of this shit


DaFrEQ 04-10-2004 05:23 PM


crashmeister 04-13-2004 07:35 AM

I am finally back in business - box@home was screwed up and the laptop didn't like to connect to the internet any more plus there was a lot of beer to drink:D

Anyway - the doc's are here
and they are probably a little screwed up - seems to be a gentoo feature recently.

The important steps that are special to the emachines laptop are here

The things that make life easier without combing thru the whole thread are:

Compiling the kernel:

emerge gentoo-dev-sources
emerge genkernel
genkernel --kernel-config=/usr/share/genkernel/x86_64/kernel-config-2.6-emachines all

Configure grub:

default 0
timeout 30

title=Emachines Kernel
root (hd0,0)
kernel (hd0,0)/boot/kernel-2.6.3-gentoo-r2 root=/dev/ram0 init=/linuxrc real_root=/dev/hda3 vga=0x317 splash=verbose pci=noacpi noapic
initrd (hd0,0)/boot/initrd-2.6.3-gentoo-r2

Make sure that you got the bootoptions right - I screwed around forever because I had typos in the pci=noacpi noapic part.

Of course you'll need to replace it with your actual kernel version and partitions.
Seems that there is trouble with the 2.6.5 kernel - try to stick to 2.6.3
There is also some info on those sites:

Hope that helps a bit - unfortunately I don't have one of those anymore.Can't help you with any specific problems.

axl 09-08-2004 03:13 PM


I'm just wondering HOW you installed gentoo ...
If it was by KNOPPIX or something similar you should not only 'cp /proc/mounts /etc/mtab" but edit it to fit your needs ...
there are loads of entries like /dev/root / rootfs rw 0 0
and all that stuff a cat /proc/mounts will give you. there should only be one line that sounds like /dev/sda1 / xfs rw 0 0

hope that helps ...

All times are GMT -5. The time now is 04:51 PM.