-   Linux - Laptop and Netbook (
-   -   FTDI driver for MIPS netbook (

vertexm 08-16-2010 09:53 PM

FTDI driver for MIPS netbook
I have a Skytex netbook with a MIPS processor, which runs 3MX 4.0 Linux, a Debian 2.6. FTDI_sio.ko is not included in this build. I have successfully compiled a complicated C program for this setup on my Toshiba Satellite with Ubuntu 10.04 LTS. Using the same environment I tried to compile ftdi_sio.c and ftdi_sio.h and get a huge number of errors. A sampling are:
error: field 'init_termios' has incomplete type
inux- error: dereferencing pointer to incomplete type

etc., which indicates that there are problems in the includes.

I tried using the includes from the 3MX source, as well as the ones on my Ubuntu system, and both have similar problems.

I have asked some friends who have a lot of Linux and C experience, and they are at a loss as to what to do, except for modifying the includes to correct the problems. This does not make sense, and is a huge task.

Any clues, or if someone has ftdi_sio compiled for MIPS, your help would be greatly appreciated.

All times are GMT -5. The time now is 09:57 PM.