LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   ext3/initrd Problem (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/ext3-initrd-problem-309841/)

DarkAsHell 04-05-2005 01:44 AM

ext3/initrd Problem
 
Allow me to preface this by stating that I am a hardware minded person. This is my first venture into the Linux OS. If I seem a bit slow or do not understand what you want me to do please be patient.

I have recently installed Red Hat 9 on my Acer Travelmate 4500. However, in order to use my 802.11g Intel Pro 2200 card I needed to update from the stock 2.4 kernel to a 2.6 or later kernel. I stumbled across Kernel.Org and soon found all the files I would need to make the transition. Google promptly gave me your guide to updating kernels on Red Hat 8/9. I followed this guide and everything seemed to be going well until I attempted to boot the 2.6.11.6 kernel. I recieved the following error message:

Mounting root filesystem
mount: error 19 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
Freeing unused kernel memory: 220k freed
Kernel panic - not syncing: No init found. Try passing init= option to kernel.

I have tried the following to fix the problem:
  • I built menuconfig and made sure all ext3 proporties had an *.
  • I remade the initrd file to no avail.
  • I followed all possible solutions presented in your guide.

If there is any further information you like me to post please tell me along with instructions on where to find this information. Any help is greatly appreciated.

I am a new member but I have a slight complaint. I had typed all of this with a link to your own guide. The forum wouldn't allow me to post this because of spamming. This is understandable and no problem. However, it would not allow me to edit my previous message but rather made me re-type the whole thread. Perhaps this is a setting on my computer...if so I apologize.

masand 04-05-2005 02:29 AM

u need support for ext2 FS no matter what FS u use
so make sure that u have built that into ur kernel not as modules

DarkAsHell 04-05-2005 04:03 PM

I am not sure if I built it into my kernel or as a module. If you could clarify what this means...thanks.

masand 04-05-2005 10:56 PM

hi there

yes u need ext2 fs support as well because linux first mounts as ext2 then it remounts it as ext3 FS


regards

DarkAsHell 04-06-2005 12:33 AM

I tried activating ext2 through the menuconfig and the same error appears upon reboot. I read a couple of lines prior to the error 19 and it states: VFS: Mounted root (ext2 filesystem). I don't believe that ext2 was the problem.

masand 04-06-2005 12:44 AM

what i meant to say that u need ext2 no matter what FS u use
also do have this support built in the kernel not as modules?

DarkAsHell 04-06-2005 01:13 AM

Well none of the ext2 options had an <M> and I changed all of them so they had an *. I believe that incorporates them into the kernel rather than as seperate modules.

DarkAsHell 04-06-2005 06:23 PM

I double checked all the ext2/ext3 stuff and there doesn't seem to be any problems there...yet according to the error message that is the source of my problems. If anyone has any additional input.

masand 04-06-2005 09:39 PM

ok then mail me the config file

linux4all [at] gmail.com

i will try to look what is wrong

regards

DarkAsHell 04-06-2005 10:49 PM

I believe what you want is the .config file located within the kernel's folder. I have sent you an e-mail with that file.

masand 04-06-2005 10:55 PM

yes i want the .config file only whcih u are using

i will look into that after i am back from my class

regards


All times are GMT -5. The time now is 08:52 PM.