LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 01-03-2009, 02:56 AM   #1
localhost
LQ Newbie
 
Registered: Feb 2003
Location: New Zealand
Posts: 5

Rep: Reputation: 0
Evo N400c ethernet problems


I have a compaq evo N400c running gentoo.
The built-in ethernet card, a Intel 82557/8/9 Ethernet Pro 100 seems to be detected successfully but ifconfig doesn't show it up, all it shows is loopback. If I do a lshw it shows as disabled and with a logical name of eth12, physical id =9 , bus info = pci@0000:00:09.0.
Why does it come up as eth12 and not eth0 ?
I have tried recompiling as a module and built-in but it makes no difference.
It can ping itself but not the router. Cables are ok since another OS (FreeBSD) is fine.
Also, If i put a 3c589 in the pcmcia slot it comes up at eth4 but it works ok.
There are no other network devices.
How do I get the first ethernet card, be it the intel pro 100 or the 3c589 to come up as eth0?

thanks

Grant
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compaq EVO N600c and SuSe 10.2 driver problems mandrakeman SUSE / openSUSE 3 06-21-2008 10:50 PM
Wireless Adapter Troubles, Compaq Evo n400c wlan w200 jasonmason Ubuntu 1 04-05-2006 06:57 AM
Compaq N400C Problems n_ight_vision Linux - Laptop and Netbook 3 09-07-2005 01:02 AM
Quirky installation of yoper on a Compaq Evo N400c ben017f Yoper 0 04-25-2005 05:29 AM
Compaq Evo Display problems too_fast Linux - Hardware 2 02-25-2003 04:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 03:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration