LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Ethernet (Marvell Yukon) card stops working after reboot [FC4] (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/ethernet-marvell-yukon-card-stops-working-after-reboot-%5Bfc4%5D-353303/)

AglaSyS 08-14-2005 09:12 PM

Ethernet (Marvell Yukon) card stops working after reboot [FC4]
 
I recently installed Fedora Core 4 (kernel 2.6.11), and everything was working, except for the ethernet card (Marvell Yukon 88E8036 Fast PCI-E Ethernet Controller).

So, I decided to get it working by myself. I found the appropriate Linux driver (sk98lin) and installed it. Set the connection up through adsl-setup, and started the connection through FC4's network manager (Activate button, but I guess it's the same as running adsl-start). It worked perfectly, excellent connection speed, etc.

Later (after just browsing a little and setting some other things up that are unrelated to the system's network), I had to reboot to WinXP for some business, and when I got back to FC4, the connection stopped working.

It's the second time this happens (I had reinstalled FC4 just before, thinking I may have screwed something up). Can anyone help me? If needed, I can reinstall Fedora again. Any suggestions are welcome =)

BeaverusIV 08-15-2005 06:21 AM

Do you have problems with the connection in windows?

I have an MSI mobo with marvel yukon pci-e on it and if I use it, and someone reboots our router (it does dhcp) it freezes my computer.

Couldn't find a solution so I use my other NIC now.

2Gnu 08-15-2005 09:37 AM

The Marvel gigabit NIC on my ASUS board also gives me fits. Using the 3Com Linux driver, I can't get to some Internet sites. With the sk98lin, I can't use the corp VPN or get to my router. Unfortunately, I'd also suggest another NIC.

buaku 08-15-2005 06:45 PM

Was the sk98lin driver still loaded after you rebooted into linux?

AglaSyS 08-16-2005 11:02 AM

Yes, it was. Actually, after I installed it, the card's name was incorrect. After I rebooted, the system got the correct name for it.

Another thing, is that after i installed sk98lin and rebooted, linux also detected my WiFi card, and placed it as eth0, and changed the Marvell card to eth1. YES, I already updated the settings to use the correct device, but still, no luck.

My connection is a DSL, which you have to use the phone number it's connected to as the username and password, and then auth it through the website (all other websites are blocked until the auth is complete) - known here in Brazil as Velox.

I've read some articles about it, and many of them say that the common solutions are activating DHCP and defining the connection as the default route.

A particular thing about the setup used here at home, is this:


||||| - Desktop PC (WinXP)(Doesn't need to be on)
|||||
|||||
|||||----(USB)------[_____]-DSL Modem-----(Blue Eth Line)------[Laptop______] (FedoraC4)
||||| |---------Phone Line|
____|

Not very good diagram... but anyway: The DSL is connected to the Desktop PC(USB), a Phone Line and the Laptop(blue cord). Does this unusual setup have anything to do with my problem? I'm pretty sure now that it's a HARDWARE recognition problem with FC4. The connection works perfectly with WinXP, and I have managed to connect some time ago with another laptop (running slack 10.0).

Any good suggestions of what to do, or a distro that usually has a good compatibility rating? I'm sick of setting up sound, widescreen lcd, mousepad, etc. FC4 easily worked with these.

For the record, I own a Toshiba Satellite M45 S331 and a Toshiba Satellite A15 S157

buaku 08-17-2005 06:57 PM

I'm not sure what else to do.
I use slackware, but I don't use the Marvell NIC.
I did try it a few times and it seemed to work ok.

I never figured out how to get both NIC's workin on different subnets, so I only use the nforce NIC.

Have you tried setting it all up again as if you never had the module loaded? Sorta start over for the NIC.

michael@greg:~> 08-21-2005 03:21 PM

If you connect your laptop to the modem with a USB cable, can you connect to the Internet on your laptop? If you can connect to the Internet on your laptop with this setup, consider connecting the desktop to the modem by CAT5 and keeping the laptop connected to the modem by USB.

collen 01-24-2006 07:41 AM

bugger... got the same here..
installed FC4 on a gigabyte ga-k8nxp-sli amd-64

the nvidea network works, but the marvel 8053 doesn't

it shows up with lspci, -> Marvel 88e8053 Gigabit Ethernet Controller.

kudzu -b -> device: eth1
driver: unknown
Desc: Marvel blah blah blah...
vendorid: 11ab
deviceid: 4362

i put in 'modprob sk98lin' at the rc.sysinit (just to be sure!)

and put 'alias eth1 sk98lin' in modprobe.conf.

big reboot, and still nothing, even after the 2.6.14 kernel upgrade...
also tried gentoo, and knoppix, but they got even worse..!!

what is this with the Marvel pci-e network card...??

isn't there a workaround, or fix for this prob.. ??

Plz help me out here..

:Pengy:

AglaSyS 01-24-2006 10:31 AM

Well, there is a workaround. You can buy a wifi router and connect it to your dsl modem. You just have to make sure your wifi card is ok. In my case, I bought it anyway, to use with windows


All times are GMT -5. The time now is 04:26 AM.