Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 11-03-2006, 01:42 PM   #1
Registered: Dec 2005
Distribution: Fedora Core
Posts: 55

Rep: Reputation: 15
Enabling Headphone/Mic jack

Ok, the specs:
Compaq Presario V6030
Fedora Core 6 x86_64
Onboard Audio (MCP51 I think)

And here's what I'm trying to do:
Right now the audio works great through the onboard speakers. Now, I have the nice Head/Mic Jack on the front, I want to be able to plug in a headset and get these to work. However, plugging headphones (I haven't tried the mic yet) into this jack produces:

- Audio Still plays over speakers
- Audio Does Not play out of headphones.

I took a look in KMix (Using KDE btw) and didn't see anything that immediately jumped out at me. So, my question is, how do I get this working?

1) Do I need to install anything special? Drivers, mixers? If so, how?
2) Is there a setting somewhere that I can change to redirect the output to the headphones instead of the speakers? Something in the control centre perhaps?
Old 11-03-2006, 03:39 PM   #2
Registered: Dec 2005
Distribution: Fedora Core
Posts: 55

Original Poster
Rep: Reputation: 15
Ok, I noticed there were 3 other posts on the same thing here (different laptops, but same problem and same audio card). So I guess this one can die and I'll just follow the other 3. Still no answer in any of them yet though.
Old 11-03-2006, 05:33 PM   #3
Registered: Aug 2002
Posts: 16,128

Rep: Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866
Might want to try alsa-driver 1.0.10.RC3
Old 12-11-2006, 12:46 PM   #4
Registered: Dec 2005
Distribution: Fedora Core
Posts: 55

Original Poster
Rep: Reputation: 15
I just wanted to confirm I did get this working. (sort of)
I have it set up now so that I get seperate speaker/headphone controls. Not exactly what I'd hoped for, as I know it works in windows properly, but at least I can now mute the speakers and use the headphone, which is what I wanted in the first place.

It's as simple as:

1) Install alsa 1.0.13
(Well, this wasn't so simple. It's not part of the fedora repository and I had to find all the 1.0.13 rpms doing searches.)
In total, on FC6 x86_64 I had to install:

libasound2 x86_64
libasound2 i386
alsa-kmdl x86_64
alsa-lib-devel x86_64
alsa-lib x86_64
alsa-lib i386

2) edit /etc/modprobe.conf and do the following:
- options snd-hda-intel index=0
+ options snd-hda-intel index=0 disable_msi=1

Walla, all working.

(Now, if anyone knows how to either get A) power management or B) stop crashes when ctrl-alt-fx'in I'm in business!)
Old 12-15-2006, 02:54 PM   #5
Registered: Dec 2005
Distribution: Fedora Core
Posts: 55

Original Poster
Rep: Reputation: 15
Ok, so ... it *was* walla, until I tried to use the mic.

Problem 1:
Now I find out the mic doesn't work. My first thought is "Hey! There's no caputre option in kmix/alsamixer!"

There is a Line In slider, and a Microphone slider, but no capture slider.

I've fired up krec and tried to record with both of these, but nothing. Can anyone provide a pointer on how to get this going?

Problem 2:
Also, I tried firing up TeamSpeak with "aoss <pathtoTS>" and I get the error:
ERROR: object '/usr/lib64/' from LD_PRELOAD cannot be preloaded: ignored.
Then I get no sound at all in this app. So does anyone know what the problem with this might be? I *AM* using the 1.0.12 of alsa-oss and the 1.0.13 of alsa because does not have a 1.0.13 version of alsa-oss yet. I don't know if it's a compatibility problem or not, but if it is - I don't get an option here as it doesn't exist!
Old 12-18-2006, 09:31 PM   #6
Registered: Dec 2005
Distribution: Fedora Core
Posts: 55

Original Poster
Rep: Reputation: 15
Ok - problem 1 update: I cranked the input to 100 and ran "arecord output.wav" ... and it turns out it does work - it's just really really quiet. Is there any way that this can be cranked up? I.e. can I change my max db gain (currently 34.5)? Can I get the Mic boost option to show up? How would I do either of these?
Old 12-21-2006, 11:41 AM   #7
Registered: Dec 2005
Distribution: Fedora Core
Posts: 55

Original Poster
Rep: Reputation: 15
Solved both problems last night, and one I didn't even know I had.

1) Low Sound.
Well, I don't know what to say. Using arecord I was getting barely audible sound, but once getting TS running, the sound volume was *PERFECT*. So it's an issue with arecord of some type, which I won't be using so no worries! Hurrah!

2) TeamSpeak.
This one was tricky. After finding info about running TeamSpeak on a 64-bit Gentoo I got to thinking that perhaps I needed 32-bit sound libraries. But of course trying to install alsa-oss from the i386 version conflicted with the x86_64 version (and wasn't available in the x86_64 repository so I didn't want to screw up my files). BUT! I uninstalled the 64-bit alsa-oss and installed the i386 alsa-oss -- and walla! I'm able to start my TeamSpeak *WITH* sound by editing the TeamSpeak file and using "aoss /path/to/TS". Hurrah!

3) Cedega/WoW conflicts with other programs using alsa
I found out after getting this all set up that even though I had alsa selected in Cedega (if you don't know Cedega, bear with me for a potential fix in other areas) it was exclusively locking the sound card. I found out I had to change my alsa device from "hw" to "default". Honestly, I don't know what this does, but it worked like a charm and I have sound everywhere now! Hurrah!

As a side note I did try 1.0.14rc1 to try and fix these issues and all it did was crash my machine over and over again. I had to boot into runlevel 1 and remove it in order to get my machine working. So... 1.0.13 for a while. Wish they'd make it the standard update for FC6.
Old 02-18-2007, 09:26 AM   #8
Registered: Dec 2004
Posts: 83

Rep: Reputation: 15

Ubuntu Edgy.
hp dv2000z
Nvidia soundcard

I download ALSA 1.0.14rc2

EVERYTHING works great.
No independent controls for audiojack and speakers.
plugging in headphones mutes speaker.


No editting files nothing.

C ya guys.

P.s: I installed release *.13 ... and when gnome start sound keeps on repeating the login sound.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Headphone jack not working in new laptop. WhiskeyTangoFoxtrot Linux - Hardware 10 12-24-2006 02:14 AM
Latitude D620 - Headphone Jack Doesn't Work Matir Linux - Hardware 5 09-15-2006 10:25 AM
no sound from speakers or headphone jack in ibm 600e donnyb General 4 03-27-2006 11:37 AM
No sound from headphone jack jefferai Linux - Laptop and Netbook 0 08-21-2004 04:05 PM
Headphone jack on CDROM how get sound out? lugoteehalt Linux - Newbie 2 10-27-2003 10:37 AM > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 08:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration