LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 10-17-2003, 05:56 PM   #16
vivekiyer
Member
 
Registered: Aug 2003
Location: AZ, USA
Distribution: Redhat 9.0
Posts: 45

Rep: Reputation: 15

I compiled the 2.6-test6. Didnt have any compilation problems. I think the reason for your problem could be that you chose the test7. The ACPi patch is out only for the test6 . SO go ahead and choose test6. I did compile in the CPU scaling. I dont know ifit works though.
 
Old 10-19-2003, 01:13 AM   #17
acascianelli
Member
 
Registered: Oct 2002
Location: Michigan
Posts: 71

Original Poster
Rep: Reputation: 15
ok....ill give that a whirl next.

it looks like that www.linuxant.com place does support the broadcom wireless card in linux on the emachines. if i could get that, and some partial acpi working like the processor/voltage stepping that would be awesome
 
Old 10-20-2003, 10:38 PM   #18
acascianelli
Member
 
Registered: Oct 2002
Location: Michigan
Posts: 71

Original Poster
Rep: Reputation: 15
ok....

i finally got the 2.6 kernel compiled and working....acpi seems to be working partially, i can now get the battery status.

also powernow seems to be working also. the battery life says 2:40 minutes which is much longer than the 1:20 it would last on full speed.

sound stopped working though...will work more on this tomorrow at work.

Last edited by acascianelli; 10-20-2003 at 11:28 PM.
 
Old 10-27-2003, 02:12 AM   #19
johnthawk
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Talking Working wireless

eMachines M5130 kernel-2.6.0-test9 - www.linuxant.com "get drivers from windows"
Video Audio Wireless ethernet all work fine,. However, acpi is only at 50% still working on it!
I'm on wireless via Linksys now.

FYI Built kernel from Kernel .org the people.redhat.com/arjanv/2.5 kernels will not work if you are using Fedora(redhat 9.095 etc)
 
Old 10-31-2003, 03:31 AM   #20
adamis
Member
 
Registered: Oct 2003
Posts: 81

Rep: Reputation: 15
I've been trying to get powernow to work for the last three days and have no luck. For some reason Mandrake seems to not think my CPU is capable of performance managment. Any of you guys have any luck?

One curious thing is some how in the midst of all my patching I some how get the laptop to run nice and cool if I unplug it. Funny thing is the cpuinfo still says it is running at 1800mhz.

So, what have you guys figured out? Oh, compiling the 2.6 kernel leaves me with KDE unable to write to the home directory and a whole slew of other errors. Not sure what's up with that.
 
Old 11-01-2003, 08:16 PM   #21
adamis
Member
 
Registered: Oct 2003
Posts: 81

Rep: Reputation: 15
Okay, I'm just about ready to give up on trying to get ACPI to work until the next kernel comes out. I think I narrowed the problem down to ACPI not detecting the processor correctly. Case in point, if I browse the /proc/acpi/processor/CPU0/info I read the following:

processor id: 0
acpi id: 0
bus mastering control: yes
power management: yes
throttling control: no
performance management: no
limit interface: no

The key here is it says "no" for perfomance management. Of course the M5310 uses an athlon moblile processor so it should say yes. Do any of you guys have performance managment as yes with your m5310? If so what distribution are you using?

Also, do you guys have any ideas why ACPI might detect this incorrectly? My thought is perhaps it has something to do with the ALi chipset and it not being fully supported in Linux yet, (just a guess of course)

If any of you guys have gotten ACPI to really work on their M5310 could you post some details on what distribution / kernel / tricks you used...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 10 and Emachines M5310 TK587 SUSE / openSUSE 0 08-23-2005 09:50 AM
SUSE 9.2 and eMachines M5310 Spyder-One Linux - Laptop and Netbook 0 01-20-2005 05:32 PM
Emachines M5310 Suspen jhawk Linux - Laptop and Netbook 4 05-01-2004 09:44 AM
Emachines M5310 3D Acceleration in Linux johnandrhona Linux - Laptop and Netbook 2 03-23-2004 05:56 PM
eMachines M5310 vivekiyer Linux - Laptop and Netbook 31 11-12-2003 03:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 05:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration