LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   eeepc + rtcwake = alarm clock (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/eeepc-rtcwake-%3D-alarm-clock-705321/)

pmate 02-17-2009 06:05 AM

eeepc + rtcwake = alarm clock
 
Hi all,
i wish to turn my eeepc 701 (Gnu/Linux Debian Lenny) into an alarm clock.
So i thought that this worked:
Code:

# rtcwake -s 20 && pm-suspend
but nothing happened...

So i tried whith wakealarm too but got the same result:
eeepc goes on suspend-mode (obviously) but doesn't wake up. It needs that (manually) the power button is pressed to wake up from suspension.

Anyone got some experience on it?

Thanks

ebmi 02-18-2009 02:10 AM

I'm running Debian 5.0, and I was able to put my laptop (dell xps m1330) to sleep for thirty seconds with

Code:

# rtcwake -m mem -s 30
The rtcwake command issues the sleep instruction itself. There is no need to run pm-suspend.

That's a pretty cool command. Thanks for showing it to me.

pmate 02-18-2009 03:59 AM

thanks for your answer,
you're totally right: there's non need to run pm-suspend.
But the problem remains: it goes in suspension and resume not after x seconds but only if i press power button. This happens only in X, in console instead, it doesn't wake up at all. I have to power off...

p.s. happy to have been useful... ;-)

ebmi 02-18-2009 06:06 PM

That's a stinker. What kernel are you running? Is it hand rolled or did you apt-get it?

pmate 02-19-2009 02:30 AM

no it isn't hand rolled, it is the default kernel of debian for eeepc.
Can it be that the problem is in some of the eeepc-acpi-scripts?
Or it can depend on bios?

ebmi 02-19-2009 02:49 AM

Well, to answer your questions, yes and yes. It sounds like your linux isn't listening to acpi events. That could be a scripts or a bios issue. I don't have any experience with an eeepc so I don't think I can offer anything more. Good luck!

geesh 02-19-2009 04:08 PM

I just tried this on an HP DV5020us laptop and it looks like it is a bios limitation. Same here, no wake up.
Tried it on a couple desktops that have a wake time settable in the bios and it works great from a terminal. Looks like it has to be settable in the bios (but you don't need to set it like that) to be function-able.

geesh 02-19-2009 04:15 PM

ok got it working try using the -u option for utc time and not local time , works on every thing i've tried around here so far!

rtcwake -d rtc0 -m mem -s 60 -u -v

pmate 02-21-2009 06:31 PM

no way, even with geesh's suggestions.
At this point i think it's a matter of acpi-scripts.
I will check in these days.
Thanks a lot


All times are GMT -5. The time now is 07:49 PM.