-   Linux - Laptop and Netbook (
-   -   eeepc 701-4g won't boot, bios or ssd? (

lifemagic 08-25-2010 04:11 AM

eeepc 701-4g won't boot, bios or ssd?

I have an eeepc 701 4gb surf. I use native Xandros and sometimes an installed eeebuntu on USB. The last time I used it I was in Xandros on SSD uploading with ftp and got the warning the drive was full, so I deleted some things in /usr I'd mis-saved there. Not sure if this caused the problem.

Next day, booting Xandros just produced a black screen. Doing an F9 restore caused the message Uncompressing Linux... Ok, booting the kernal.' and a flashing cursor, but then it stayed like that.

Trying to boot the previously working eeebuntu on usb (choosing it after pressing esc. on start up), produced the message 'starting up' but then nothing. Starting eeebuntu in recovery mode produced a line of code, the last of which was he last of which was 0.336623] ACPI: Checking for initramfs for custom DSDT' and a cursor after it, but then nothing.

I went to a windows computer and made a new live usb of eeebuntu, but trying to boot it produced a unetbootin screen and flashing cursor but then nothing. (previously the same thing would boot).

I can still get a blue bios screen by pressing F2. Boot booster is off and os installation marked as finished.

I tried the 'battery out and on button for 30 seconds routine' and 'toothpick in the cmos hole' tricks. I also opened up the RAM, made sure I was properly grounded, reseated the ram and touched a screwdriver to the little cmos plates which are like triangles.

So now I'm stuck. Might it be the bios or ssd? If a solution was to run only installed usb's I'd be quite happy, but changing the boot order in bios doesn't do anything.

I don't quite understand. Can it be the bios if it won't boot an os that was previously working? Surely flashing it wouldn't make any difference, though I'll try if the instructions are clear enough. If it's the SSD, why won't it boot a live usb? When doing so, I assumed the SSD wasn't accessed at all, or is that wrong?

Thanks for any ideas.

yooy 08-25-2010 05:54 AM


why won't it boot a live usb?
are you sure that usb booted before and that it would boot on other computer (with similar hardware)
you can try installing fresh usb with unetbootin


got the warning the drive was full, so I deleted some things in /usr I'd mis-saved there. Not sure if this caused the problem.
can you put that things back?:)

lifemagic 08-26-2010 05:06 AM

Yep. It booted before, used it loads of times, so the os on the usb and ssd stopped booting at the same moment.

In /usr, I only deleted files I recognised as mine eg. university essays etc. that I'd missaved there. It's possible I mis-deleted something, I don't know.

I'm using cybercafes while the eee is down, they won't let me do a live boot.

lifemagic 08-29-2010 04:52 AM

OK, I'm still working out the best I can. I got as far as realising I can burn a system rescue image on usb and try that, which I've just done and am off to try now.

rokytnji 08-29-2010 09:59 PM

I own a 701SD. Sounds like you covered all the bases as far as cmos reset, etc....

It definitely is a mystery why a live pendrive that booted before won't now. It should still boot even with a dead SSD drive. Thats my understanding anyhows.

I would get away from trying the Ubuntus. But that is just me. I would try making a Live Puppeee Celeron Kernel Live Usb. Puppeee seems to boot up on any EEEPC.

I run AntiX 8.5 on my Asus EEEP 701SD and Asus EEEPC 900. Got tired of trying to upkeep Xandros Repositories as they fell by the wayside. What gets me is that you can access bios boot order (Esc key). Can you also go directly into bios and reset it back to default settings.

F9 restore not working makes it sound like internal SSD is borked.
Thats where Xandros puts the recovery partition. Still should not effect USB boot though. While is system rescue. See if internal SSD shows that it is full still even though you deleted some stuff.

Improper shutdowns on SSD drives like the cheap ones in Asus 701
Phison drives cause excessive writes to said drives which fills them back up again to full status. I have seen this with SD external Flash, Pendrive Flash, and SSD Flash which kills the boot
process. I usually used Gparted like in Puppeee on a flash drive to do a check on full drive which would usually fix the drive again. Hard to say what is going on with you from my neck of the woods. If Bios works. The pendrive should boot (unless it is corrupted also or one of those pendrives that don't like to boot)

Recovery Xandros Isos in case you want/need them

Good Luck with it and Happy Trais, Rok

lifemagic 08-31-2010 05:10 AM

Thank you.

I did try a puppy linux, as well as Damned small linux, and both on another usb, and no joy.

The cybercafe won't let me try the live usb.

I am getting somewhere though. I made a system recovery cd on usb, couldn't boot, but did run memtest and it said it was ok. I posted a question on the forum over there.

Also I found out about ultimate boot cd, and will be trying that later. Advice I'm getting elsewhere is to use this recovery to wipe the sdd and then try a live boot. It sounds drastic... but it's on a non-functioning computer I'll be trying this I suppose.

I will keep the thread posted.

If I get this sorted, it's going to make one hell of a wiki post somewhere!

lifemagic 09-03-2010 08:14 AM


Yes, I worked out that there isn't supposed to be an IDE slave detected in the BIOS.

I kept playing with UBDC last night, and worked on the 'hard disk (and sdd?) tools.


This worked, and picked up the drive 'Siliconmotion SM223AC' which I presume is my ssd. It did some kind of scan, showing a large grey block of ... whatever it scanned, all ,10ms. It all looked OK (to the untrained eye).


Analyise =

Disk 81 4001Mb/3815MB - CHS 48625563

1 - P Linux 0 1 1 299 25463 [system]
2 - P Linux 3000 1 *** *** [user]
3 - P Fat32 LBA 484 01 ****** [BIOS]
4 - P EFI (Fat - 12/16/32) **********
No partition is bootable

(I'm using stars to indicate various numbers I didn't record)


My next steps:

1 - get ubcd version 503 for gparted, and try and repair disk problems there.
2 - try to restore the mbr with testdisk
3 - boot and nuke the ssd and try the live eeebuntu again
4 - flash bios
5 - brick... but it won't come to that. The tests say I'm OK. I'm gonna get through this.

rokytnji 09-03-2010 02:58 PM


No partition is bootable
Sounds like main problem on internal SSD 4 gig drive. Doing the chkdisk in gparted in ubcd should correct any errors on disk. Then just do a linux reinstall via pendrive.

If wiping the drive with Dariks boot and Nuke, Do another chkdisk in gparted before reinstall for safety and good measure.

Edit: Don't know if chkdisk will even work after darik boot and nuke because drive will be zeroed out and so no files to fix. OOPS.

lifemagic 09-04-2010 06:31 AM


I downloaded ubcd 503, and got gparted to work. It's in the 'parted magic' suite, which will only run when I run it from an option, safe boot > no acpi, which is strange as acpi is coming up again.

It brought up sda1 and I let it check and repair. I made the sector bootable. But there was no difference when trying to boot from it.

From the same suitue of programs, I used a file manager, and could access the entire directory structure of sda1.

Then I used testdisk. This is where I went wrong. The first drive it listed is now marked as bootable. I went to another option to 'write a new copy of the MBR code to first sector'. It did so. Now when I try to boot from sda1, it shows 1234F: with a cursor, and pressing enter repeats the message. Yipee, I lost my MBR!

Then I had a sudden thought. Now I can access sda1, why not move the boot and grub menu to ubcd-usb, unplug everything and try to boot eeebuntu-usb alone; this would have the same effect as nuking the ssd as there would be no boot info anywhere to confuse it. I tried and it would only let me move some folders, which I did. Then I renamed /boot (on sda1) to /NOTboot.

Then I unplugged everything except eeebuntu-usb, tried to boot from it, same as before, a unetbootin menu that keeps booting to itself.

So... I've probably lost native Xandros as I messed up the MBR.

The upside is, that little 'parted magic' suitue is a mini-operating system. I have a pdf reader and image viewer and can type and save to usb with leafpad, and that's going to save me a load of money in cybercafes as I'm using the eee for studying courses I'm taking at the moment.

Right now, I'm getting Knoppix from a torrent to see if that works.

The main goal at this point is to put the new Xandros iso (which I have) or eeebuntu on the ssd, no idea what to do as I still can't boot a live usb and, as far as I understand, nuking the drive will make no difference.

rokytnji 09-05-2010 07:51 AM

Still watching to see how you fare. I'm off for a 2 day motorcycle trip.

michaelk 09-05-2010 09:27 AM

FYI linux does not use the boot flag.

FWIW the disk has a GPT format and not a standard MBR. Make sure any tools you use are the latest and support GPT. If you have already wiped the disk then it does not matter.

lifemagic 09-06-2010 06:32 AM

Not wiped yet, but am trying to get the courage for a bios update (and knowledge).

Enjoy the bike trip!

lifemagic 09-08-2010 08:05 AM

I updated the BIOS. I put a FAT16 formatted 2gb drive in with bios 1302 renamed as 701.rom. It found it, said it was erasing, then 'the BIOS' update is finished. Please press the power button to shut down the system.

I started it up again, pressed F2 for the BIOS. The new version is shown, with the ssd detected, os set to finished, boot priority set to removable media as the first, ssd as second, so I tried to boot eeebuntu on usb again... but it was the same, booting repeatedly into a unetbootin menu with the options default and help.

I booted eeebuntu again, got the same menu but chose help. There was a screen of code as far as:

0.329721] ACPI Core revision 20080926
0.337021] ACPI: Checking initramfs for custom DIST

which is the same as before the BIOS update.

However, UBCD still boots. I went to 'super grub disc' and pressed c for a command line to try and repair the mbr on sda1. At the command line, I typed:

find /boot/grub/stage1

and got the output:


I input:

root (fd0)

and it output:

'filesystem is fat, using whole disk'

So... back where I started.

rokytnji 09-08-2010 09:56 AM

Try this. With the eeeubuntu pendrive inserted. UBCD pendrive pulled.

On the eeebuntu grub screen. just type in

Then pick default from the menu.


However, UBCD still boots. I went to 'super grub disc' and pressed c for a command line to try and repair the mbr on sda1. At the command line, I typed:

find /boot/grub/stage1

and got the output:


I input:

root (fd0)

and it output:

'filesystem is fat, using whole disk'

So... back where I started.
Not sure what is going on here. Super Grub says the /boot/grub/stage1 is on a floppy drive "fd0".

That is why when you type


root (fd0)
nothing happens.

You are the only person I have seen so far on the net that can't boot a pendrive of Linux. But can boot a pendrive made with UBCD. It;s a Wonderment.

Internal Drive status has no bearing on how bios and a linux bootable pendrive inter act as far as I know. I've booted and ran Puppy CDs on a computer with no internal Hardrive as well as other Linux Cds.

Yesterday I made a pendrive of Puppeee 4.4 Beta Testing (Celeron Version). Works real well on my 900.
I have a frugal install made on Pendrive with persistence with Java,Flash,devx (version of build-essentials for puppy linux), Firefox 3.6.8 with flash, plus a ton of other apps that come with Puppeee distro.

Leaving you with download link (bottom one with puppeee4.4-beta1-cel..> 04-Sep-2010 17:05 130M is for a Celeron Asus like your 701)

Install instructions. They work fine for me.

where the .sfs files are at for java and firefox and opera for Puppeee

How to install a sfs file in Puppeee


Download the SFS file and put in in /mnt/home (this is assuming you've done a frugal install). Go to Menu->System->BootManager and click Choose Which SFS Files to Load at Bootup. Select the SFS file you want to load and click Add. Then reboot.

How do dual boot Puppy with Xandros installed (or any Linux distro ) inside internal SSD


How to Dual-Boot Xandros and Puppeee without installing a New Bootloader
You can add Puppeee to the Menu that comes up on Xandros when you press F9.

This tutorial was done on my 4G, it might be slightly different if you have a different model of EeePC.

First you need to boot Puppeee from a USB stick and find a partition with some free space on it. The bare minimum space you'll need is about 170MB. To see the free space, start Partview from the Filesystem menu.


On some slow SSDs, the usb drive may load first, and then your hard drive will be sdb and the usb drive will be sda - you can tell which is which by looking at the desktop icons.

In my case, sda2 has the most space, so I will put Puppeee there. Click on the sda2 drive icon and create a new directory called puppeee. Then you need to copy four files from the usb stick into the new directory. The four you need are vmlinuz, initrd.gz, eee-xxx.sfs, and zexxxxxx.sfs


Now you need to locate the grub configuration file called Menu.lst. On the 4G it's on sda1, in /boot/grub. You will edit this file and add a new entry for Puppeee.


Change the line that says timeout=0 to timeout=2. This will make it a lot easier to bring up the menu when booting.

Now add a new menu entry for Puppeee like the one shown in the screenshot. You can see I used root (0x80,1), because I put the Puppeee files on sda2. The number after the comma corresponds to the partition number, 0=sda1, 1=sda2, 2=sda3, etc.

You've got to tell it where the kernel (vmlinuz) and initrd.gz are. I put them in a directory called puppeee, so my menu entry reflects that. I also added a parameters to speed up booting. Nousbwait tells Puppeee not to wait to boot until usb drives have been loaded - this is fine because Puppeee won't be booting of a usb drive now that you've copied it to the hard drive. Psubdir tells Puppeee where to look for the SFS files - it can boot without that, but it takes longer because it has to search. Pmedia tells Puppeee what kind of drive you have - an SSD should be ataflash and a regular drive should be atahd; you really only need to specify it if you have an SSD to make sure it uses Pupmode 13 which is kinder to flash media.

Now save the menu.lst file, shut down the EeePc, say no when it asks if you want to save. Remove the usb drive. Start the EeePc and press F9 a few times until you get a menu. Select Puppeee from the menu and with any luck, Puppeee will boot, and you'll be able to create a save file on the next reboot.

Note: you can use a similar method to dual boot Puppeee with any Linux that's already installed. You just need to locate the grub configuration and figure out how to create a new menu entry.

Comments (0) Added by jemimah May 23, 2010 (3:29PM)
Bug with Tray Icons in RC2
There is a problem with the bluetooth applet in RC2 that may prevent the tray apps from loading correctly in IceWM. You can fix it by going to /root/Startup and renaming bluetooth-applet to zbluetooth-applet - this will cause it to load last and seems to resolve the issue. It should be fixed in RC3.

Comments (0) Added by jemimah May 20, 2010 (10:09PM)
The Easy Way to do a Frugal Install with Puppeee as the only OS


The new usb installer can also be used successfully on hard drives.

This howto explains one way to install Puppeee, there are many other ways. This method is ideal for a small SSD.

First you need to create a bootable USB stick or card by following the directions on the Download page. Then use your bootable stick to boot Puppeee, selecting the appropriate settings for your timezone and keyboard.

You should see your drives show up on the desktop. Make sure your hard drive is not mounted and start Gparted from the System Menu. For small SSDs I like to consolidate to just one partition - to do this, delete the existing partitions, and create a new partition that fills the whole disk. Warning: this will delete all data you had on the hard disk. This also removes the option of doing an F9 restore. You'll need the CD to a restore after performing this operation. You need to format it with a FAT32 filesystem for this install method to work. As of RC6, you can choose to format with FAT32, EXT2, or EXT3 filesysyems. Ext2 is recommended for SSDs, Ext3 for regular hard drives. Once you've created your new partition, save the changes and quit Gparted.

This is what my 4G's hard disk looked like orginally

This is what it looks like right before I apply the changes

Now your old partitions will disappear from the desktop and the new one will appear. Mount the new drive and copy all the files from your USB boot stick to the new drive. Go into the boot directory on the new drive and click on to make the drive bootable. (Exactly the same way you created the bootable usb stick)

Now shutdown the EeePC. When it asks if you want to save, say no. Remove the usb stick and start the EeePC again. With any luck, you will see the Puppeee boot menu. Pick "Boot Puppeee" and Puppeee will start. Select the settings for your timezone and keyboard and X windows again.

Once the desktop loads, you are going to reboot so you can create a save file. When it asks what kind of save file you want to create, choose "Save to a File", and select your hard drive as the location to save. I don't recommend using "Save to Partition", as it is less flexible and not SSD friendly.

Start Puppeee again and let it configure your new Save file. If you copied additional SFS packages to your hard drive, such as Firefox, the DevX compiling environment, or Open Office, it will now ask you if you'd like to load those. Select the ones you want and reboot one last time.

You now have Puppeee installed and configured.

If you have an SSD, you should see a Save button on your desktop; this is how you know that Puppeee recognized the SSD and is using Pupmode 13 to minimize writes to disk. If you don't get a Save button, please contact me - the auto-detection feature is new and may need a little debugging.
I can say the save button is working in the new 4.4 release.

That is it from me for today. Have some catching up with business after my trip.

Happy Trails, Rok

Big Edit: Just saw your thread at EeeUser Forum. You say there


Hmmmm. I registered for my course today (doing an English diploma); I need to read pdf's all day and type, and at least I can do that in Parted Magic. It could be worse.
So parted magic Iso on pendrive boots also? That is Linux on a pendrive.
Something is terribly wrong with the way you are making your eeebuntu pendrive if parted magic boots but eeebuntu won't.

lifemagic 09-09-2010 08:47 AM


Nice to have you back.

Parted magic is within UBCD; it doesn't boot independently. I get the usual UBCD menu, choose parted magic, then choose 'safe boot, no acpi' and it works. Yes, it's a mini linux, kind of. But nothing else boots. Of course, I tried Knoppix live usb with a noacpi option, but that didn't work.

I'll try the idea with the grub menu on eeebuntu when I get home.

I'm thinking, considering everything I've tried, that some kind of information on the ssd is confusing the boot process, so just nuking ssd could be best. If it didn't work, I'd still have parted magic, and be done with it.

All times are GMT -5. The time now is 08:42 AM.